<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#" class="no-js"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width,initial-scale=1.0"><link type="text/css" media="all" href="https://digbr.com/wp-content/cache/autoptimize/css/autoptimize_a68a6fdb380ec0f01599d53d16ea2f89.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://digbr.com/wp-content/cache/autoptimize/css/autoptimize_c909164a47191bbbc08b3eaf00494b8d.css" rel="stylesheet" /><link type="text/css" media="only screen and (max-width: 768px)" href="https://digbr.com/wp-content/cache/autoptimize/css/autoptimize_cfc7e39d708c2a6d0ed80d0180ecdb98.css" rel="stylesheet" /><title>Only 27 days until LSU football returns&#8230; here&#8217;s what we know so far &#8211; Dig Baton Rouge</title><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Dig Baton Rouge &raquo; Feed" href="https://digbr.com/feed/" /><link rel="alternate" type="text/calendar" title="Dig Baton Rouge &raquo; iCal Feed" href="https://digbr.com/events/?ical=1" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/digbr.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='gridlove-fonts-css'  href='https://fonts.googleapis.com/css?family=Cabin%3A400%2C700%7CLato%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;ver=1.4.2' type='text/css' media='all' /><link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A700%2C400%2C400i%7CRoboto%3A700%2C400&#038;ver=4.9.8' type='text/css' media='screen' /><link rel='stylesheet' id='mailchimp-for-wp-css'  href='https://digbr.com/wp-content/plugins/mailchimp-for-wp-pro/assets/css/css.php?checkbox=1&#038;ver=1.98.7' type='text/css' media='all' /> <script type='text/javascript'>var tribe_events_linked_posts = {"post_types":{"tribe_venue":"venue","tribe_organizer":"organizer"}};</script> <script type='text/javascript' src='https://digbr.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript'>var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/27-days-until-lsu-football-returns\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View Cart","cart_url":"https:\/\/digbr.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};</script> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/arrive/2.4.1/arrive.min.js?ver=2.4.1'></script> <script type='text/javascript'>var tribe_this_week = {"ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php"};</script> <link rel='https://api.w.org/' href='https://digbr.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://digbr.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://digbr.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Things to do: Monday' href='https://digbr.com/things-to-do-monday-20/' /><link rel="canonical" href="https://digbr.com/27-days-until-lsu-football-returns/" /><link rel="alternate" type="application/json+oembed" href="https://digbr.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdigbr.com%2F27-days-until-lsu-football-returns%2F" /><link rel="alternate" type="text/xml+oembed" href="https://digbr.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdigbr.com%2F27-days-until-lsu-football-returns%2F&#038;format=xml" /><meta property="fb:app_id" content="713095298769737" />  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MW6NQMQ');</script>  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-21029509-1', 'auto');
  ga('send', 'pageview');</script><script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":74208,"post_name":"27-days-until-lsu-football-returns","post_title":"Only 27 days until LSU football returns... here's what we know so far","post_type":"post","post_author":"10000239","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":6,"name":"Sports","slug":"sports","term_group":0,"term_taxonomy_id":6,"taxonomy":"category","description":"","parent":0,"count":597,"filter":"raw","cat_ID":6,"category_count":597,"category_description":"","cat_name":"Sports","category_nicename":"sports","category_parent":0}]; _mmunch['postTags'] = [{"term_id":585,"name":"no-comments","slug":"no-comments","term_group":0,"term_taxonomy_id":585,"taxonomy":"post_tag","description":"","parent":0,"count":25,"filter":"raw"},{"term_id":457,"name":"NOW","slug":"now","term_group":0,"term_taxonomy_id":457,"taxonomy":"post_tag","description":"For homepage block","parent":0,"count":640,"filter":"raw"}]; _mmunch['postAuthor'] = {"name":"","ID":""};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="86056" async></script> <script type="text/javascript">jQuery(document).ready(function() {
				// CUSTOM AJAX CONTENT LOADING FUNCTION
				var ajaxRevslider = function(obj) {
				
					// obj.type : Post Type
					// obj.id : ID of Content to Load
					// obj.aspectratio : The Aspect Ratio of the Container / Media
					// obj.selector : The Container Selector where the Content of Ajax will be injected. It is done via the Essential Grid on Return of Content
					
					var content = "";

					data = {};
					
					data.action = 'revslider_ajax_call_front';
					data.client_action = 'get_slider_html';
					data.token = 'a3d0896356';
					data.type = obj.type;
					data.id = obj.id;
					data.aspectratio = obj.aspectratio;
					
					// SYNC AJAX REQUEST
					jQuery.ajax({
						type:"post",
						url:"https://digbr.com/wp-admin/admin-ajax.php",
						dataType: 'json',
						data:data,
						async:false,
						success: function(ret, textStatus, XMLHttpRequest) {
							if(ret.success == true)
								content = ret.data;								
						},
						error: function(e) {
							console.log(e);
						}
					});
					
					 // FIRST RETURN THE CONTENT WHEN IT IS LOADED !!
					 return content;						 
				};
				
				// CUSTOM AJAX FUNCTION TO REMOVE THE SLIDER
				var ajaxRemoveRevslider = function(obj) {
					return jQuery(obj.selector+" .rev_slider").revkill();
				};

				// EXTEND THE AJAX CONTENT LOADING TYPES WITH TYPE AND FUNCTION
				var extendessential = setInterval(function() {
					if (jQuery.fn.tpessential != undefined) {
						clearInterval(extendessential);
						if(typeof(jQuery.fn.tpessential.defaults) !== 'undefined') {
							jQuery.fn.tpessential.defaults.ajaxTypes.push({type:"revslider",func:ajaxRevslider,killfunc:ajaxRemoveRevslider,openAnimationSpeed:0.3});   
							// type:  Name of the Post to load via Ajax into the Essential Grid Ajax Container
							// func: the Function Name which is Called once the Item with the Post Type has been clicked
							// killfunc: function to kill in case the Ajax Window going to be removed (before Remove function !
							// openAnimationSpeed: how quick the Ajax Content window should be animated (default is 0.3)
						}
					}
				},30);
			});</script> <script type='text/javascript'>var taqyeem = {"ajaxurl":"https://digbr.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};</script> <meta name="generator" content="EventON 2.5.5" /><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/> <!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://digbr.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://digbr.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><meta name="wpsso:mark:begin" content="wpsso meta tags begin"/><meta name="generator" content="WPSSO 3.45.3/G"/><link rel="shortlink" href="https://digbr.com/?p=74208"/><meta property="og:url" content="https://digbr.com/27-days-until-lsu-football-returns/"/><meta property="og:type" content="article"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="Dig Baton Rouge"/><meta property="og:title" content="Only 27 days until LSU football returns... here&rsquo;s what we know so far"/><meta property="og:description" content="By JAMES MORAN | Tiger Rag Associate Editor &nbsp; This time last year, Jerry Sullivan was an analyst who had to filter his technical expertise through other coaches who would then impart the wisdom to players. Analysts aren&rsquo;t able to even speak to players about anything football... #nocomments #now"/><meta property="og:image" content="https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-600x315.jpg"/><meta property="og:image:width" content="600"/><meta property="og:image:height" content="315"/><meta property="article:published_time" content="2018-08-06T16:50:02+00:00"/><meta property="article:modified_time" content="2018-08-06T17:03:24+00:00"/><meta property="article:tag" content="no-comments"/><meta property="article:tag" content="now"/><meta property="og:updated_time" content="2018-08-06T17:03:24+00:00"/><meta name="weibo:article:create_at" content="2018-08-06 16:50:02"/><meta name="weibo:article:update_at" content="2018-08-06 17:03:24"/><meta name="twitter:domain" content="digbr.com"/><meta name="twitter:title" content="Only 27 days until LSU football returns... here&rsquo;s what we know so far"/><meta name="twitter:description" content="By JAMES MORAN | Tiger Rag Associate Editor &nbsp; This time last year, Jerry Sullivan was an analyst who had to filter his technical expertise through other coaches who would then... #nocomments #now"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-800x450.jpg"/><link itemprop="url" href="https://digbr.com/27-days-until-lsu-football-returns/"/><meta itemprop="name" content="Only 27 days until LSU football returns... here&rsquo;s what we know so far"/><meta itemprop="description" content="By JAMES MORAN | Tiger Rag Associate Editor &nbsp; This time last year, Jerry Sullivan was an analyst who had to filter his technical expertise through other coaches who would then impart the wisdom to players. Analysts aren&rsquo;t able to even speak to..."/><meta itemprop="datePublished" content="2018-08-06T16:50:02+00:00"/><meta itemprop="dateModified" content="2018-08-06T17:03:24+00:00"/><meta name="author" content="James Moran"/><meta name="description" content="By JAMES MORAN | Tiger Rag Associate Editor &nbsp; This time last year, Jerry Sullivan was an analyst who had to filter his technical expertise through other..."/> <noscript itemprop="author" itemscope itemtype="https://schema.org/Person"><link itemprop="url" href="https://www.tigerrag.com/"/><meta itemprop="name" content="James Moran"/><meta itemprop="description" content="Associate Editor, Tiger Rag"/> </noscript> <noscript itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><link itemprop="url" href="https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-800x450.jpg"/><meta itemprop="width" content="800"/><meta itemprop="height" content="450"/> </noscript><meta name="wpsso:mark:end" content="wpsso meta tags end"/> <noscript><style type="text/css">.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head><body class="post-template-default single single-post postid-74208 single-format-standard unknown wpb-js-composer js-comp-ver-4.11.2.1 vc_responsive"><header id="header" class="gridlove-site-header hidden-md-down  gridlove-header-shadow"><div class="gridlove-header-wrapper"><div class="gridlove-header-1 gridlove-header-middle container"><div class="gridlove-slot-l"><div class="gridlove-site-branding  "> <span class="site-title h1"><a href="https://digbr.com/" rel="home"><img class="gridlove-logo" src="https://digbr.com/wp-content/uploads/2018/02/DIG-Logo-white-sm.png" alt="Dig Baton Rouge"></a></span></div></div><div class="gridlove-slot-r"><nav class="gridlove-main-navigation"><ul id="menu-main-menu" class="gridlove-main-nav gridlove-menu"><li id="menu-item-6977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6977"><a href="https://digbr.com/category/news/">NEWS</a><ul class="sub-menu"><li id="menu-item-66360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66360"><a href="https://digbr.com/category/news/crime/">Crime</a></li><li id="menu-item-66359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66359"><a href="https://digbr.com/category/news/biz/">Business</a></li><li id="menu-item-7141" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7141"><a href="https://digbr.com/category/news/opinion/">Opinion</a></li><li id="menu-item-6979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6979"><a href="https://digbr.com/category/news/campus/">LSU</a></li></ul></li><li id="menu-item-7306" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7306"><a href="https://digbr.com/category/leisure/">LEISURE</a><ul class="sub-menu"><li id="menu-item-66358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66358"><a href="https://digbr.com/the-lineup/">Things to do</a></li><li id="menu-item-66393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66393"><a href="https://digbr.com/food-drink/">Food &#038; Drink</a></li><li id="menu-item-6969" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6969"><a href="https://digbr.com/category/leisure/arts-culture/">Arts &#038; Culture</a></li><li id="menu-item-7316" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7316"><a href="https://digbr.com/category/sports/">Sports</a></li><li id="menu-item-6972" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6972"><a href="https://digbr.com/category/leisure/music/">Music</a></li><li id="menu-item-31878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31878"><a href="https://digbr.com/category/leisure/fitness/">Health &#038; Fitness</a></li><li id="menu-item-73314" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-73314"><a href="https://digbr.com/the-six/">THE SIX</a></li></ul></li><li id="menu-item-47579" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47579"><a href="#">FUN STUFF!</a><ul class="sub-menu"><li id="menu-item-72249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-72249"><a href="https://digbr.com/category/leisure/perk/">Perks</a></li><li id="menu-item-47583" class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-47583"><a href="https://digbr.com/product-category/ticketed-event/">DIG Events</a></li><li id="menu-item-7155" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7155"><a href="https://digbr.com/category/galleries/">Galleries</a></li></ul></li><li id="menu-item-66741" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66741"><a href="https://digbr.com/category/magazine/">MAGAZINE</a></li><li id="menu-item-71994" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71994"><a href="https://digbr.com/brag18/">BRAG18</a></li></ul></nav><ul class="gridlove-actions gridlove-menu"><li class="gridlove-actions-button gridlove-action-search"> <span> <i class="fa fa-search"></i> </span><ul class="sub-menu"><li><form class="gridlove-search-form" action="https://digbr.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form></li></ul></li><li class="gridlove-actions-button"> <span class="gridlove-sidebar-action"> <i class="fa fa-bars"></i> </span></li></ul></div></div></div><div id="gridlove-header-sticky" class="gridlove-header-sticky"><div class="container"><div class="gridlove-slot-l"><div class="gridlove-site-branding mini"> <span class="site-title h1"><a href="https://digbr.com/" rel="home"><img class="gridlove-logo-mini" src="https://digbr.com/wp-content/uploads/2018/02/DIG-Logo-white-mini2.png" alt="Dig Baton Rouge"></a></span></div></div><div class="gridlove-slot-r"><nav class="gridlove-main-navigation"><ul id="menu-main-menu-1" class="gridlove-main-nav gridlove-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6977"><a href="https://digbr.com/category/news/">NEWS</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66360"><a href="https://digbr.com/category/news/crime/">Crime</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66359"><a href="https://digbr.com/category/news/biz/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7141"><a href="https://digbr.com/category/news/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6979"><a href="https://digbr.com/category/news/campus/">LSU</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7306"><a href="https://digbr.com/category/leisure/">LEISURE</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66358"><a href="https://digbr.com/the-lineup/">Things to do</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66393"><a href="https://digbr.com/food-drink/">Food &#038; Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6969"><a href="https://digbr.com/category/leisure/arts-culture/">Arts &#038; Culture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7316"><a href="https://digbr.com/category/sports/">Sports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6972"><a href="https://digbr.com/category/leisure/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31878"><a href="https://digbr.com/category/leisure/fitness/">Health &#038; Fitness</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-73314"><a href="https://digbr.com/the-six/">THE SIX</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47579"><a href="#">FUN STUFF!</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-72249"><a href="https://digbr.com/category/leisure/perk/">Perks</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-47583"><a href="https://digbr.com/product-category/ticketed-event/">DIG Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7155"><a href="https://digbr.com/category/galleries/">Galleries</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66741"><a href="https://digbr.com/category/magazine/">MAGAZINE</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71994"><a href="https://digbr.com/brag18/">BRAG18</a></li></ul></nav><ul class="gridlove-actions gridlove-menu"><li class="gridlove-actions-button gridlove-action-search"> <span> <i class="fa fa-search"></i> </span><ul class="sub-menu"><li><form class="gridlove-search-form" action="https://digbr.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form></li></ul></li><li class="gridlove-actions-button"> <span class="gridlove-sidebar-action"> <i class="fa fa-bars"></i> </span></li></ul></div></div></div></header><div id="gridlove-header-responsive" class="gridlove-header-responsive hidden-lg-up"><div class="container"><div class="gridlove-site-branding mini"> <span class="site-title h1"><a href="https://digbr.com/" rel="home"><img class="gridlove-logo-mini" src="https://digbr.com/wp-content/uploads/2018/02/DIG-Logo-white-mini2.png" alt="Dig Baton Rouge"></a></span></div><ul class="gridlove-actions gridlove-menu"><li class="gridlove-actions-button gridlove-action-search"> <span> <i class="fa fa-search"></i> </span><ul class="sub-menu"><li><form class="gridlove-search-form" action="https://digbr.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form></li></ul></li><li class="gridlove-actions-button"> <span class="gridlove-sidebar-action"> <i class="fa fa-bars"></i> </span></li></ul></div></div><div id="content" class="gridlove-site-content container gridlove-sidebar-right"><div class="row"><div class="gridlove-share-wrapper"><div class="gridlove-share gridlove-box gridlove-sticky-share"> <a href="javascript:void(0);" class="gridlove-facebook gridlove-share-item" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fdigbr.com%2F27-days-until-lsu-football-returns%2F&amp;t=Only+27+days+until+LSU+football+returns%26%238230%3B+here%26%238217%3Bs+what+we+know+so+far"><i class="fa fa-facebook"></i></a> <a href="javascript:void(0);" class="gridlove-twitter gridlove-share-item" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fdigbr.com%2F27-days-until-lsu-football-returns%2F&amp;text=Only+27+days+until+LSU+football+returns%26%238230%3B+here%26%238217%3Bs+what+we+know+so+far"><i class="fa fa-twitter"></i></a> <a href="/cdn-cgi/l/email-protection#6c531f190e06090f185123020015475e5b47080d151f47190218050047203f39470a0303180e0d0000471e0918191e021f495e5a495e5f545e5f5c495f2e4704091e09495e5a495e5f545e5d5b495f2e1f471b040d18471b09470702031b471f03470a0d1e4a0d011c570e030815510418181c1f495f2d495e2a495e2a08050b0e1e420f0301495e2a5e5b41080d151f41190218050041001f19410a0303180e0d0000411e0918191e021f495e2a" class="gridlove-mailto"><i class="fa fa-envelope-o"></i></a></div></div><div class="gridlove-content gridlove-single-layout-1"><article id="post-74208" class="gridlove-box box-vm post-74208 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-no-comments tag-now"><div class="entry-image"> <img width="740" height="416" src="https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-740x416.jpg" class="attachment-gridlove-single size-gridlove-single wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-740x416.jpg 740w, https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-300x169.jpg 300w, https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-768x432.jpg 768w, https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-1024x576.jpg 1024w, https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-150x84.jpg 150w, https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-600x338.jpg 600w, https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-1032x581.jpg 1032w, https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-800x450.jpg 800w, https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU.jpg 1200w" sizes="(max-width: 740px) 100vw, 740px" data-wp-pid="74209" nopin="nopin" /></div><div class="box-inner-p-bigger box-single"><div class="entry-header"><div class="entry-category"> <a href="https://digbr.com/category/sports/" class="gridlove-cat gridlove-cat-6">Sports</a></div><h1 class="entry-title">Only 27 days until LSU football returns&#8230; here&#8217;s what we know so far</h1><div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="https://digbr.com/author/jamesmoran/"><img src="https://digbr.com/wp-content/uploads/2018/02/TIGER-RAG-LOGO1-150x150.png" width="24" height="24" alt="James Moran" class="avatar avatar-24 wp-user-avatar wp-user-avatar-24 alignnone photo" /> James Moran</a></span></span></div><div class="meta-item meta-date"><span class="updated">10 hours ago</span></div></div></div><div class="entry-content"><div class="wpsso-schema-image-for-pinterest" style="display:none;"> <img src="https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-800x450.jpg" width="0" height="0" style="width:0;height:0;" data-pin-description="By JAMES MORAN | Tiger Rag Associate Editor &nbsp; This time last year, Jerry Sullivan was an analyst who had to filter his technical expertise through other coaches who would then impart the wisdom to players. Analysts aren&rsquo;t able to even speak to..."/></div><div class='mailmunch-forms-before-post' style='display: none !important;'></div><p><strong><span style="font-size: 10pt;"><img class="size-full wp-image-69398 alignleft" src="https://digbr.com/wp-content/uploads/2018/01/TW-logo-2.jpg" alt="" width="92" height="30" data-wp-pid="69398" /></span></strong></p><p><strong><span style="font-size: 10pt;">By JAMES MORAN | Tiger Rag Associate Editor</span></strong></p><p>&nbsp;</p><p>This time last year, Jerry Sullivan was an analyst who had to filter his technical expertise through other coaches who would then impart the wisdom to players. Analysts aren’t able to even speak to players about anything football related, per NCAA rules.</p><p>Now a full-fledged assistant coach, the long-time NFL wide receivers coach is spending his August drilling LSU’s large assembly of unproven-yet-talented pass catchers on the finer points of route running.</p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div><p>And as those receivers have found through two days of practice, Sullivan is far more concerned about proper technique than he is about the results.</p><div class="su-button-center"><a href="http://www.tigerrag.com/fall-camp-report-day-two/" class="su-button su-button-style-soft su-button-wide" style="color:#FFFFFF;background-color:#460eb5;border-color:#380b91;border-radius:0px;-moz-border-radius:0px;-webkit-border-radius:0px" target="_self"><span style="color:#FFFFFF;padding:7px 20px;font-size:16px;line-height:24px;border-color:#7e56cb;border-radius:0px;-moz-border-radius:0px;-webkit-border-radius:0px;text-shadow:none;-moz-text-shadow:none;-webkit-text-shadow:none"><i class="fa fa-paw" style="font-size:16px;color:#FFFFFF"></i> Read More and Comment</span></a></div><p><em>Image: Tiger Rag</em></p><p>&nbsp;</p><div class='mailmunch-forms-after-post' style='display: none !important;'></div></div><div class="gridlove-author"><div class="row"><div class="col-lg-2 col-md-2 col-sm-5"> <img src="https://digbr.com/wp-content/uploads/2018/02/TIGER-RAG-LOGO1-150x150.png" width="100" height="100" alt="James Moran" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 alignnone photo" /></div><div class="col-lg-10 col-md-10 col-sm-12"><h4>James Moran</h4><div class="gridlove-author-desc"><p>Associate Editor, Tiger Rag</p></div><div class="gridlove-author-links"> <a href="https://digbr.com/author/jamesmoran/" class="gridlove-pill pill-large">View all posts</a><a href="http://www.tigerrag.com/" target="_blank" class="gridlove-sl-item fa fa-link"></a></div></div></div></div></div></article><div class="gridlove-related"><div class="gridlove-module"><div class="module-header"><div class="module-title"><h4 class="h2">You may also like</h2></div></div><div class="row"><div class="col-lg-12 col-md-12 col-sm-12"><article class="gridlove-post gridlove-post-b gridlove-box  post-74176 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-no-comments tag-now"><div class="entry-image"> <a href="https://digbr.com/lsu-ranked-24-in-preseason-poll/" title="LSU ranked No. 24 in Preseason Poll"><img width="385" height="300" src="https://digbr.com/wp-content/uploads/2018/08/Ed-Orgeron_Troy_LSU-385x300.jpg" class="attachment-gridlove-b8 size-gridlove-b8 wp-post-image" alt="" data-wp-pid="74177" nopin="nopin" /></a></div><div class="box-inner-ptbr box-col-b entry-sm-overlay"><div class="box-inner-ellipsis"><div class="entry-category"> <a href="https://digbr.com/category/sports/" class="gridlove-cat gridlove-cat-6">Sports</a></div><h2 class="entry-title h3"><a href="https://digbr.com/lsu-ranked-24-in-preseason-poll/">LSU ranked No. 24 in Preseason Poll</a></h2><div class="entry-content"><p>By JAMES MORAN | Tiger Rag Associate Editor &nbsp; The 65 voting coaches — or, in many cases, their sports information directors — appear to be a bit more bullish on LSU than the odds makers in Las Vegas or the press contingent at Southeastern...</p></div></div><div class="entry-meta"><div class="meta-item meta-date"><span class="updated">3 days ago</span></div></div></div></article></div></div></div></div></div><div class="gridlove-sidebar"><div id="shortcode-widget-2" class="widget gridlove-box shortcode_widget"><div class="textwidget"><article class="custom-614 gridlove-post gridlove-post-d gridlove-box post type-post status-publish format-standard has-post-thumbnail hentry"> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">ga('send', 'event', 'ads', 'impressions', 'MOCKLER BEVERAGE COMPANY - Cheers!');</script> <div class="entry-image"><a onclick="ga('send', 'event', 'ads', 'clicks', 'MOCKLER BEVERAGE COMPANY - Cheers!');" href="https://coronausa.com" target="_blank"> <img width="750" height="600" src="https://digbr.com/wp-content/uploads/2016/05/budresizeweb-copy.jpg" class="attachment-gridlove-d4 size-gridlove-d4 wp-post-image wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2016/05/budresizeweb-copy.jpg 750w, https://digbr.com/wp-content/uploads/2016/05/budresizeweb-copy-300x240.jpg 300w, https://digbr.com/wp-content/uploads/2016/05/budresizeweb-copy-150x120.jpg 150w, https://digbr.com/wp-content/uploads/2016/05/budresizeweb-copy-600x480.jpg 600w, https://digbr.com/wp-content/uploads/2016/05/budresizeweb-copy-740x592.jpg 740w" sizes="(max-width: 750px) 100vw, 750px" data-wp-pid="66423" nopin="nopin" /> </a></div><div class="entry-overlay box-inner-p"><div class="box-inner-ellipsis"><h2 class="entry-title h3"> <a onclick="ga('send', 'event', 'ads', 'clicks', 'MOCKLER BEVERAGE COMPANY - Cheers!');" href="https://coronausa.com" target="_blank">Cheers!</a></h2><div class="client" style="">MOCKLER BEVERAGE COMPANY</div></div></div></article></div></div><div id="mks_social_widget-4" class="widget gridlove-box mks_social_widget"><h4 class="widget-title">Follow Us</h4><ul class="mks_social_widget_ul"><li><a href="https://www.instagram.com/digbatonrouge/" title="Instagram" class="instagram_ico soc_circle" target="_blank" style="width: 42px; height: 42px; font-size: 16px;"><span>instagram</span></a></li><li><a href="https://twitter.com/DigBatonRouge" title="Twitter" class="twitter_ico soc_circle" target="_blank" style="width: 42px; height: 42px; font-size: 16px;"><span>twitter</span></a></li><li><a href="https://www.facebook.com/digbatonrouge/" title="Facebook" class="facebook_ico soc_circle" target="_blank" style="width: 42px; height: 42px; font-size: 16px;"><span>facebook</span></a></li></ul></div><div id="evcalwidget-2" class="widget gridlove-box EvcalWidget"><div id='evcal_widget' class='evo_widget'><div id='evcal_calendar_265' class='ajde_evcal_calendar  ul' ><div class='evo-data' data-cyear="2018" data-cmonth="8" data-runajax="1" data-evc_open="0" data-cal_ver="2.5.5" data-mapscroll="true" data-mapformat="roadmap" data-mapzoom="18" data-mapiconurl="" data-ev_cnt="5" data-show_limit="no" data-tiles="no" data-sort_by="sort_date" data-filters_on="false" data-range_start="0" data-range_end="0" data-send_unix="0" data-ux_val="0" data-accord="0" data-rtl="no"  ></div><div id='evcal_head' class='calendar_header ' ><div class='evo_cal_above'><span class='evo-gototoday-btn' style='display:none' data-mo='8' data-yr='2018' data-dy=''>Current Month</span></div><div class='evo_cal_above_content'></div><div class='cal_arguments' style='display:none' data-hide_past="yes" data-show_et_ft_img="no" data-event_order="ASC" data-ft_event_priority="no" data-lang="L1" data-month_incre="0" data-only_ft="no" data-evc_open="no" data-show_limit="no" data-etc_override="no" data-show_limit_redir="0" data-tiles="no" data-tile_height="0" data-tile_bg="0" data-tile_count="2" data-tile_style="0" data-s="" data-members_only="no" data-ux_val="0" data-show_limit_ajax="no" data-show_limit_paged="1" ></div><div class='clear'></div></div><div class='evcal_month_line'><p>august</p></div><div id='evcal_list' class='eventon_events_list '><div id="event_72355" class="eventon_list_event  event" data-event_id="72355" data-ri="11" data-time="1533513601-1533599999" data-colr="#5ca4b4" itemscope itemtype='http://schema.org/Event' 1><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/5-merch-mule-monday/&quest;ri&equals;11&amp;'></a><span itemprop='name'  >$5 Merch Mule Monday</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2018/05/13230211_1005663339514840_8981324291178176819_n-300x300.jpg' ></meta><meta itemprop='description' content='Take away the Monday blues with $5 Moscow Mule's at The Overpass Merchant!  &nbsp;  Image via The Overpass Merchant Facebook' ></meta><meta itemprop='startDate' content='2018-8-6' ></meta><meta itemprop='endDate' content='2018-8-6' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">The Overpass Merchant</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">2904 Perkins Rd Baton Rouge, LA 70808</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "$5 Merch Mule Monday",
							  	"startDate": "2018-8-6T00-00-00-00",
							  	"endDate": "2018-8-6T23-23-59-00",
							  	"image":"https://digbr.com/wp-content/uploads/2018/05/13230211_1005663339514840_8981324291178176819_n-300x300.jpg",
							  	"description":"Take away the Monday blues with $5 Moscow Mule's at The Overpass Merchant!

&nbsp;

Image via The Overpass Merchant Facebook",
							  	"location":{
										"@type":"Place",
										"name":"The Overpass Merchant",
										"address":"2904 Perkins Rd Baton Rouge, LA 70808"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #5ca4b4;" id="evc_153351360172355" class="event_repeat desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#5ca4b4' data-smon='august' data-syr='2018'><span class='evo_start '><em class='date'>06</em><em class='month'>aug</em><em class='time'>allday</em></span><span class='evo_end only_time'><em class='time'>allday</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.4254294,-91.1591391"  data-location_address="2904 Perkins Rd Baton Rouge, LA 70808" data-location_type="lonlat" data-location_name="The Overpass Merchant" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>$5 Merch Mule Monday</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='960' data-imgwidth='960'  style='background-image: url("https://digbr.com/wp-content/uploads/2018/05/13230211_1005663339514840_8981324291178176819_n.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>Take away the Monday blues with $5 Moscow Mule's at The Overpass Merchant!  &nbsp;  Image via The Overpass Merchant Facebook</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>Take away the Monday blues with $5 Moscow Mule&#8217;s at The Overpass Merchant!</p><p>&nbsp;</p><p>Image via The Overpass Merchant Facebook</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>All Day (Monday)</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='369'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>The Overpass Merchant</p><p>2904 Perkins Rd Baton Rouge, LA 70808</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=72355&amp;sunix=20180806T050000Z&amp;eunix=20180807T045900Z&amp;loca=2904 Perkins Rd Baton Rouge, LA 70808&amp;locn=The Overpass Merchant' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=%245+Merch+Mule+Monday&amp;dates=20180806T050000Z/20180807T045900Z&amp;details=Take+away+the+Monday+blues+with+%245+Moscow+Mule%27s+at+The+Overpass+Merchant%21%0D%0A%0D%0A%26nbsp%3B%0D%0A%0D%0AImage+via+The+Overpass+Merchant+Facebook&amp;location=The+Overpass+Merchant - 2904+Perkins+Rd+Baton+Rouge%2C+LA+70808' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_72352" class="eventon_list_event  event" data-event_id="72352" data-ri="12" data-time="1533600001-1533686399" data-colr="#5ca4b4" itemscope itemtype='http://schema.org/Event' 2><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/5-burger-night-olive-or-twist/&quest;ri&equals;12&amp;'></a><span itemprop='name'  >$5 Burger Night @ Olive or Twist</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2018/05/Screen-Shot-2018-05-16-at-11.08.13-AM-300x300.png' ></meta><meta itemprop='description' content='Come for lunch, come again for dinner!  $5 burger with housemade pickles, caramelized onions, and hand-cut fries ALL DAY every Tuesday! Do we need to say more??  &nbsp;  Image via Olive or Twist' ></meta><meta itemprop='startDate' content='2018-8-7' ></meta><meta itemprop='endDate' content='2018-8-7' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Olive or Twist</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">7248 Perkins Rd, Ste A Baton Rouge, Louisiana 70808</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "$5 Burger Night @ Olive or Twist",
							  	"startDate": "2018-8-7T00-00-00-00",
							  	"endDate": "2018-8-7T23-23-59-00",
							  	"image":"https://digbr.com/wp-content/uploads/2018/05/Screen-Shot-2018-05-16-at-11.08.13-AM-300x300.png",
							  	"description":"Come for lunch, come again for dinner!

$5 burger with housemade pickles, caramelized onions, and hand-cut fries ALL DAY every Tuesday! Do we need to say more??

&nbsp;

Image via Olive or Twist",
							  	"location":{
										"@type":"Place",
										"name":"Olive or Twist",
										"address":"7248 Perkins Rd, Ste A Baton Rouge, Louisiana 70808"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #5ca4b4;" id="evc_153360000172352" class="event_repeat desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#5ca4b4' data-smon='august' data-syr='2018'><span class='evo_start '><em class='date'>07</em><em class='month'>aug</em><em class='time'>allday</em></span><span class='evo_end only_time'><em class='time'>allday</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.4001818,-91.1140126"  data-location_address="7248 Perkins Rd, Ste A Baton Rouge, Louisiana 70808" data-location_type="lonlat" data-location_name="Olive or Twist" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>$5 Burger Night @ Olive or Twist</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='1198' data-imgwidth='1198'  style='background-image: url("https://digbr.com/wp-content/uploads/2018/05/Screen-Shot-2018-05-16-at-11.08.13-AM.png")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>Come for lunch, come again for dinner!  $5 burger with housemade pickles, caramelized onions, and hand-cut fries ALL DAY every Tuesday! Do we need to say more??  &nbsp;  Image via Olive or Twist</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>Come for lunch, come again for dinner!</p><p>$5 burger with housemade pickles, caramelized onions, and hand-cut fries ALL DAY every Tuesday! Do we need to say more??</p><p>&nbsp;</p><p>Image via Olive or Twist<a href="https://www.instagram.com/p/BXwFNy7DN7X/?taken-by=oliveortwistbr"> Instagram</a></p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>All Day (Tuesday)</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='498'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Olive or Twist</p><p>7248 Perkins Rd, Ste A Baton Rouge, Louisiana 70808</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=72352&amp;sunix=20180807T050000Z&amp;eunix=20180808T045900Z&amp;loca=7248 Perkins Rd, Ste A Baton Rouge, Louisiana 70808&amp;locn=Olive or Twist' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=%245+Burger+Night+%40+Olive+or+Twist&amp;dates=20180807T050000Z/20180808T045900Z&amp;details=Come+for+lunch%2C+come+again+for+dinner%21%0D%0A%0D%0A%245+burger+with+housemade+pickles%2C+caramelized+onions%2C+and+hand-cut+fries+ALL+DAY+every+Tuesday%21+Do+we+need+to+say+more%3F%3F%0D%0A%0D%0A%26nbsp%3B%0D%0A%0D%0AImage+via+Olive+or+Twist&amp;location=Olive+or+Twist - 7248+Perkins+Rd%2C+Ste+A+Baton+Rouge%2C+Louisiana+70808' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_73913" class="eventon_list_event  event" data-event_id="73913" data-ri="6" data-time="1533654000-1533675600" data-colr="#5ca4b4" itemscope itemtype='http://schema.org/Event' 3><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/free-margaritas-for-teachers/&quest;ri&equals;6&amp;'></a><span itemprop='name'  >Free Margaritas For Teachers!</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2018/07/teachers-300x169.jpg' ></meta><meta itemprop='description' content='To celebrate the start of the new school year, we're offering a free margarita for Teachers! From August 1st through the 8th, get one FREE house margarita for education professionals' ></meta><meta itemprop='startDate' content='2018-8-7' ></meta><meta itemprop='endDate' content='2018-8-7' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">The Velvet Cactus</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">7655 Old Hammond Hwy. </item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Free Margaritas For Teachers!",
							  	"startDate": "2018-8-7T15-15-00-00",
							  	"endDate": "2018-8-7T21-21-00-00",
							  	"image":"https://digbr.com/wp-content/uploads/2018/07/teachers-300x169.jpg",
							  	"description":"To celebrate the start of the new school year, we're offering a free margarita for Teachers! From August 1st through the 8th, get one FREE house margarita for education professionals",
							  	"location":{
										"@type":"Place",
										"name":"The Velvet Cactus",
										"address":"7655 Old Hammond Hwy. "
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #5ca4b4;" id="evc_153365400073913" class="event_repeat desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#5ca4b4' data-smon='august' data-syr='2018'><span class='evo_start '><em class='date'>07</em><em class='month'>aug</em><em class='time'><i>(aug 7)</i>3:00 pm</em></span><span class='evo_end only_time'><em class='time'><i>(aug 7)</i>3:00 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.4313211,-91.1083129"  data-location_address="7655 Old Hammond Hwy. " data-location_type="lonlat" data-location_name="The Velvet Cactus" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Free Margaritas For Teachers!</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='1082' data-imgwidth='1924'  style='background-image: url("https://digbr.com/wp-content/uploads/2018/07/teachers.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>To celebrate the start of the new school year, we're offering a free margarita for Teachers! From August 1st through the 8th, get one FREE house margarita for education professionals</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>To celebrate the start of the new school year, we&#8217;re offering a free margarita for Teachers! From August 1st through the 8th, get one FREE house margarita for education professionals with a staff ID, limit one per customer. Please enjoy responsibly.</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Tuesday) 3:00 pm - 9:00 pm</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='459'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>The Velvet Cactus</p><p>7655 Old Hammond Hwy.</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_learnMICS evorow bordb '><div class='tb'><div class='tbrow'> <a class='evcal_col50 dark1 bordr evo_clik_row' href='https://www.facebook.com/events/207724170077036/' target="_blank"> <span class='evcal_evdata_row ' > <span class='evcal_evdata_icons'><i class='fa fa-link'></i></span><h3 class='evo_h3'>Learn More</h3> </span> </a><div class='evo_ics evcal_col50 dark1 evo_clik_row' ><div class='evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=73913&amp;sunix=20180807T200000Z&amp;eunix=20180808T020000Z&amp;loca=7655 Old Hammond Hwy. &amp;locn=The Velvet Cactus' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Free+Margaritas+For+Teachers%21&amp;dates=20180807T200000Z/20180808T020000Z&amp;details=To+celebrate+the+start+of+the+new+school+year%2C+we%27re+offering+a+free+margarita+for+Teachers%21+From+August+1st+through+the+8th%2C+get+one+FREE+house+margarita+for+education+professionals&amp;location=The+Velvet+Cactus - 7655+Old+Hammond+Hwy.+' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div></div></div></div></div><div class='clear end'></div></div><div id="event_74149" class="eventon_list_event  event" data-event_id="74149" data-time="1533659400-1533666600" data-colr="#5ca4b4" itemscope itemtype='http://schema.org/Event' 4><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/taco-tuesday-2-2/'></a><span itemprop='name'  >Taco Tuesday</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2018/08/tacos-300x114.png' ></meta><meta itemprop='description' content='$2 draft beers, $2 tacos  image: Facebook/La Carreta Government' ></meta><meta itemprop='startDate' content='2018-8-7' ></meta><meta itemprop='endDate' content='2018-8-7' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">La Carreta</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">4065 Government St</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Taco Tuesday",
							  	"startDate": "2018-8-7T16-16-30-00",
							  	"endDate": "2018-8-7T18-18-30-00",
							  	"image":"https://digbr.com/wp-content/uploads/2018/08/tacos-300x114.png",
							  	"description":"$2 draft beers, $2 tacos

image: Facebook/La Carreta Government",
							  	"location":{
										"@type":"Place",
										"name":"La Carreta",
										"address":"4065 Government St"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #5ca4b4;" id="evc_153365940074149" class="event_repeat desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#5ca4b4' data-smon='august' data-syr='2018'><span class='evo_start '><em class='date'>07</em><em class='month'>aug</em><em class='time'><i>(aug 7)</i>4:30 pm</em></span><span class='evo_end only_time'><em class='time'><i>(aug 7)</i>4:30 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.4446952,-91.1473532"  data-location_address="4065 Government St" data-location_type="lonlat" data-location_name="La Carreta" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Taco Tuesday</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='315' data-imgwidth='828'  style='background-image: url("https://digbr.com/wp-content/uploads/2018/08/tacos.png")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>$2 draft beers, $2 tacos  image: Facebook/La Carreta Government</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>$2 draft beers, $2 tacos</p><p>image: Facebook/La Carreta Government</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Tuesday) 4:30 pm - 6:30 pm</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='709'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>La Carreta</p><p>4065 Government St</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_learnMICS evorow bordb '><div class='tb'><div class='tbrow'> <a class='evcal_col50 dark1 bordr evo_clik_row' href='http://carretarestaurant.com/#government' target="_blank"> <span class='evcal_evdata_row ' > <span class='evcal_evdata_icons'><i class='fa fa-link'></i></span><h3 class='evo_h3'>Learn More</h3> </span> </a><div class='evo_ics evcal_col50 dark1 evo_clik_row' ><div class='evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=74149&amp;sunix=20180807T213000Z&amp;eunix=20180807T233000Z&amp;loca=4065 Government St&amp;locn=La Carreta' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Taco+Tuesday&amp;dates=20180807T213000Z/20180807T233000Z&amp;details=%242+draft+beers%2C+%242+tacos%0D%0A%0D%0Aimage%3A+Facebook%2FLa+Carreta+Government&amp;location=La+Carreta - 4065+Government+St' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div></div></div></div></div><div class='clear end'></div></div><div id="event_72944" class="eventon_list_event  event" data-event_id="72944" data-ri="9" data-time="1533668400-1533685800" data-colr="#5ca4b4" itemscope itemtype='http://schema.org/Event' 5><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/trivia-tuesday-at-rotolos/&quest;ri&equals;9&amp;'></a><span itemprop='name'  >Trivia Tuesday at Rotolo's</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2018/06/rotolos-300x200.jpg' ></meta><meta itemprop='description' content='Bring your group of friends to Rotolos on Tuesdays to test you knowledge and have some great pizza!' ></meta><meta itemprop='startDate' content='2018-8-7' ></meta><meta itemprop='endDate' content='2018-8-7' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Rotolo&#039;s Craft and Crust</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">411 Ben Hur Rd</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Trivia Tuesday at Rotolo's",
							  	"startDate": "2018-8-7T19-19-00-00",
							  	"endDate": "2018-8-7T23-23-50-00",
							  	"image":"https://digbr.com/wp-content/uploads/2018/06/rotolos-300x200.jpg",
							  	"description":"Bring your group of friends to Rotolos on Tuesdays to test you knowledge and have some great pizza!",
							  	"location":{
										"@type":"Place",
										"name":"Rotolo&#039;s Craft and Crust",
										"address":"411 Ben Hur Rd"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #5ca4b4;" id="evc_153366840072944" class="event_repeat desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#5ca4b4' data-smon='august' data-syr='2018'><span class='evo_start '><em class='date'>07</em><em class='month'>aug</em><em class='time'><i>(aug 7)</i>7:00 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata '  data-location_address="411 Ben Hur Rd" data-location_type="address" data-location_name="Rotolo&#039;s Craft and Crust" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Trivia Tuesday at Rotolo's</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='400' data-imgwidth='600'  style='background-image: url("https://digbr.com/wp-content/uploads/2018/06/rotolos.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>Bring your group of friends to Rotolos on Tuesdays to test you knowledge and have some great pizza!</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>Bring your group of friends to Rotolos on Tuesdays to test you knowledge and have some great pizza!</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Tuesday) 7:00 pm</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='523'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Rotolo&#039;s Craft and Crust</p><p>411 Ben Hur Rd</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_learnMICS evorow bordb '><div class='tb'><div class='tbrow'> <a class='evcal_col50 dark1 bordr evo_clik_row' href='https://www.facebook.com/events/969358703227235/' target="_blank"> <span class='evcal_evdata_row ' > <span class='evcal_evdata_icons'><i class='fa fa-link'></i></span><h3 class='evo_h3'>Learn More</h3> </span> </a><div class='evo_ics evcal_col50 dark1 evo_clik_row' ><div class='evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=72944&amp;sunix=20180808T000000Z&amp;eunix=20180808T045000Z&amp;loca=411 Ben Hur Rd&amp;locn=Rotolo&#039;s Craft and Crust' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Trivia+Tuesday+at+Rotolo%27s&amp;dates=20180808T000000Z/20180808T045000Z&amp;details=Bring+your+group+of+friends+to+Rotolos+on+Tuesdays+to+test+you+knowledge+and+have+some+great+pizza%21&amp;location=Rotolo%26%23039%3Bs+Craft+and+Crust - 411+Ben+Hur+Rd' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div></div></div></div></div><div class='clear end'></div></div></div><div class='clear'></div></div></div></div><div id="gridlove_posts_widget-1" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Recent posts<span class="gridlove-slider-controls" data-autoplay="0"></span></h4><div class="gridlove-posts-widget gridlove-widget-slider"><div class="gridlove-posts-widget-item-wrapper"><article class="post-74208 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-no-comments tag-now"><div class="entry-image"> <a href="https://digbr.com/27-days-until-lsu-football-returns/" title="Only 27 days until LSU football returns&#8230; here&#8217;s what we know so far"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/08/Jonathan-Giles_LSU-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="74209" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/27-days-until-lsu-football-returns/">Only 27 days until LSU football returns&#8230; here&#8217;s what we know so far</a></h6></div></article><article class="post-74197 post type-post status-publish format-standard has-post-thumbnail hentry category-leisure tag-now"><div class="entry-image"> <a href="https://digbr.com/things-to-do-monday-20/" title="Things to do: Monday"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/08/dinneronthepatio-1-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="74200" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/things-to-do-monday-20/">Things to do: Monday</a></h6></div></article><article class="post-74195 post type-post status-publish format-standard has-post-thumbnail hentry category-leisure tag-now"><div class="entry-image"> <a href="https://digbr.com/cat-haven-adoption-of-the-week-meet-annie/" title="Cat Haven Adoption of the Week: Meet Annie!"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/08/Annie-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="74196" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/cat-haven-adoption-of-the-week-meet-annie/">Cat Haven Adoption of the Week: Meet Annie!</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-74178 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-now"><div class="entry-image"> <a href="https://digbr.com/send-jordan-from-rouses-to-school-is-top-trending-campaign-on-gofundme/" title="&#8220;Send Jordan from Rouses to School&#8221; is top trending campaign on GoFundMe"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/08/31798172_1533127498144293_r-80x60.jpeg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="74179" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/send-jordan-from-rouses-to-school-is-top-trending-campaign-on-gofundme/">&#8220;Send Jordan from Rouses to School&#8221; is top trending campaign on GoFundMe</a></h6></div></article><article class="post-74176 post type-post status-publish format-standard has-post-thumbnail hentry category-sports tag-no-comments tag-now"><div class="entry-image"> <a href="https://digbr.com/lsu-ranked-24-in-preseason-poll/" title="LSU ranked No. 24 in Preseason Poll"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/08/Ed-Orgeron_Troy_LSU-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="74177" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/lsu-ranked-24-in-preseason-poll/">LSU ranked No. 24 in Preseason Poll</a></h6></div></article><article class="post-74154 post type-post status-publish format-standard has-post-thumbnail hentry category-campus tag-now"><div class="entry-image"> <a href="https://digbr.com/update-on-the-nicholson-gateway-project/" title="Update on the Nicholson Gateway project"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/08/Screen-Shot-2018-08-02-at-10.40.26-AM-80x60.png" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="74157" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/update-on-the-nicholson-gateway-project/">Update on the Nicholson Gateway project</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-73501 post type-post status-publish format-standard has-post-thumbnail hentry category-perk tag-now"><div class="entry-image"> <a href="https://digbr.com/win-a-pair-of-tickets-to-see-parish-county-line/" title="Win a pair of tickets to see Parish County Line!"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/07/pcl-cover-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="73502" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/win-a-pair-of-tickets-to-see-parish-county-line/">Win a pair of tickets to see Parish County Line!</a></h6></div></article><article class="post-73984 post type-post status-publish format-standard has-post-thumbnail hentry category-magazine tag-highlight"><div class="entry-image"> <a href="https://digbr.com/august-2018-in-this-issue/" title="August 2018: In This Issue"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/08/Pres-56-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="73989" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/august-2018-in-this-issue/">August 2018: In This Issue</a></h6></div></article><article class="post-74136 post type-post status-publish format-standard has-post-thumbnail hentry category-magazine"><div class="entry-image"> <a href="https://digbr.com/big-love/" title="Big Love"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/08/IMG_6017-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="74140" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/big-love/">Big Love</a></h6></div></article></div></div></div><div id="shortcode-widget-3" class="widget gridlove-box shortcode_widget"><div class="textwidget"><article class="custom-614 gridlove-post gridlove-post-d gridlove-box post type-post status-publish format-standard has-post-thumbnail hentry"> <script type="text/javascript">ga('send', 'event', 'ads', 'impressions', 'Stinky\'s Fish Camp - Absolut Bloody Mary Bar EVERY Sunday');</script> <div class="entry-image"><a onclick="ga('send', 'event', 'ads', 'clicks', 'Stinky\'s Fish Camp - Absolut Bloody Mary Bar EVERY Sunday');" href="https://www.stinkysbr.com/" target="_blank"> <img width="700" height="565" src="https://digbr.com/wp-content/uploads/2018/06/0718_StinkysWEB.jpg" class="attachment-gridlove-d4 size-gridlove-d4 wp-post-image wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2018/06/0718_StinkysWEB.jpg 700w, https://digbr.com/wp-content/uploads/2018/06/0718_StinkysWEB-300x242.jpg 300w, https://digbr.com/wp-content/uploads/2018/06/0718_StinkysWEB-150x121.jpg 150w, https://digbr.com/wp-content/uploads/2018/06/0718_StinkysWEB-600x484.jpg 600w, https://digbr.com/wp-content/uploads/2018/06/0718_StinkysWEB-370x300.jpg 370w" sizes="(max-width: 700px) 100vw, 700px" data-wp-pid="72894" nopin="nopin" /> </a></div><div class="entry-overlay box-inner-p"><div class="box-inner-ellipsis"><h2 class="entry-title h3"> <a onclick="ga('send', 'event', 'ads', 'clicks', 'Stinky\'s Fish Camp - Absolut Bloody Mary Bar EVERY Sunday');" href="https://www.stinkysbr.com/" target="_blank">Absolut Bloody Mary Bar EVERY Sunday</a></h2><div class="client" style="">Stinky's Fish Camp</div></div></div></article></div></div></div></div></div><div id="footer" class="gridlove-footer"><div class="container"><div class="row"><div class="col-lg-4 col-md-6 col-sm-12"><div id="text-2" class="widget widget_text"><div class="textwidget"><p><img width="159" src="https://digbr.com/wp-content/uploads/2017/09/DIG-wht.png"/></p><p>DIGBR.com is how Baton Rouge keeps the pulse of our great city. We curate what's important and deliver it fast and throughout the day along with great content from your monthly DIG Magazine.</p></div></div><div id="mks_social_widget-3" class="widget mks_social_widget"><ul class="mks_social_widget_ul"><li><a href="https://www.facebook.com/digbatonrouge/" title="Facebook" class="facebook_ico soc_circle" target="_blank" style="width: 40px; height: 40px; font-size: 16px;"><span>facebook</span></a></li><li><a href="https://twitter.com/DigBatonRouge" title="Twitter" class="twitter_ico soc_circle" target="_blank" style="width: 40px; height: 40px; font-size: 16px;"><span>twitter</span></a></li><li><a href="https://www.instagram.com/digbatonrouge/" title="Instagram" class="instagram_ico soc_circle" target="_blank" style="width: 40px; height: 40px; font-size: 16px;"><span>instagram</span></a></li></ul></div></div><div class="col-lg-4 col-md-6 col-sm-12"><div id="mc4wp_widget-3" class="widget widget_mc4wp_widget"><h4 class="widget-title">Newsletter</h4><div id="mc4wp-form-1" class="mc4wp-form mc4wp-form-47580 mc4wp-ajax "><form method="post" action="https://digbr.com/27-days-until-lsu-football-returns/"><p> <label for="mc4wp_email">Every day, DIG hits your inbox with the latest happening in BR - news, fun, cool events and more.</label> <input type="email" id="mc4wp_email" name="EMAIL" required placeholder="Your email address" /></p><p> <input type="submit" value="Sign up" /></p><textarea name="_mc4wp_required_but_not_really" style="display: none;"></textarea><input type="hidden" name="_mc4wp_form_ID" value="47580" /><input type="hidden" name="_mc4wp_form_instance" value="1" /><input type="hidden" name="_mc4wp_form_submit" value="1" /><input type="hidden" name="_mc4wp_form_nonce" value="40814d10cc" /></form><span class="mc4wp-ajax-loader" style="display: none;"></span><div style="display:none;" class="mc4wp-alert mc4wp-success-message mc4wp-success">Thank you, your sign-up request was successful! Please check your e-mail inbox. <span class="mc4wp-mailchimp-error"></span></div><div style="display:none;" class="mc4wp-alert mc4wp-already_subscribed-message mc4wp-notice">Given email address is already subscribed, thank you! <span class="mc4wp-mailchimp-error"></span></div><div style="display:none;" class="mc4wp-alert mc4wp-invalid_email-message mc4wp-error">Please provide a valid email address. <span class="mc4wp-mailchimp-error"></span></div><div style="display:none;" class="mc4wp-alert mc4wp-error-message mc4wp-error">Oops. Something went wrong. Please try again later. <span class="mc4wp-mailchimp-error"></span></div></div></div></div><div class="col-lg-4 col-md-6 col-sm-12"><div id="nav_menu-1" class="widget widget_nav_menu"><h4 class="widget-title">Help &#038; Support</h4><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-47573" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47573"><a href="https://digbr.com/terms-of-service/">Terms of Service</a></li><li id="menu-item-47574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47574"><a href="https://digbr.com/advertise-with-dig/">Advertise</a></li><li id="menu-item-47576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47576"><a href="https://digbr.com/join-the-team/">Join the Team!</a></li><li id="menu-item-48020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48020"><a href="https://digbr.com/find-a-copy/">Find a copy</a></li><li id="menu-item-63187" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63187"><a href="https://digbr.com/aboutcontact/">About/Contact</a></li></ul></div></div></div></div></div><div class="gridlove-copyright"><div class="container"><p style="text-align: center">Copyright © 2017 · Primedia Holdings, LLC</p></div></div></div><div class="gridlove-sidebar-action-wrapper"> <span class="gridlove-action-close"><i class="fa fa-times" aria-hidden="true"></i></span><div class="gridlove-sidebar-action-inside"><div class="hidden-lg-up widget gridlove-box widget_nav_menu"><ul id="menu-main-menu-2" class="gridlove-mobile-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6977"><a href="https://digbr.com/category/news/">NEWS</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66360"><a href="https://digbr.com/category/news/crime/">Crime</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66359"><a href="https://digbr.com/category/news/biz/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7141"><a href="https://digbr.com/category/news/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6979"><a href="https://digbr.com/category/news/campus/">LSU</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7306"><a href="https://digbr.com/category/leisure/">LEISURE</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66358"><a href="https://digbr.com/the-lineup/">Things to do</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66393"><a href="https://digbr.com/food-drink/">Food &#038; Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6969"><a href="https://digbr.com/category/leisure/arts-culture/">Arts &#038; Culture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7316"><a href="https://digbr.com/category/sports/">Sports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6972"><a href="https://digbr.com/category/leisure/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31878"><a href="https://digbr.com/category/leisure/fitness/">Health &#038; Fitness</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-73314"><a href="https://digbr.com/the-six/">THE SIX</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47579"><a href="#">FUN STUFF!</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-72249"><a href="https://digbr.com/category/leisure/perk/">Perks</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-47583"><a href="https://digbr.com/product-category/ticketed-event/">DIG Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7155"><a href="https://digbr.com/category/galleries/">Galleries</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66741"><a href="https://digbr.com/category/magazine/">MAGAZINE</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71994"><a href="https://digbr.com/brag18/">BRAG18</a></li></ul></div><div id="mks_social_widget-1" class="widget gridlove-box mks_social_widget"><h4 class="widget-title">Follow us</h4><p>Don't be shy, get in touch. We love meeting interesting people and making new friends.</p><ul class="mks_social_widget_ul"><li><a href="https://www.facebook.com/mekshq" title="Facebook" class="facebook_ico soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;"><span>facebook</span></a></li><li><a href="https://twitter.com/mekshq" title="Twitter" class="twitter_ico soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;"><span>twitter</span></a></li><li><a href="http://youtube.com/" title="Youtube" class="youtube_ico soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;"><span>youtube</span></a></li><li><a href="http://blogger.com" title="Blogger" class="blogger_ico soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;"><span>blogger</span></a></li></ul></div><div id="gridlove_posts_widget-2" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Most popular<span class="gridlove-slider-controls" data-autoplay="0"></span></h4></div><div id="gridlove_posts_widget-3" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Most discussed<span class="gridlove-slider-controls" data-autoplay="0"></span></h4><div class="gridlove-posts-widget gridlove-widget-slider"><div class="gridlove-posts-widget-item-wrapper"><article class="post-12295 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-sports"><div class="entry-image"> <a href="https://digbr.com/londoner-hosts-celebration-of-historic-usa-world-cup-victory/" title="Londoner Hosts Celebration of Historic USA World Cup Victory"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/ANCHOR_Outlaws-Londoner-12-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12296" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/londoner-hosts-celebration-of-historic-usa-world-cup-victory/">Londoner Hosts Celebration of Historic USA World Cup Victory</a></h6></div></article><article class="post-12485 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/business-as-usual-bobby-jindal-crony-capitalism/" title="Business As Usual"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/Fred-Dive-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12486" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/business-as-usual-bobby-jindal-crony-capitalism/">Business As Usual</a></h6></div></article><article class="post-12652 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/paul-stars-part-two/" title="All Mainieri Team: Infield"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/07/JUMP-Austin-Nola-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12653" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/paul-stars-part-two/">All Mainieri Team: Infield</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-12047 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-leisure category-sports"><div class="entry-image"> <a href="https://digbr.com/digs-baton-rouge-world-cup-watch-guide/" title="DIG&#8217;s Baton Rouge World Cup Watch Guide"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/JUMP-2014.06.07_DIG_FUTBOL-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12048" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/digs-baton-rouge-world-cup-watch-guide/">DIG&#8217;s Baton Rouge World Cup Watch Guide</a></h6></div></article><article class="post-12262 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/red-stick-roller-derby-baton-rouge-bittersweet/" title="BITTERSWEET"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/roller-derby-1-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12265" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/red-stick-roller-derby-baton-rouge-bittersweet/">BITTERSWEET</a></h6></div></article><article class="post-49342 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/fargas-finished-lsu-womens-basketball-needs-to-move-past-coaching-regime/" title="Fargas finished? LSU women&#8217;s basketball needs to move past coaching regime"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2016/03/Fargas-1-e1457541734999-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="49344" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/fargas-finished-lsu-womens-basketball-needs-to-move-past-coaching-regime/">Fargas finished? LSU women&#8217;s basketball needs to move past coaching regime</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-48120 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/diamonds-in-the-rough/" title="Diamonds in the Rough"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2016/02/Jacob-Hester-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="48123" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/diamonds-in-the-rough/">Diamonds in the Rough</a></h6></div></article><article class="post-28505 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/making-moves-taking-risks/" title="Making Moves, Taking Risks"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2015/03/Jimmy-Graham-80x60.png" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="28506" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/making-moves-taking-risks/">Making Moves, Taking Risks</a></h6></div></article><article class="post-30257 post type-post status-publish format-standard has-post-thumbnail hentry category-outdoors category-sports tag-chase-berenson"><div class="entry-image"> <a href="https://digbr.com/camping-on-the-cajun-riveriera/" title="Camping on the Cajun Riveriera"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-80x60.jpg 80w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-300x225.jpg 300w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-768x576.jpg 768w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-1024x768.jpg 1024w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-150x113.jpg 150w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-600x450.jpg 600w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-1032x774.jpg 1032w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-740x555.jpg 740w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-800x600.jpg 800w" sizes="(max-width: 80px) 100vw, 80px" data-wp-pid="30258" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/camping-on-the-cajun-riveriera/">Camping on the Cajun Riveriera</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-16337 post type-post status-publish format-standard hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/game-day-preview-lsu-vs-nmsu/" title="Game Day Preview: LSU vs. NMSU"> <img src="https://demo.mekshq.com/gridlove/wp-content/themes/gridlove/assets/img/gridlove_default.jpg" alt="Game Day Preview: LSU vs. NMSU" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/game-day-preview-lsu-vs-nmsu/">Game Day Preview: LSU vs. NMSU</a></h6></div></article><article class="post-18420 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/its-time-we-admit-that-father-time-has-drew-brees-on-the-ropes/" title="Father Time has Drew Brees on the Ropes"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/10/Brees-Saints-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="18422" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/its-time-we-admit-that-father-time-has-drew-brees-on-the-ropes/">Father Time has Drew Brees on the Ropes</a></h6></div></article><article class="post-11580 post type-post status-publish format-video has-post-thumbnail hentry category-sports post_format-post-format-video"><div class="entry-image"> <a href="https://digbr.com/lsu-vanderbilt-sec-tournament-highlights/" title="LSU vs. Vanderbilt: SEC Tournament Highlights"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/03/Alex-Bregman-web-e1400779515326-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="9684" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/lsu-vanderbilt-sec-tournament-highlights/">LSU vs. Vanderbilt: SEC Tournament Highlights</a></h6></div></article></div></div></div></div></div><div class="gridlove-sidebar-action-overlay"></div> <script type="text/javascript">var gmapstyles = 'default';</script> <div id="fb-root"></div> <script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=713095298769737";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MW6NQMQ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>  <script>jQuery(document)
	.on('ready', function(){
		if(jQuery('body').is('.home')){
			setTimeout(function(){
				window.location.reload(1);
			}, 1800000);
		}
	});</script><div class='evo_lightboxes'><div class='evo_lightbox eventcard eventon_events_list' id=''><div class="evo_content_in"><div class="evo_content_inin"><div class="evo_lightbox_content"> <a class='evolbclose '>X</a><div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'></div></div></div></div></div></div> <script type='text/javascript'>var evoli_ajax_script = {"evoli_ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php","postnonce":"14de8f2b60"};</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/digbr.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};</script> <script type='text/javascript'>var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/27-days-until-lsu-football-returns\/?wc-ajax=%%endpoint%%"};</script> <script type='text/javascript'>var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/27-days-until-lsu-football-returns\/?wc-ajax=%%endpoint%%","fragment_name":"wc_fragments"};</script> <script type='text/javascript'>var gridlove_js_settings = {"rtl_mode":"","header_sticky":"1","header_sticky_offset":"100","header_sticky_up":"","logo":"https:\/\/digbr.com\/wp-content\/uploads\/2018\/02\/DIG-Logo-white-sm.png","logo_retina":"https:\/\/digbr.com\/wp-content\/uploads\/2018\/02\/DIG-Logo-white-ret.png","logo_mini":"https:\/\/digbr.com\/wp-content\/uploads\/2018\/02\/DIG-Logo-white-mini2.png","logo_mini_retina":"","gridlove_gallery":"1"};</script> <script type='text/javascript'>var the_ajax_script = {"ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php","postnonce":"f69a6c7e16"};</script> <script type='text/javascript' src='https://maps.googleapis.com/maps/api/js?ver=1.0'></script> <script type='text/javascript'>var mc4wp_vars = {"ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php","ajax_loader_url":"https:\/\/digbr.com\/wp-content\/plugins\/mailchimp-for-wp-pro\/assets\/img\/ajax-loader.gif"};</script>  </style>  <script type="text/javascript" defer src="https://digbr.com/wp-content/cache/autoptimize/js/autoptimize_2b0972682d67c002f5613295efc27523.js"></script></body></html>