<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#" class="no-js"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width,initial-scale=1.0"><link type="text/css" media="all" href="https://digbr.com/wp-content/cache/autoptimize/css/autoptimize_dba4c6ee8427b18c15dec544da5bce9a.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://digbr.com/wp-content/cache/autoptimize/css/autoptimize_4f48808b489246de2f8fd72dc317b715.css" rel="stylesheet" /><link type="text/css" media="only screen and (max-width: 768px)" href="https://digbr.com/wp-content/cache/autoptimize/css/autoptimize_cfc7e39d708c2a6d0ed80d0180ecdb98.css" rel="stylesheet" /><title>A food journey with Iverstine Family Farms &#8211; Dig Baton Rouge</title><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Dig Baton Rouge &raquo; Feed" href="https://digbr.com/feed/" /><link rel="alternate" type="text/calendar" title="Dig Baton Rouge &raquo; iCal Feed" href="https://digbr.com/events/?ical=1" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/digbr.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='gridlove-fonts-css'  href='https://fonts.googleapis.com/css?family=Cabin%3A400%2C700%7CLato%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;ver=1.4.2' type='text/css' media='all' /><link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A700%2C400%2C400i%7CRoboto%3A700%2C400&#038;ver=4.9.1' type='text/css' media='screen' /><link rel='stylesheet' id='mailchimp-for-wp-css'  href='https://digbr.com/wp-content/plugins/mailchimp-for-wp-pro/assets/css/css.php?checkbox=1&#038;ver=1.98.7' type='text/css' media='all' /> <script type='text/javascript'>var tribe_events_linked_posts = {"post_types":{"tribe_venue":"venue","tribe_organizer":"organizer"}};</script> <script type='text/javascript' src='https://digbr.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript'>var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/a-food-journey-with-iverstine-family-farms\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View Cart","cart_url":"https:\/\/digbr.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};</script> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/arrive/2.4.1/arrive.min.js?ver=2.4.1'></script> <script type='text/javascript'>var tribe_this_week = {"ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php"};</script> <link rel='https://api.w.org/' href='https://digbr.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://digbr.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://digbr.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Jay Picks Six for Restaurant Week' href='https://digbr.com/jay-picks-six-for-restaurant-week/' /><link rel="canonical" href="https://digbr.com/a-food-journey-with-iverstine-family-farms/" /><link rel="alternate" type="application/json+oembed" href="https://digbr.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdigbr.com%2Fa-food-journey-with-iverstine-family-farms%2F" /><link rel="alternate" type="text/xml+oembed" href="https://digbr.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdigbr.com%2Fa-food-journey-with-iverstine-family-farms%2F&#038;format=xml" /><meta property="fb:app_id" content="713095298769737" /> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MW6NQMQ');</script>  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-21029509-1', 'auto');
  ga('send', 'pageview');</script><script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":69233,"post_name":"a-food-journey-with-iverstine-family-farms","post_title":"A food journey with Iverstine Family Farms","post_type":"post","post_author":"10000223","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":13,"name":"Food &amp; Drink","slug":"food-drink","term_group":0,"term_taxonomy_id":13,"taxonomy":"category","description":"","parent":10,"count":624,"filter":"raw","cat_ID":13,"category_count":624,"category_description":"","cat_name":"Food &amp; Drink","category_nicename":"food-drink","category_parent":10}]; _mmunch['postTags'] = [{"term_id":458,"name":"FEATURED","slug":"featured","term_group":0,"term_taxonomy_id":458,"taxonomy":"post_tag","description":"","parent":0,"count":5,"filter":"raw"},{"term_id":457,"name":"NOW","slug":"now","term_group":0,"term_taxonomy_id":457,"taxonomy":"post_tag","description":"For homepage block","parent":0,"count":311,"filter":"raw"}]; _mmunch['postAuthor'] = {"name":"","ID":""};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="86056" async></script> <script type="text/javascript">jQuery(document).ready(function() {
				// CUSTOM AJAX CONTENT LOADING FUNCTION
				var ajaxRevslider = function(obj) {
				
					// obj.type : Post Type
					// obj.id : ID of Content to Load
					// obj.aspectratio : The Aspect Ratio of the Container / Media
					// obj.selector : The Container Selector where the Content of Ajax will be injected. It is done via the Essential Grid on Return of Content
					
					var content = "";

					data = {};
					
					data.action = 'revslider_ajax_call_front';
					data.client_action = 'get_slider_html';
					data.token = '13303aac7d';
					data.type = obj.type;
					data.id = obj.id;
					data.aspectratio = obj.aspectratio;
					
					// SYNC AJAX REQUEST
					jQuery.ajax({
						type:"post",
						url:"https://digbr.com/wp-admin/admin-ajax.php",
						dataType: 'json',
						data:data,
						async:false,
						success: function(ret, textStatus, XMLHttpRequest) {
							if(ret.success == true)
								content = ret.data;								
						},
						error: function(e) {
							console.log(e);
						}
					});
					
					 // FIRST RETURN THE CONTENT WHEN IT IS LOADED !!
					 return content;						 
				};
				
				// CUSTOM AJAX FUNCTION TO REMOVE THE SLIDER
				var ajaxRemoveRevslider = function(obj) {
					return jQuery(obj.selector+" .rev_slider").revkill();
				};

				// EXTEND THE AJAX CONTENT LOADING TYPES WITH TYPE AND FUNCTION
				var extendessential = setInterval(function() {
					if (jQuery.fn.tpessential != undefined) {
						clearInterval(extendessential);
						if(typeof(jQuery.fn.tpessential.defaults) !== 'undefined') {
							jQuery.fn.tpessential.defaults.ajaxTypes.push({type:"revslider",func:ajaxRevslider,killfunc:ajaxRemoveRevslider,openAnimationSpeed:0.3});   
							// type:  Name of the Post to load via Ajax into the Essential Grid Ajax Container
							// func: the Function Name which is Called once the Item with the Post Type has been clicked
							// killfunc: function to kill in case the Ajax Window going to be removed (before Remove function !
							// openAnimationSpeed: how quick the Ajax Content window should be animated (default is 0.3)
						}
					}
				},30);
			});</script> <script type='text/javascript'>var taqyeem = {"ajaxurl":"https://digbr.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};</script> <meta name="generator" content="EventON 2.5.5" /><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/> <!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://digbr.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://digbr.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><meta name="wpsso:mark:begin" content="wpsso meta tags begin"/><meta name="generator" content="WPSSO 3.45.3/G"/><link rel="shortlink" href="https://digbr.com/?p=69233"/><meta property="og:url" content="https://digbr.com/a-food-journey-with-iverstine-family-farms/"/><meta property="og:type" content="article"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="Dig Baton Rouge"/><meta property="og:title" content="A food journey with Iverstine Family Farms"/><meta property="og:description" content="For most of us, we just don&rsquo;t have the space nor time (nor know-how) to run our own backyard farm. Sure, we have some awesome veggies growing, but livestock? That&rsquo;s a whole different animal. I, for one, am making a conscious effort in 2018 to learn a little more about the meat I... #featured #now"/><meta property="og:image" content="https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-600x315.jpg"/><meta property="og:image:width" content="600"/><meta property="og:image:height" content="315"/><meta property="article:author" content="https://www.facebook.com/thecurioustastebud/"/><meta property="article:published_time" content="2017-12-29T15:00:37+00:00"/><meta property="article:modified_time" content="2017-12-28T18:43:11+00:00"/><meta property="article:tag" content="featured"/><meta property="article:tag" content="now"/><meta property="og:updated_time" content="2017-12-28T18:43:11+00:00"/><meta name="weibo:article:create_at" content="2017-12-29 15:00:37"/><meta name="weibo:article:update_at" content="2017-12-28 18:43:11"/><meta name="twitter:domain" content="digbr.com"/><meta name="twitter:title" content="A food journey with Iverstine Family Farms"/><meta name="twitter:description" content="For most of us, we just don&rsquo;t have the space nor time (nor know-how) to run our own backyard farm. Sure, we have some awesome veggies growing, but livestock? That&rsquo;s a whole... #featured #now"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-800x533.jpg"/><link itemprop="url" href="https://digbr.com/a-food-journey-with-iverstine-family-farms/"/><meta itemprop="name" content="A food journey with Iverstine Family Farms"/><meta itemprop="description" content="For most of us, we just don&rsquo;t have the space nor time (nor know-how) to run our own backyard farm. Sure, we have some awesome veggies growing, but livestock? That&rsquo;s a whole different animal. I, for one, am making a conscious effort in 2018 to..."/><meta itemprop="datePublished" content="2017-12-29T15:00:37+00:00"/><meta itemprop="dateModified" content="2017-12-28T18:43:11+00:00"/><meta name="description" content="For most of us, we just don&rsquo;t have the space nor time (nor know-how) to run our own backyard farm. Sure, we have some awesome veggies growing, but..."/> <noscript itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Ailsa von Dobeneck"/> </noscript> <noscript itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><link itemprop="url" href="https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-800x533.jpg"/><meta itemprop="width" content="800"/><meta itemprop="height" content="533"/> </noscript><meta name="wpsso:mark:end" content="wpsso meta tags end"/><noscript><style type="text/css">.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head><body class="post-template-default single single-post postid-69233 single-format-standard unknown wpb-js-composer js-comp-ver-4.11.2.1 vc_responsive"><header id="header" class="gridlove-site-header hidden-md-down  gridlove-header-shadow"><div class="gridlove-header-wrapper"><div class="gridlove-header-1 gridlove-header-middle container"><div class="gridlove-slot-l"><div class="gridlove-site-branding  "> <span class="site-title h1"><a href="https://digbr.com/" rel="home"><img class="gridlove-logo" src="https://digbr.com/wp-content/uploads/2017/09/DIG-REG.png" alt="Dig Baton Rouge"></a></span></div></div><div class="gridlove-slot-r"><nav class="gridlove-main-navigation"><ul id="menu-main-menu" class="gridlove-main-nav gridlove-menu"><li id="menu-item-6979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6979"><a href="https://digbr.com/category/news/campus/">LSU</a></li><li id="menu-item-6977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6977"><a href="https://digbr.com/category/news/">NEWS</a><ul class="sub-menu"><li id="menu-item-66360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66360"><a href="https://digbr.com/category/news/crime/">Crime</a></li><li id="menu-item-66359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66359"><a href="https://digbr.com/category/news/biz/">Business</a></li><li id="menu-item-7141" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7141"><a href="https://digbr.com/category/news/opinion/">Opinion</a></li></ul></li><li id="menu-item-7306" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-7306"><a href="https://digbr.com/category/leisure/">LEISURE</a><ul class="sub-menu"><li id="menu-item-66358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66358"><a href="https://digbr.com/the-lineup/">Things to do</a></li><li id="menu-item-66393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66393"><a href="https://digbr.com/food-drink/">Food &#038; Drink</a></li><li id="menu-item-6969" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6969"><a href="https://digbr.com/category/leisure/arts-culture/">Arts &#038; Culture</a></li><li id="menu-item-6972" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6972"><a href="https://digbr.com/category/leisure/music/">Music</a></li><li id="menu-item-31878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31878"><a href="https://digbr.com/category/leisure/fitness/">Health &#038; Fitness</a></li></ul></li><li id="menu-item-7316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7316"><a href="https://digbr.com/category/sports/">SPORTS</a></li><li id="menu-item-47579" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47579"><a href="#">FUN STUFF!</a><ul class="sub-menu"><li id="menu-item-47583" class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-47583"><a href="https://digbr.com/product-category/ticketed-event/">DIG Events</a></li><li id="menu-item-7155" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7155"><a href="https://digbr.com/category/galleries/">Galleries</a></li></ul></li><li id="menu-item-66363" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66363"><a href="https://digbr.com/brag17/">BRAG17</a></li><li id="menu-item-66741" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66741"><a href="https://digbr.com/category/magazine/">MAGAZINE</a></li></ul></nav><ul class="gridlove-actions gridlove-menu"><li class="gridlove-actions-button gridlove-action-search"> <span> <i class="fa fa-search"></i> </span><ul class="sub-menu"><li><form class="gridlove-search-form" action="https://digbr.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form></li></ul></li><li class="gridlove-actions-button"> <span class="gridlove-sidebar-action"> <i class="fa fa-bars"></i> </span></li></ul></div></div></div><div id="gridlove-header-sticky" class="gridlove-header-sticky"><div class="container"><div class="gridlove-slot-l"><div class="gridlove-site-branding mini"> <span class="site-title h1"><a href="https://digbr.com/" rel="home"><img class="gridlove-logo-mini" src="https://digbr.com/wp-content/uploads/2017/09/DIG-mobile.png" alt="Dig Baton Rouge"></a></span></div></div><div class="gridlove-slot-r"><nav class="gridlove-main-navigation"><ul id="menu-main-menu-1" class="gridlove-main-nav gridlove-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6979"><a href="https://digbr.com/category/news/campus/">LSU</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6977"><a href="https://digbr.com/category/news/">NEWS</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66360"><a href="https://digbr.com/category/news/crime/">Crime</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66359"><a href="https://digbr.com/category/news/biz/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7141"><a href="https://digbr.com/category/news/opinion/">Opinion</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-7306"><a href="https://digbr.com/category/leisure/">LEISURE</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66358"><a href="https://digbr.com/the-lineup/">Things to do</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66393"><a href="https://digbr.com/food-drink/">Food &#038; Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6969"><a href="https://digbr.com/category/leisure/arts-culture/">Arts &#038; Culture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6972"><a href="https://digbr.com/category/leisure/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31878"><a href="https://digbr.com/category/leisure/fitness/">Health &#038; Fitness</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7316"><a href="https://digbr.com/category/sports/">SPORTS</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47579"><a href="#">FUN STUFF!</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-47583"><a href="https://digbr.com/product-category/ticketed-event/">DIG Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7155"><a href="https://digbr.com/category/galleries/">Galleries</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66363"><a href="https://digbr.com/brag17/">BRAG17</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66741"><a href="https://digbr.com/category/magazine/">MAGAZINE</a></li></ul></nav><ul class="gridlove-actions gridlove-menu"><li class="gridlove-actions-button gridlove-action-search"> <span> <i class="fa fa-search"></i> </span><ul class="sub-menu"><li><form class="gridlove-search-form" action="https://digbr.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form></li></ul></li><li class="gridlove-actions-button"> <span class="gridlove-sidebar-action"> <i class="fa fa-bars"></i> </span></li></ul></div></div></div></header><div id="gridlove-header-responsive" class="gridlove-header-responsive hidden-lg-up"><div class="container"><div class="gridlove-site-branding mini"> <span class="site-title h1"><a href="https://digbr.com/" rel="home"><img class="gridlove-logo-mini" src="https://digbr.com/wp-content/uploads/2017/09/DIG-mobile.png" alt="Dig Baton Rouge"></a></span></div><ul class="gridlove-actions gridlove-menu"><li class="gridlove-actions-button gridlove-action-search"> <span> <i class="fa fa-search"></i> </span><ul class="sub-menu"><li><form class="gridlove-search-form" action="https://digbr.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form></li></ul></li><li class="gridlove-actions-button"> <span class="gridlove-sidebar-action"> <i class="fa fa-bars"></i> </span></li></ul></div></div><div id="content" class="gridlove-site-content container gridlove-sidebar-right"><div class="row"><div class="gridlove-share-wrapper"><div class="gridlove-share gridlove-box gridlove-sticky-share"><a href="javascript:void(0);" class="gridlove-facebook gridlove-share-item" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fdigbr.com%2Fa-food-journey-with-iverstine-family-farms%2F&amp;t=A+food+journey+with+Iverstine+Family+Farms"><i class="fa fa-facebook"></i></a> <a href="javascript:void(0);" class="gridlove-twitter gridlove-share-item" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fdigbr.com%2Fa-food-journey-with-iverstine-family-farms%2F&amp;text=A+food+journey+with+Iverstine+Family+Farms"><i class="fa fa-twitter"></i></a> <a href="/cdn-cgi/l/email-protection#724d010710181711064f3359141d1d1659181d07001c170b59051b061a593b04170001061b1c175934131f1b1e0b593413001f0154131f0249101d160b4f1a06060201574133574034574034161b1510005c111d1f574034135f141d1d165f181d07001c170b5f051b061a5f1b04170001061b1c175f14131f1b1e0b5f1413001f01574034" class="gridlove-mailto"><i class="fa fa-envelope-o"></i></a> <a href="javascript:void(0);"  class="gridlove-linkedin gridlove-share-item" data-url="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://digbr.com/a-food-journey-with-iverstine-family-farms/&amp;title=A food journey with Iverstine Family Farms"><i class="fa fa-linkedin"></i></a></div></div><div class="gridlove-content gridlove-single-layout-1"><article id="post-69233" class="gridlove-box box-vm post-69233 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink tag-featured tag-now"><div class="entry-image"> <img width="740" height="493" src="https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-740x493.jpg" class="attachment-gridlove-single size-gridlove-single wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-740x493.jpg 740w, https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-300x200.jpg 300w, https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-768x512.jpg 768w, https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-1024x683.jpg 1024w, https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-150x100.jpg 150w, https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-600x400.jpg 600w, https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-1032x688.jpg 1032w, https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-800x533.jpg 800w, https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4.jpg 1200w" sizes="(max-width: 740px) 100vw, 740px" data-wp-pid="69241" nopin="nopin" /></div><div class="box-inner-p-bigger box-single"><div class="entry-header"><div class="entry-category"> <a href="https://digbr.com/category/leisure/food-drink/" class="gridlove-cat gridlove-cat-13">Food &amp; Drink</a></div><h1 class="entry-title">A food journey with Iverstine Family Farms</h1><div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="https://digbr.com/author/ailsavondobeneck/"><img alt='' src='https://secure.gravatar.com/avatar/e871270231da738061e060b5f2cf4c7d?s=24&#038;d=mm&#038;r=g' class='avatar avatar-24 photo' height='24' width='24' /> Ailsa von Dobeneck</a></span></span></div><div class="meta-item meta-date"><span class="updated">5 mins ago</span></div></div></div><div class="entry-content"><div class="wpsso-schema-image-for-pinterest" style="display:none;"> <img src="https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-800x533.jpg" width="0" height="0" style="width:0;height:0;" data-pin-description="For most of us, we just don&rsquo;t have the space nor time (nor know-how) to run our own backyard farm. Sure, we have some awesome veggies growing, but livestock? That&rsquo;s a whole different animal. I, for one, am making a conscious effort in 2018 to..."/></div><div class='mailmunch-forms-before-post' style='display: none !important;'></div><p class="p1">For most of us, we just don’t have the space nor time (nor know-how) to run our own backyard farm. Sure, we have some awesome veggies growing, but livestock? That’s a whole different animal. I, for one, am making a conscious effort in 2018 to learn a little more about the meat</p><p class="p1">I eat. Truth be told, a lot of the neatly wrapped proteins at the grocery (unless otherwise marked) come from an industrialized farm that doesn’t look much like a farm at all. I want to know the protein I am eating is fresh, as local as possible, and was well-cared for before it came to me. Buying from a local butcher offers just that. This month Perkin’s Road staple, Iverstine Family Farms, gave us a full farm-to-table education and made it clear why butcher shops are back in a major way.</p><p class="p1"><img class="aligncenter size-large wp-image-69234" src="https://digbr.com/wp-content/uploads/2017/12/IFB-3-cows--1024x683.jpg" alt="" width="770" height="514" data-wp-pid="69234" srcset="https://digbr.com/wp-content/uploads/2017/12/IFB-3-cows--1024x683.jpg 1024w, https://digbr.com/wp-content/uploads/2017/12/IFB-3-cows--300x200.jpg 300w, https://digbr.com/wp-content/uploads/2017/12/IFB-3-cows--768x512.jpg 768w, https://digbr.com/wp-content/uploads/2017/12/IFB-3-cows--150x100.jpg 150w, https://digbr.com/wp-content/uploads/2017/12/IFB-3-cows--600x400.jpg 600w, https://digbr.com/wp-content/uploads/2017/12/IFB-3-cows--1032x688.jpg 1032w, https://digbr.com/wp-content/uploads/2017/12/IFB-3-cows--740x493.jpg 740w, https://digbr.com/wp-content/uploads/2017/12/IFB-3-cows--800x533.jpg 800w, https://digbr.com/wp-content/uploads/2017/12/IFB-3-cows-.jpg 1200w" sizes="(max-width: 770px) 100vw, 770px" /></p><p class="p1">Phase 1: We put on those rubber boots and headed out to the farm. On their 65 acres of land in Kentwood, the Iverstine family raises the chickens, hogs, turkeys, cattle and lamb that supply the butcher shop in Baton Rouge. It is a passion for Galen Iverstine, who started the business with his parents after the purchase of two pigs.</p><p class="p1">“After finishing my degree in political science at LSU in 2009, I really got into learning about sustainable methods of farming,” Iverstine said. He then headed to a farm in New Hampshire to learn the ropes. Galen returned eager to bring high-quality local meat to market. “We started selling at the Farmer’s market in 2010 and have been growing ever since.”</p><p class="p1">We took a walk through the fields while Galen gave us the rundown of his intensive rotational multi-species grazing practices (try that one five times fast). To translate, he and his team move the cows and chickens daily, allowing for fertilizer to be evenly spread and good root systems to develop. The chickens move in after the cows and it all becomes this kind of symbiotic dance between the animals and the land, ensuring everything is in balance and the pastures aren’t depleted.</p><p><img class="aligncenter size-large wp-image-69237" src="https://digbr.com/wp-content/uploads/2017/12/IFB-Galen-and-pigs-7-1024x683.jpg" alt="" width="770" height="514" data-wp-pid="69237" srcset="https://digbr.com/wp-content/uploads/2017/12/IFB-Galen-and-pigs-7-1024x683.jpg 1024w, https://digbr.com/wp-content/uploads/2017/12/IFB-Galen-and-pigs-7-300x200.jpg 300w, https://digbr.com/wp-content/uploads/2017/12/IFB-Galen-and-pigs-7-768x512.jpg 768w, https://digbr.com/wp-content/uploads/2017/12/IFB-Galen-and-pigs-7-150x100.jpg 150w, https://digbr.com/wp-content/uploads/2017/12/IFB-Galen-and-pigs-7-600x400.jpg 600w, https://digbr.com/wp-content/uploads/2017/12/IFB-Galen-and-pigs-7-1032x688.jpg 1032w, https://digbr.com/wp-content/uploads/2017/12/IFB-Galen-and-pigs-7-740x493.jpg 740w, https://digbr.com/wp-content/uploads/2017/12/IFB-Galen-and-pigs-7-800x533.jpg 800w, https://digbr.com/wp-content/uploads/2017/12/IFB-Galen-and-pigs-7.jpg 1200w" sizes="(max-width: 770px) 100vw, 770px" /></p><p class="p1">We then visited with the Berkshire pigs. I had heard of the breed as their pork, known for its richness in flavor and texture, often makes the menus of some of the country’s best restaurants. Iverstine Farms now produces 320 hogs a year, which roam on a large plot of low brush but they never stray too far from the grain feeder.</p><p class="p1">“The cattle are purely grass-fed and the poultry and pigs have a grass/ grain split, ensuring healthy happy animals and great taste on the plate,” said Iverstine.</p><p class="p1">We hopped in the car and headed to the Perkins Road store to test the results of this labor of love. The Iverstines’ right hand man at the butcher shop, Aarden, was an amazing and enthusiastic guide. They have everything you would expect and lots of new things to try.</p><p class="p1"><img class="aligncenter size-large wp-image-69239" src="https://digbr.com/wp-content/uploads/2017/12/IFB-shop-4--1024x683.jpg" alt="" width="770" height="514" data-wp-pid="69239" srcset="https://digbr.com/wp-content/uploads/2017/12/IFB-shop-4--1024x683.jpg 1024w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-4--300x200.jpg 300w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-4--768x512.jpg 768w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-4--150x100.jpg 150w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-4--600x400.jpg 600w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-4--1032x688.jpg 1032w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-4--740x493.jpg 740w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-4--800x533.jpg 800w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-4-.jpg 1200w" sizes="(max-width: 770px) 100vw, 770px" /></p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div><p class="p1">Their succulent pork chops and sausages, which they make in house, are some of the best sellers. We tried the beef and pork, green onion, and “flying Hawaiian” sausage varieties. The beef and pork was hearty and traditional, while the green onion had a bit of a bite. The flying Hawaiian, made with pineapple and jalapeno, was my favorite. It has this amazing sweetness and kick that is a completely unique and a welcome surprise. All will be making an appearance on my grill this spring. They also have boudin for those in search of Louisiana favorites.</p><p class="p1">While we snacked, Aarden gave us a taste of the flexibility and expertise they offer shoppers.</p><p class="p1">“We are a whole animal shop,” said Aarden, “so if you need a certain cut or quantity, just give us a call or come on in. We can work with you to make sure you get exactly what you need. We get folks in from all cultures and backgrounds who use different cuts for traditional recipes. There is something for everyone.”</p><p class="p1"><img class="aligncenter size-large wp-image-69235" src="https://digbr.com/wp-content/uploads/2017/12/IFB-butcher--1024x683.jpg" alt="" width="770" height="514" data-wp-pid="69235" srcset="https://digbr.com/wp-content/uploads/2017/12/IFB-butcher--1024x683.jpg 1024w, https://digbr.com/wp-content/uploads/2017/12/IFB-butcher--300x200.jpg 300w, https://digbr.com/wp-content/uploads/2017/12/IFB-butcher--768x512.jpg 768w, https://digbr.com/wp-content/uploads/2017/12/IFB-butcher--150x100.jpg 150w, https://digbr.com/wp-content/uploads/2017/12/IFB-butcher--600x400.jpg 600w, https://digbr.com/wp-content/uploads/2017/12/IFB-butcher--1032x688.jpg 1032w, https://digbr.com/wp-content/uploads/2017/12/IFB-butcher--740x493.jpg 740w, https://digbr.com/wp-content/uploads/2017/12/IFB-butcher--800x533.jpg 800w, https://digbr.com/wp-content/uploads/2017/12/IFB-butcher-.jpg 1200w" sizes="(max-width: 770px) 100vw, 770px" /></p><p class="p1">They also have your grocery store staples. A variety of steak lines the counter, they have chicken breast, and you can get your ground beef made to your preferred fat content. They recommend 80/20 but, again, are flexible to your needs. Aarden’s positive “can do” vibe was so refreshing that I felt excited to get cooking.</p><p class="p1">Iverstine Farms also offers weekly lunch specials for take-out (in the $7-$10 range). The “Cuban Sandwich Crisis” has been a staple and this week they were also offering “Porko Villa Tacos,” which were phenomenal.</p><p class="p1"><img class="aligncenter size-large wp-image-69240" src="https://digbr.com/wp-content/uploads/2017/12/IFB-tacos-2--1024x683.jpg" alt="" width="770" height="514" data-wp-pid="69240" srcset="https://digbr.com/wp-content/uploads/2017/12/IFB-tacos-2--1024x683.jpg 1024w, https://digbr.com/wp-content/uploads/2017/12/IFB-tacos-2--300x200.jpg 300w, https://digbr.com/wp-content/uploads/2017/12/IFB-tacos-2--768x512.jpg 768w, https://digbr.com/wp-content/uploads/2017/12/IFB-tacos-2--150x100.jpg 150w, https://digbr.com/wp-content/uploads/2017/12/IFB-tacos-2--600x400.jpg 600w, https://digbr.com/wp-content/uploads/2017/12/IFB-tacos-2--1032x688.jpg 1032w, https://digbr.com/wp-content/uploads/2017/12/IFB-tacos-2--740x493.jpg 740w, https://digbr.com/wp-content/uploads/2017/12/IFB-tacos-2--800x533.jpg 800w, https://digbr.com/wp-content/uploads/2017/12/IFB-tacos-2-.jpg 1200w" sizes="(max-width: 770px) 100vw, 770px" /></p><p class="p1">Loaded with pulled pork and pickled veggies (both made in-house), the flavor was rich and decadent. I could have eaten five easily. Full and happy, I felt like I had a new understanding and appreciation of butchers and was encouraged by how accessible they are in Baton Rouge.</p><p class="p1">For catering options, lunch menus, and all their offerings visit <a href="https://www.iverstinefarms.com/">IverstineFarms.com</a>. The store is located at 4765 Perkins Road.</p><p><em><img class="aligncenter size-large wp-image-69238" src="https://digbr.com/wp-content/uploads/2017/12/IFB-shop-2--1024x683.jpg" alt="" width="770" height="514" data-wp-pid="69238" srcset="https://digbr.com/wp-content/uploads/2017/12/IFB-shop-2--1024x683.jpg 1024w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-2--300x200.jpg 300w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-2--768x512.jpg 768w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-2--150x100.jpg 150w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-2--600x400.jpg 600w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-2--1032x688.jpg 1032w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-2--740x493.jpg 740w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-2--800x533.jpg 800w, https://digbr.com/wp-content/uploads/2017/12/IFB-shop-2-.jpg 1200w" sizes="(max-width: 770px) 100vw, 770px" />Images: Sean Gasser</em></p><div class='mailmunch-forms-after-post' style='display: none !important;'></div></div></div></article><div class="gridlove-ad"><a href="#"><img src="https://mekshq.com/static/gridlove/gridlove_ad_728x90.jpg" alt=""></a></div><div style="padding: 40px 60px 50px; background-color: #fff; box-shadow: 0 3px 5px 0 rgba(0,1,1,.1); margin-bottom: 30px;"><h3>Comments</h3><div class="fb-comments" data-href="https://digbr.com/a-food-journey-with-iverstine-family-farms/" data-numposts="5" data-width="100%"></div></div><div class="gridlove-related"><div class="gridlove-module"><div class="module-header"><div class="module-title"><h4 class="h2">You may also like</h2></div></div><div class="row"><div class="col-lg-12 col-md-12 col-sm-12"><article class="gridlove-post gridlove-post-b gridlove-box  post-69224 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-magazine tag-featured tag-now"><div class="entry-image"> <a href="https://digbr.com/jay-picks-six-for-restaurant-week/" title="Jay Picks Six for Restaurant Week"><img width="385" height="300" src="https://digbr.com/wp-content/uploads/2017/12/JayDucoteJan2018-385x300.jpg" class="attachment-gridlove-b8 size-gridlove-b8 wp-post-image" alt="" data-wp-pid="69228" nopin="nopin" /></a></div><div class="box-inner-ptbr box-col-b entry-sm-overlay"><div class="box-inner-ellipsis"><div class="entry-category"> <a href="https://digbr.com/category/leisure/food-drink/" class="gridlove-cat gridlove-cat-13">Food &amp; Drink</a><a href="https://digbr.com/category/magazine/" class="gridlove-cat gridlove-cat-482">MAGAZINE</a></div><h2 class="entry-title h3"><a href="https://digbr.com/jay-picks-six-for-restaurant-week/">Jay Picks Six for Restaurant Week</a></h2><div class="entry-content"><p>Restaurant Week is back and I’m ready to DIG in! Each January and July presents a weeklong feeding frenzy around Baton rouge. I’m no stranger to the dining scene around here, so I compiled a list of six eateries that I’m looking forward to checking...</p></div></div><div class="entry-meta"><div class="meta-item meta-date"><span class="updated">36 mins ago</span></div></div></div></article></div></div></div></div></div><div class="gridlove-sidebar"><div id="shortcode-widget-2" class="widget gridlove-box shortcode_widget"><div class="textwidget"><article class="custom-614 gridlove-post gridlove-post-d gridlove-box post type-post status-publish format-standard has-post-thumbnail hentry"> <script data-cfasync="false" src="/cdn-cgi/scripts/af2821b0/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">ga('send', 'event', 'ads', 'impressions', 'Hungry Howie's - A food journey with Iverstine Family Farms');</script> <div class="entry-image"><a onclick="ga('send', 'event', 'ads', 'clicks', 'Hungry Howie's - A food journey with Iverstine Family Farms');" href="https://www.hungryhowies.com" target="_blank"> <img width="700" height="600" src="https://digbr.com/wp-content/uploads/2017/08/HH9132.jpg" class="attachment-gridlove-d4 size-gridlove-d4 wp-post-image wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2017/08/HH9132.jpg 700w, https://digbr.com/wp-content/uploads/2017/08/HH9132-300x257.jpg 300w, https://digbr.com/wp-content/uploads/2017/08/HH9132-150x129.jpg 150w, https://digbr.com/wp-content/uploads/2017/08/HH9132-600x514.jpg 600w" sizes="(max-width: 700px) 100vw, 700px" data-wp-pid="66380" nopin="nopin" /> </a></div><div class="entry-overlay box-inner-p"><div class="box-inner-ellipsis"><h2 class="entry-title h3"> <a onclick="ga('send', 'event', 'ads', 'clicks', 'Hungry Howie's - A food journey with Iverstine Family Farms');" href="https://www.hungryhowies.com" target="_blank">Tailgate with Howie&#8217;s!</a></h2><div class="client" style="">Hungry Howie's</div></div></div></article></div></div><div id="mks_social_widget-4" class="widget gridlove-box mks_social_widget"><h4 class="widget-title">Follow Us</h4><ul class="mks_social_widget_ul"><li><a href="https://www.instagram.com/digbatonrouge/" class="instagram_ico soc_circle" target="_blank" style="width: 42px; height: 42px; font-size: 16px;"><span>instagram</span></a></li><li><a href="https://twitter.com/DigBatonRouge" class="twitter_ico soc_circle" target="_blank" style="width: 42px; height: 42px; font-size: 16px;"><span>twitter</span></a></li><li><a href="https://www.facebook.com/digbatonrouge/" class="facebook_ico soc_circle" target="_blank" style="width: 42px; height: 42px; font-size: 16px;"><span>facebook</span></a></li></ul></div><div data-is data-is-api="https://digbr.com/wp-content/plugins/elfsight-instashow/api/" data-is-source="#idigbr, @digbatonrouge" data-is-limit="21" data-is-cache-media-time="10600" data-is-columns="3" data-is-rows="4" data-is-gutter="1" data-is-direction="vertical" data-is-scrollbar="false" data-is-speed="600" data-is-auto="0" data-is-popup-speed="400" data-is-color-popup-username="rgb(0, 142, 255)" data-is-color-popup-username-hover="rgb(37, 181, 255)" data-is-color-popup-instagram-link="rgb(0, 142, 255)" data-is-color-popup-instagram-link-hover="rgb(37, 181, 255)" data-is-color-popup-counters="rgb(0, 0, 0)" data-is-color-popup-anchor="rgb(0, 142, 255)" data-is-color-popup-anchor-hover="rgb(37, 181, 255)" data-is-color-popup-text="rgb(0, 0, 0)"></div><div id="evcalwidget-2" class="widget gridlove-box EvcalWidget"><div id='evcal_widget' class='evo_widget'><div id='evcal_calendar_246' class='ajde_evcal_calendar  ul' ><div class='evo-data' data-cyear="2017" data-cmonth="12" data-runajax="1" data-evc_open="0" data-cal_ver="2.5.5" data-mapscroll="true" data-mapformat="roadmap" data-mapzoom="18" data-mapiconurl="" data-ev_cnt="5" data-show_limit="no" data-tiles="no" data-sort_by="sort_date" data-filters_on="false" data-range_start="0" data-range_end="0" data-send_unix="0" data-ux_val="0" data-accord="0" data-rtl="no"  ></div><div id='evcal_head' class='calendar_header ' ><div class='evo_cal_above'><span class='evo-gototoday-btn' style='display:none' data-mo='12' data-yr='2017' data-dy=''>Current Month</span></div><div class='evo_cal_above_content'></div><div class='cal_arguments' style='display:none' data-hide_past="yes" data-show_et_ft_img="no" data-event_order="ASC" data-ft_event_priority="no" data-lang="L1" data-month_incre="0" data-only_ft="no" data-evc_open="no" data-show_limit="no" data-etc_override="no" data-show_limit_redir="0" data-tiles="no" data-tile_height="0" data-tile_bg="0" data-tile_count="2" data-tile_style="0" data-s="" data-members_only="no" data-ux_val="0" data-show_limit_ajax="no" data-show_limit_paged="1" ></div><div class='clear'></div></div><div class='evcal_month_line'><p>december</p></div><div id='evcal_list' class='eventon_events_list '><div id="event_69115" class="eventon_list_event  event" data-event_id="69115" data-time="1514534400-1514584800" data-colr="#ff057a" itemscope itemtype='http://schema.org/Event' 1><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/coffee-on-the-porch/'></a><span itemprop='name'  >Coffee on the Porch</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2017/12/coffee-300x124.jpg' ></meta><meta itemprop='description' content='This month, join Mid City Studio Baton Rouge at the Main Library at Goodwood for the final Coffee on the Porch of 2017! There will be free coffee' ></meta><meta itemprop='startDate' content='2017-12-29' ></meta><meta itemprop='endDate' content='2017-12-29' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Main Library at Goodwood</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress"> 7711 Goodwood Blvd, Baton Rouge, Louisiana 70806</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Coffee on the Porch",
							  	"startDate": "2017-12-29T08-08-00-00",
							  	"endDate": "2017-12-29T22-22-00-00",
							  	"image":"https://digbr.com/wp-content/uploads/2017/12/coffee-300x124.jpg",
							  	"description":"This month, join Mid City Studio Baton Rouge at the Main Library at Goodwood for the final Coffee on the Porch of 2017! There will be free coffee",
							  	"location":{
										"@type":"Place",
										"name":"Main Library at Goodwood",
										"address":" 7711 Goodwood Blvd, Baton Rouge, Louisiana 70806"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #ff057a;" id="evc_151453440069115" class="desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#ff057a' data-smon='december' data-syr='2017'><span class='evo_start '><em class='date'>29</em><em class='month'>dec</em><em class='time'><i>(dec 29)</i>8:00 am</em></span><span class='evo_end only_time'><em class='time'><i>(dec 29)</i>8:00 am</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.4437814,-91.1072014"  data-location_address=" 7711 Goodwood Blvd, Baton Rouge, Louisiana 70806" data-location_type="lonlat" data-location_name="Main Library at Goodwood" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Coffee on the Porch</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='525' data-imgwidth='1275'  style='background-image: url("https://digbr.com/wp-content/uploads/2017/12/coffee.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>This month, join Mid City Studio Baton Rouge at the Main Library at Goodwood for the final Coffee on the Porch of 2017! There will be free coffee</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell shorter_desc'><div class='eventon_details_shading_bot'><p class='eventon_shad_p' content='less'><span class='ev_more_text' data-txt='less'>more</span><span class='ev_more_arrow'></span></p></div><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>This month, join <a href="https://www.facebook.com/midcitystudioBR/" data-hovercard="/ajax/hovercard/page.php?id=173529469501183&amp;extragetparams=%7B%22directed_target_id%22%3A142035409777988%7D" data-hovercard-prefer-more-content-show="1">Mid City Studio Baton Rouge</a> at the <a href="https://www.facebook.com/MainLibraryatGoodwood/" data-hovercard="/ajax/hovercard/page.php?id=156137764401075&amp;extragetparams=%7B%22directed_target_id%22%3A142035409777988%7D" data-hovercard-prefer-more-content-show="1">Main Library at Goodwood</a> for the final Coffee on the Porch of 2017! There will be free coffee courtesy of <a href="https://www.facebook.com/Cafeciteaux/" data-hovercard="/ajax/hovercard/page.php?id=137199773146226&amp;extragetparams=%7B%22directed_target_id%22%3A142035409777988%7D" data-hovercard-prefer-more-content-show="1">Cafeciteaux Coffee Roasters</a>, breakfast treats courtesy of<a href="https://www.facebook.com/PaneraBreadBatonRougeLA/" data-hovercard="/ajax/hovercard/page.php?id=680885025311872&amp;extragetparams=%7B%22directed_target_id%22%3A142035409777988%7D" data-hovercard-prefer-more-content-show="1">Panera Bread</a>, and socializing with your neighbors! Special thanks to <a href="https://www.facebook.com/ebrpl/" data-hovercard="/ajax/hovercard/page.php?id=139196433860&amp;extragetparams=%7B%22directed_target_id%22%3A142035409777988%7D" data-hovercard-prefer-more-content-show="1">East Baton Rouge Parish Library</a> for hosting us!</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Friday) 8:00 am - 10:00 pm</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='462'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Main Library at Goodwood</p><p> 7711 Goodwood Blvd, Baton Rouge, Louisiana 70806</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=69115&amp;sunix=20171229T140000Z&amp;eunix=20171230T040000Z&amp;loca= 7711 Goodwood Blvd, Baton Rouge, Louisiana 70806&amp;locn=Main Library at Goodwood' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Coffee+on+the+Porch&amp;dates=20171229T140000Z/20171230T040000Z&amp;details=This+month%2C+join%C2%A0Mid+City+Studio+Baton+Rouge%C2%A0at+the%C2%A0Main+Library+at+Goodwood%C2%A0for+the+final+Coffee+on+the+Porch+of+2017%21+There+will+be+free+coffee&amp;location=Main+Library+at+Goodwood - +7711+Goodwood+Blvd%2C+Baton+Rouge%2C+Louisiana+70806' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_67609" class="eventon_list_event  event" data-event_id="67609" data-ri="35" data-time="1514570400-1514590200" data-colr="#ff057a" itemscope itemtype='http://schema.org/Event' 2><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/christmas-at-blue-bayou-drive-thru-light-show/&quest;ri&equals;35&amp;'></a><span itemprop='name'  >Christmas at Blue Bayou—Drive Thru Light Show</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2017/10/22729018_2013127448960505_2528513555774320832_n-300x131.jpg' ></meta><meta itemprop='description' content='Come start a new family tradition and drive thru over a mile of custom lights synchronized to music for you to listen to through your own car radio! Tickets are' ></meta><meta itemprop='startDate' content='2017-12-29' ></meta><meta itemprop='endDate' content='2017-12-29' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Blue Bayou Water Park</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">18142 Perkins Road </item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Christmas at Blue Bayou—Drive Thru Light Show",
							  	"startDate": "2017-12-29T18-18-00-00",
							  	"endDate": "2017-12-29T23-23-30-00",
							  	"image":"https://digbr.com/wp-content/uploads/2017/10/22729018_2013127448960505_2528513555774320832_n-300x131.jpg",
							  	"description":"Come start a new family tradition and drive thru over a mile of custom lights synchronized to music for you to listen to through your own car radio! Tickets are",
							  	"location":{
										"@type":"Place",
										"name":"Blue Bayou Water Park",
										"address":"18142 Perkins Road "
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #ff057a;" id="evc_151457040067609" class="event_repeat desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#ff057a' data-smon='december' data-syr='2017'><span class='evo_start '><em class='date'>29</em><em class='month'>dec</em><em class='time'><i>(dec 29)</i>6:00 pm</em></span><span class='evo_end only_time'><em class='time'><i>(dec 29)</i>6:00 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.343012,-91.030171"  data-location_address="18142 Perkins Road " data-location_type="lonlat" data-location_name="Blue Bayou Water Park" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Christmas at Blue Bayou—Drive Thru Light Show</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='420' data-imgwidth='960'  style='background-image: url("https://digbr.com/wp-content/uploads/2017/10/22729018_2013127448960505_2528513555774320832_n.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>Come start a new family tradition and drive thru over a mile of custom lights synchronized to music for you to listen to through your own car radio! Tickets are</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>Come start a new family tradition and drive thru over a mile of custom lights synchronized to music for you to listen to through your own car radio! Tickets are sold at the gate with cash, credit card and debit card for $28.00 (tax included) per car (up to 8 passengers).</p><p>The light show starts November 24th, 2017 and goes through January 7th, 2018.</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Friday) 6:00 pm - 11:30 pm</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='531'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Blue Bayou Water Park</p><p>18142 Perkins Road</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_learnMICS evorow bordb '><div class='tb'><div class='tbrow'> <a class='evcal_col50 dark1 bordr evo_clik_row' href='https://www.facebook.com/ChristmasatBlueBayou/' target="_blank"> <span class='evcal_evdata_row ' > <span class='evcal_evdata_icons'><i class='fa fa-link'></i></span><h3 class='evo_h3'>Learn More</h3> </span> </a><div class='evo_ics evcal_col50 dark1 evo_clik_row' ><div class='evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=67609&amp;sunix=20171230T000000Z&amp;eunix=20171230T053000Z&amp;loca=18142 Perkins Road &amp;locn=Blue Bayou Water Park' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Christmas+at+Blue+Bayou%E2%80%94Drive+Thru+Light+Show&amp;dates=20171230T000000Z/20171230T053000Z&amp;details=Come+start+a+new+family+tradition+and+drive+thru+over+a+mile+of+custom+lights+synchronized+to+music+for+you+to+listen+to+through+your+own+car+radio%21+Tickets+are&amp;location=Blue+Bayou+Water+Park - 18142+Perkins+Road+' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div></div></div></div></div><div class='clear end'></div></div><div id="event_68875" class="eventon_list_event  event" data-event_id="68875" data-ri="3" data-time="1514570400-1514577600" data-colr="#ff057a" itemscope itemtype='http://schema.org/Event' 3><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/omg-friday-nights-at-la-divina-cafe/&quest;ri&equals;3&amp;'></a><span itemprop='name'  >OMG Friday Nights at La Divina Cafe</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2017/12/omg-300x150.jpg' ></meta><meta itemprop='description' content='OMG! Original Music Gathering!Get your spot in the spotlight! Enjoy great talent.How Do OMG Friday's work? We primarily feature original singer/songwriters... but have also hosted comedy skits, poetry, various instruments,' ></meta><meta itemprop='startDate' content='2017-12-29' ></meta><meta itemprop='endDate' content='2017-12-29' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">La Divina Cafe</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">3535 Perkins Road Suite 360</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "OMG Friday Nights at La Divina Cafe",
							  	"startDate": "2017-12-29T18-18-00-00",
							  	"endDate": "2017-12-29T20-20-00-00",
							  	"image":"https://digbr.com/wp-content/uploads/2017/12/omg-300x150.jpg",
							  	"description":"OMG! Original Music Gathering!

Get your spot in the spotlight! Enjoy great talent.

How Do OMG Friday's work? We primarily feature original singer/songwriters... but have also hosted comedy skits, poetry, various instruments,",
							  	"location":{
										"@type":"Place",
										"name":"La Divina Cafe",
										"address":"3535 Perkins Road Suite 360"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #ff057a;" id="evc_151457040068875" class="event_repeat desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#ff057a' data-smon='december' data-syr='2017'><span class='evo_start '><em class='date'>29</em><em class='month'>dec</em><em class='time'><i>(dec 29)</i>6:00 pm</em></span><span class='evo_end only_time'><em class='time'><i>(dec 29)</i>6:00 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata '  data-location_address="3535 Perkins Road Suite 360" data-location_type="address" data-location_name="La Divina Cafe" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>OMG Friday Nights at La Divina Cafe</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='960' data-imgwidth='1920'  style='background-image: url("https://digbr.com/wp-content/uploads/2017/12/omg.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>OMG! Original Music Gathering!Get your spot in the spotlight! Enjoy great talent.How Do OMG Friday's work? We primarily feature original singer/songwriters... but have also hosted comedy skits, poetry, various instruments,</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell shorter_desc'><div class='eventon_details_shading_bot'><p class='eventon_shad_p' content='less'><span class='ev_more_text' data-txt='less'>more</span><span class='ev_more_arrow'></span></p></div><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>OMG! Original Music Gathering!</p><p>Get your spot in the spotlight! Enjoy great talent.</p><p>How Do OMG Friday&#8217;s work? We primarily feature original singer/songwriters&#8230; but have also hosted comedy skits, poetry, various instruments, acting monologues and more.</p><p>Do you need to practice your original performance with a welcoming audience of family and friends? Come by La Divina for OMG &#8211; Original Music Gathering Friday Nights!</p><p>Arrive early for the best seating. Check in with the weekly OMG Coordinator to get your spot in the spotlight.</p><p>Local Music, wine, beer, great food and cozy ambience. Support local talent. Tickets not necessary/No Reserved Seating #local #music #wine #beer #song</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Friday) 6:00 pm - 8:00 pm</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='569'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>La Divina Cafe</p><p>3535 Perkins Road Suite 360</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=68875&amp;sunix=20171230T000000Z&amp;eunix=20171230T020000Z&amp;loca=3535 Perkins Road Suite 360&amp;locn=La Divina Cafe' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=OMG+Friday+Nights+at+La+Divina+Cafe&amp;dates=20171230T000000Z/20171230T020000Z&amp;details=OMG%21+Original+Music+Gathering%21%0D%0A%0D%0AGet+your+spot+in+the+spotlight%21+Enjoy+great+talent.%0D%0A%0D%0AHow+Do+OMG+Friday%27s+work%3F+We+primarily+feature+original+singer%2Fsongwriters...+but+have+also+hosted+comedy+skits%2C+poetry%2C+various+instruments%2C&amp;location=La+Divina+Cafe - 3535+Perkins+Road+Suite+360' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_69093" class="eventon_list_event  event" data-event_id="69093" data-time="1514570400-1514584800" data-colr="#ff057a" itemscope itemtype='http://schema.org/Event' 4><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/hrpo-20th-anniversary-celebration-and-preview-party/'></a><span itemprop='name'  >HRPO 20th Anniversary Celebration and Preview Party</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2017/12/hrpo-300x111.jpg' ></meta><meta itemprop='description' content='HRPO 20TH ANNIVERSARY CELEBRATION &amp; Preview Party
No admission fee. For all ages.
Binocular recommended.The idea to bring a public telescope to East Baton Rouge Parish came from a phone call between' ></meta><meta itemprop='startDate' content='2017-12-29' ></meta><meta itemprop='endDate' content='2017-12-29' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Highland Road Park Observatory</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">13800 Highland Road</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "HRPO 20th Anniversary Celebration and Preview Party",
							  	"startDate": "2017-12-29T18-18-00-00",
							  	"endDate": "2017-12-29T22-22-00-00",
							  	"image":"https://digbr.com/wp-content/uploads/2017/12/hrpo-300x111.jpg",
							  	"description":"HRPO 20TH ANNIVERSARY CELEBRATION &amp; Preview Party
No admission fee. For all ages.
Binocular recommended.

The idea to bring a public telescope to East Baton Rouge Parish came from a phone call between",
							  	"location":{
										"@type":"Place",
										"name":"Highland Road Park Observatory",
										"address":"13800 Highland Road"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #ff057a;" id="evc_151457040069093" class="desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#ff057a' data-smon='december' data-syr='2017'><span class='evo_start '><em class='date'>29</em><em class='month'>dec</em><em class='time'><i>(dec 29)</i>6:00 pm</em></span><span class='evo_end only_time'><em class='time'><i>(dec 29)</i>6:00 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.3474366,-91.0730718"  data-location_address="13800 Highland Road" data-location_type="lonlat" data-location_name="Highland Road Park Observatory" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>HRPO 20th Anniversary Celebration and Preview Party</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='315' data-imgwidth='851'  style='background-image: url("https://digbr.com/wp-content/uploads/2017/12/hrpo.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>HRPO 20TH ANNIVERSARY CELEBRATION &amp; Preview Party
No admission fee. For all ages.
Binocular recommended.The idea to bring a public telescope to East Baton Rouge Parish came from a phone call between</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell shorter_desc'><div class='eventon_details_shading_bot'><p class='eventon_shad_p' content='less'><span class='ev_more_text' data-txt='less'>more</span><span class='ev_more_arrow'></span></p></div><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>HRPO 20TH ANNIVERSARY CELEBRATION &amp; Preview Party<br /> No admission fee. For all ages.<br /> Binocular recommended.</p><p>The idea to bring a public telescope to East Baton Rouge Parish came from a phone call between LSU astrophysicist Greg Guzik and BRAS member Melanie Hair. The Department of Physics and Astronomy at LSU secured the funding for a professional-grade reflector from the Optical Guidance Systems company. BREC (under then-Superintendent Eugene Young) agreed to provided grounds, a building, staff and an operating budget. The rest is history! Join us in a celebration of the past and a look to the future.</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Friday) 6:00 pm - 10:00 pm</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='577'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Highland Road Park Observatory</p><p>13800 Highland Road</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=69093&amp;sunix=20171230T000000Z&amp;eunix=20171230T040000Z&amp;loca=13800 Highland Road&amp;locn=Highland Road Park Observatory' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=HRPO+20th+Anniversary+Celebration+and+Preview+Party&amp;dates=20171230T000000Z/20171230T040000Z&amp;details=HRPO+20TH+ANNIVERSARY+CELEBRATION+%26amp%3B+Preview+Party%0D%0ANo+admission+fee.+For+all+ages.%0D%0ABinocular+recommended.%0D%0A%0D%0AThe+idea+to+bring+a+public+telescope+to+East+Baton+Rouge+Parish+came+from+a+phone+call+between&amp;location=Highland+Road+Park+Observatory - 13800+Highland+Road' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_69095" class="eventon_list_event  event" data-event_id="69095" data-time="1514574000-1514581200" data-colr="#ff057a" itemscope itemtype='http://schema.org/Event' 5><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/lady-bird-presented-by-films-at-manship/'></a><span itemprop='name'  >Lady Bird presented by Films at Manship</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2017/12/lady-bird-300x169.jpg' ></meta><meta itemprop='description' content='We are screening the award winning film #LadyBird 3 times this month! Catch it Tuesday December 26 at 7:00 PM, Friday December 29 at 7:00pm, or Saturday' ></meta><meta itemprop='startDate' content='2017-12-29' ></meta><meta itemprop='endDate' content='2017-12-29' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Manship Theatre at Shaw Center for the Arts</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">100 Lafayette St, Baton Rouge, Louisiana 70801</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Lady Bird presented by Films at Manship",
							  	"startDate": "2017-12-29T19-19-00-00",
							  	"endDate": "2017-12-29T21-21-00-00",
							  	"image":"https://digbr.com/wp-content/uploads/2017/12/lady-bird-300x169.jpg",
							  	"description":"We are screening the award winning film #LadyBird 3 times this month! Catch it Tuesday December 26 at 7:00 PM, Friday December 29 at 7:00pm, or Saturday",
							  	"location":{
										"@type":"Place",
										"name":"Manship Theatre at Shaw Center for the Arts",
										"address":"100 Lafayette St, Baton Rouge, Louisiana 70801"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #ff057a;" id="evc_151457400069095" class="desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#ff057a' data-smon='december' data-syr='2017'><span class='evo_start '><em class='date'>29</em><em class='month'>dec</em><em class='time'><i>(dec 29)</i>7:00 pm</em></span><span class='evo_end only_time'><em class='time'><i>(dec 29)</i>7:00 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.447684,-91.1890198"  data-location_address="100 Lafayette St, Baton Rouge, Louisiana 70801" data-location_type="lonlat" data-location_name="Manship Theatre at Shaw Center for the Arts" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Lady Bird presented by Films at Manship</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='607' data-imgwidth='1080'  style='background-image: url("https://digbr.com/wp-content/uploads/2017/12/lady-bird.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>We are screening the award winning film #LadyBird 3 times this month! Catch it Tuesday December 26 at 7:00 PM, Friday December 29 at 7:00pm, or Saturday</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>We are screening the award winning film <a class="_58cn" href="https://www.facebook.com/hashtag/ladybird" data-ft="{&quot;tn&quot;:&quot;*N&quot;,&quot;type&quot;:104}">#LadyBird</a> 3 times this month! Catch it Tuesday December 26 at 7:00 PM, Friday December 29 at 7:00pm, or Saturday December 30 at 2:00pm.⠀<br /> In Lady Bird, Greta Gerwig reveals herself to be a bold new cinematic voice with her directorial debut, excavating both the humor and pathos in the turbulent bond between a mother and her teenage daughter.</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Friday) 7:00 pm - 9:00 pm</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='463'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Manship Theatre at Shaw Center for the Arts</p><p>100 Lafayette St, Baton Rouge, Louisiana 70801</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_learnMICS evorow bordb '><div class='tb'><div class='tbrow'> <a class='evcal_col50 dark1 bordr evo_clik_row' href='https://www.facebook.com/events/148402695805507/' target="_blank"> <span class='evcal_evdata_row ' > <span class='evcal_evdata_icons'><i class='fa fa-link'></i></span><h3 class='evo_h3'>Learn More</h3> </span> </a><div class='evo_ics evcal_col50 dark1 evo_clik_row' ><div class='evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=69095&amp;sunix=20171230T010000Z&amp;eunix=20171230T030000Z&amp;loca=100 Lafayette St, Baton Rouge, Louisiana 70801&amp;locn=Manship Theatre at Shaw Center for the Arts' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Lady+Bird+presented+by+Films+at+Manship&amp;dates=20171230T010000Z/20171230T030000Z&amp;details=We+are+screening+the+award+winning+film+%23LadyBird+3+times+this+month%21+Catch+it+Tuesday+December+26+at+7%3A00+PM%2C+Friday+December+29+at+7%3A00pm%2C+or+Saturday&amp;location=Manship+Theatre+at+Shaw+Center+for+the+Arts - 100+Lafayette+St%2C+Baton+Rouge%2C+Louisiana+70801' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div></div></div></div></div><div class='clear end'></div></div></div><div class='clear'></div></div></div></div><div id="gridlove_posts_widget-1" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Recent posts<span class="gridlove-slider-controls" data-autoplay="0"></span></h4><div class="gridlove-posts-widget gridlove-widget-slider"><div class="gridlove-posts-widget-item-wrapper"><article class="post-69233 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink tag-featured tag-now"><div class="entry-image"> <a href="https://digbr.com/a-food-journey-with-iverstine-family-farms/" title="A food journey with Iverstine Family Farms"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2017/12/IFB-fence-4-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="69241" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/a-food-journey-with-iverstine-family-farms/">A food journey with Iverstine Family Farms</a></h6></div></article><article class="post-69224 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-magazine tag-featured tag-now"><div class="entry-image"> <a href="https://digbr.com/jay-picks-six-for-restaurant-week/" title="Jay Picks Six for Restaurant Week"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2017/12/JayDucoteJan2018-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="69228" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/jay-picks-six-for-restaurant-week/">Jay Picks Six for Restaurant Week</a></h6></div></article><article class="post-69203 post type-post status-publish format-standard has-post-thumbnail hentry category-magazine tag-highlight"><div class="entry-image"> <a href="https://digbr.com/this-month-in-dig-january-2018/" title="This month in Dig: January 2018"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2017/12/EditorPhotoJan2018-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="69204" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/this-month-in-dig-january-2018/">This month in Dig: January 2018</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-69222 post type-post status-publish format-standard has-post-thumbnail hentry category-leisure tag-now"><div class="entry-image"> <a href="https://digbr.com/things-to-do-thursday-dec-28/" title="Things to do Thursday, Dec. 28"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2017/12/25358506_144517302873496_9052782881471871675_o-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="69223" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/things-to-do-thursday-dec-28/">Things to do Thursday, Dec. 28</a></h6></div></article><article class="post-69220 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-featured tag-now"><div class="entry-image"> <a href="https://digbr.com/schneider-phat-hat-to-headline-red-stick-revelry/" title="Schneider, Phat Hat to headline Red Stick Revelry"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2017/12/RedStickRevelry2017-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="69221" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/schneider-phat-hat-to-headline-red-stick-revelry/">Schneider, Phat Hat to headline Red Stick Revelry</a></h6></div></article><article class="post-69219 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-now"><div class="entry-image"> <a href="https://digbr.com/report-casino-to-downtown-bike-path-coming/" title="Report: Casino-to-downtown bike path coming"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2016/01/BerensonOutdoorsInTheCity-2-e1453926755140-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2016/01/BerensonOutdoorsInTheCity-2-e1453926755140-80x60.jpg 80w, https://digbr.com/wp-content/uploads/2016/01/BerensonOutdoorsInTheCity-2-e1453926755140-300x225.jpg 300w, https://digbr.com/wp-content/uploads/2016/01/BerensonOutdoorsInTheCity-2-e1453926755140-150x113.jpg 150w, https://digbr.com/wp-content/uploads/2016/01/BerensonOutdoorsInTheCity-2-e1453926755140-600x450.jpg 600w, https://digbr.com/wp-content/uploads/2016/01/BerensonOutdoorsInTheCity-2-e1453926755140.jpg 700w" sizes="(max-width: 80px) 100vw, 80px" data-wp-pid="47883" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/report-casino-to-downtown-bike-path-coming/">Report: Casino-to-downtown bike path coming</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-69218 post type-post status-publish format-standard has-post-thumbnail hentry category-the-sports-troll tag-now"><div class="entry-image"> <a href="https://digbr.com/orgeron-gets-his-mulligan-and-his-man/" title="Orgeron gets his mulligan, and his man"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2017/11/canada-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="67668" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/orgeron-gets-his-mulligan-and-his-man/">Orgeron gets his mulligan, and his man</a></h6></div></article><article class="post-69208 post type-post status-publish format-standard has-post-thumbnail hentry category-lifestyle category-magazine tag-now"><div class="entry-image"> <a href="https://digbr.com/at-the-heart-of-art/" title="At the Heart of Art"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2017/12/VPA-macrame-6-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="69210" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/at-the-heart-of-art/">At the Heart of Art</a></h6></div></article><article class="post-69205 post type-post status-publish format-standard has-post-thumbnail hentry category-lifestyle category-magazine tag-now"><div class="entry-image"> <a href="https://digbr.com/bourbonbluebringsbalancetomensfashion/" title="Bourbon+Blue brings balance to men&#8217;s fashion"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2017/12/BourbonBlue1-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="69206" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/bourbonbluebringsbalancetomensfashion/">Bourbon+Blue brings balance to men&#8217;s fashion</a></h6></div></article></div></div></div><div class="gridlove-sticky-sidebar"><div id="mks_ads_widget-1" class="widget gridlove-box mks_ads_widget"><ul class="mks_adswidget_ul large"><li data-showind="0"> <a href="#" target="_blank" > <img src="https://mekshq.com/static/gridlove/gridlove_ad_300x250.jpg" alt="gridlove_ad_300x250.jpg" style="width:300px; height:250px;" width="300"  height="250"/> </a></li></ul></div></div></div></div></div><div id="footer" class="gridlove-footer"><div class="container"><div class="row"><div class="col-lg-4 col-md-6 col-sm-12"><div id="text-2" class="widget widget_text"><div class="textwidget"><p><img width="159" src="https://digbr.com/wp-content/uploads/2017/09/DIG-wht.png"/></p><p>DIGBR.com is how Baton Rouge keeps the pulse of our great city. We curate what's important and deliver it fast and throughout the day along with great content from your monthly DIG Magazine.</p></div></div><div id="mks_social_widget-3" class="widget mks_social_widget"><ul class="mks_social_widget_ul"><li><a href="https://www.facebook.com/digbatonrouge/" class="facebook_ico soc_circle" target="_blank" style="width: 40px; height: 40px; font-size: 16px;"><span>facebook</span></a></li><li><a href="https://twitter.com/DigBatonRouge" class="twitter_ico soc_circle" target="_blank" style="width: 40px; height: 40px; font-size: 16px;"><span>twitter</span></a></li><li><a href="https://www.instagram.com/digbatonrouge/" class="instagram_ico soc_circle" target="_blank" style="width: 40px; height: 40px; font-size: 16px;"><span>instagram</span></a></li></ul></div></div><div class="col-lg-4 col-md-6 col-sm-12"><div id="mc4wp_widget-3" class="widget widget_mc4wp_widget"><h4 class="widget-title">Newsletter</h4><div id="mc4wp-form-1" class="mc4wp-form mc4wp-form-47580 mc4wp-ajax "><form method="post" action="https://digbr.com/a-food-journey-with-iverstine-family-farms/"><p> <label for="mc4wp_email">Every day, DIG hits your inbox with the latest happening in BR - news, fun, cool events and more.</label> <input type="email" id="mc4wp_email" name="EMAIL" required placeholder="Your email address" /></p><p> <input type="submit" value="Sign up" /></p><textarea name="_mc4wp_required_but_not_really" style="display: none;"></textarea><input type="hidden" name="_mc4wp_form_ID" value="47580" /><input type="hidden" name="_mc4wp_form_instance" value="1" /><input type="hidden" name="_mc4wp_form_submit" value="1" /><input type="hidden" name="_mc4wp_form_nonce" value="c206448714" /></form><span class="mc4wp-ajax-loader" style="display: none;"></span><div style="display:none;" class="mc4wp-alert mc4wp-success-message mc4wp-success">Thank you, your sign-up request was successful! Please check your e-mail inbox. <span class="mc4wp-mailchimp-error"></span></div><div style="display:none;" class="mc4wp-alert mc4wp-already_subscribed-message mc4wp-notice">Given email address is already subscribed, thank you! <span class="mc4wp-mailchimp-error"></span></div><div style="display:none;" class="mc4wp-alert mc4wp-invalid_email-message mc4wp-error">Please provide a valid email address. <span class="mc4wp-mailchimp-error"></span></div><div style="display:none;" class="mc4wp-alert mc4wp-error-message mc4wp-error">Oops. Something went wrong. Please try again later. <span class="mc4wp-mailchimp-error"></span></div></div></div></div><div class="col-lg-4 col-md-6 col-sm-12"><div id="nav_menu-1" class="widget widget_nav_menu"><h4 class="widget-title">Help &#038; Support</h4><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-47573" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47573"><a href="https://digbr.com/terms-of-service/">Terms of Service</a></li><li id="menu-item-47574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47574"><a href="https://digbr.com/advertise-with-dig/">Advertise</a></li><li id="menu-item-47576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47576"><a href="https://digbr.com/join-the-team/">Join the Team!</a></li><li id="menu-item-48020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48020"><a href="https://digbr.com/find-a-copy/">Find a copy</a></li><li id="menu-item-63187" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63187"><a href="https://digbr.com/aboutcontact/">About/Contact</a></li></ul></div></div></div></div></div><div class="gridlove-copyright"><div class="container"><p style="text-align: center">Copyright © 2017 · Primedia Holdings, LLC</p></div></div></div><div class="gridlove-sidebar-action-wrapper"><span class="gridlove-action-close"><i class="fa fa-times" aria-hidden="true"></i></span><div class="gridlove-sidebar-action-inside"><div class="hidden-lg-up widget gridlove-box widget_nav_menu"><ul id="menu-main-menu-2" class="gridlove-mobile-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6979"><a href="https://digbr.com/category/news/campus/">LSU</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6977"><a href="https://digbr.com/category/news/">NEWS</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66360"><a href="https://digbr.com/category/news/crime/">Crime</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66359"><a href="https://digbr.com/category/news/biz/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7141"><a href="https://digbr.com/category/news/opinion/">Opinion</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-7306"><a href="https://digbr.com/category/leisure/">LEISURE</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66358"><a href="https://digbr.com/the-lineup/">Things to do</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66393"><a href="https://digbr.com/food-drink/">Food &#038; Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6969"><a href="https://digbr.com/category/leisure/arts-culture/">Arts &#038; Culture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6972"><a href="https://digbr.com/category/leisure/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31878"><a href="https://digbr.com/category/leisure/fitness/">Health &#038; Fitness</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7316"><a href="https://digbr.com/category/sports/">SPORTS</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47579"><a href="#">FUN STUFF!</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-47583"><a href="https://digbr.com/product-category/ticketed-event/">DIG Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7155"><a href="https://digbr.com/category/galleries/">Galleries</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66363"><a href="https://digbr.com/brag17/">BRAG17</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66741"><a href="https://digbr.com/category/magazine/">MAGAZINE</a></li></ul></div><div id="mks_social_widget-1" class="widget gridlove-box mks_social_widget"><h4 class="widget-title">Follow us</h4><p>Don't be shy, get in touch. We love meeting interesting people and making new friends.</p><ul class="mks_social_widget_ul"><li><a href="https://www.facebook.com/mekshq" class="facebook_ico soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;"><span>facebook</span></a></li><li><a href="https://twitter.com/mekshq" class="twitter_ico soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;"><span>twitter</span></a></li><li><a href="http://youtube.com/" class="youtube_ico soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;"><span>youtube</span></a></li><li><a href="http://blogger.com" class="blogger_ico soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;"><span>blogger</span></a></li></ul></div><div id="gridlove_posts_widget-2" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Most popular<span class="gridlove-slider-controls" data-autoplay="0"></span></h4></div><div id="gridlove_posts_widget-3" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Most discussed<span class="gridlove-slider-controls" data-autoplay="0"></span></h4><div class="gridlove-posts-widget gridlove-widget-slider"><div class="gridlove-posts-widget-item-wrapper"><article class="post-12047 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-leisure category-sports"><div class="entry-image"> <a href="https://digbr.com/digs-baton-rouge-world-cup-watch-guide/" title="DIG&#8217;s Baton Rouge World Cup Watch Guide"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/JUMP-2014.06.07_DIG_FUTBOL-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12048" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/digs-baton-rouge-world-cup-watch-guide/">DIG&#8217;s Baton Rouge World Cup Watch Guide</a></h6></div></article><article class="post-12652 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/paul-stars-part-two/" title="All Mainieri Team: Infield"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/07/JUMP-Austin-Nola-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12653" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/paul-stars-part-two/">All Mainieri Team: Infield</a></h6></div></article><article class="post-12295 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-sports"><div class="entry-image"> <a href="https://digbr.com/londoner-hosts-celebration-of-historic-usa-world-cup-victory/" title="Londoner Hosts Celebration of Historic USA World Cup Victory"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/ANCHOR_Outlaws-Londoner-12-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12296" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/londoner-hosts-celebration-of-historic-usa-world-cup-victory/">Londoner Hosts Celebration of Historic USA World Cup Victory</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-12485 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/business-as-usual-bobby-jindal-crony-capitalism/" title="Business As Usual"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/Fred-Dive-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12486" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/business-as-usual-bobby-jindal-crony-capitalism/">Business As Usual</a></h6></div></article><article class="post-12495 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/thompson-sets-100-meter-national-record/" title="Thompson Sets 100-Meter National Record"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/Richard-Thompson-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12498" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/thompson-sets-100-meter-national-record/">Thompson Sets 100-Meter National Record</a></h6></div></article><article class="post-19303 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/gameday-preview-lsu-vs-alabama/" title="Gameday Preview: LSU vs. Alabama"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/11/IMG_7074-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="19304" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/gameday-preview-lsu-vs-alabama/">Gameday Preview: LSU vs. Alabama</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-48119 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/early-effects/" title="Early Effects"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2016/02/20150829_DIG_TIGER_STADIUM-0001-e1454524706563-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="48121" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/early-effects/">Early Effects</a></h6></div></article><article class="post-28829 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/big-question-for-the-big-man/" title="Big Question for the Big Man"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2015/03/Screen-shot-2015-03-25-at-7.18.20-PM-80x60.png" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="28831" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/big-question-for-the-big-man/">Big Question for the Big Man</a></h6></div></article><article class="post-30459 post type-post status-publish format-standard has-post-thumbnail hentry category-sports category-uncategorized"><div class="entry-image"> <a href="https://digbr.com/potential-or-project/" title="Potential or Project?"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2015/05/Garrett-Grayson-1-80x60.jpeg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="30460" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/potential-or-project/">Potential or Project?</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-16889 post type-post status-publish format-standard has-post-thumbnail hentry category-outdoors category-sports"><div class="entry-image"> <a href="https://digbr.com/natural-browse-mother-natures-deer-season-advantages/" title="Natural Browse: Mother Nature&#8217;s Deer Season Advantages"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/09/shutterstock_68707150-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="16890" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/natural-browse-mother-natures-deer-season-advantages/">Natural Browse: Mother Nature&#8217;s Deer Season Advantages</a></h6></div></article><article class="post-18600 post type-post status-publish format-standard has-post-thumbnail hentry category-outdoors category-sports"><div class="entry-image"> <a href="https://digbr.com/cyclocross-races-through-baton-rouge/" title="Cyclocross races through Baton Rouge"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/10/shutterstock_21758767-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="18601" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/cyclocross-races-through-baton-rouge/">Cyclocross races through Baton Rouge</a></h6></div></article><article class="post-11728 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports tag-talkin-tigers"><div class="entry-image"> <a href="https://digbr.com/talkin-tigers-aaron-nola/" title="Talkin’ Tigers: Aaron Nola"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/Aaron-Nola-copy-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="11729" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/talkin-tigers-aaron-nola/">Talkin’ Tigers: Aaron Nola</a></h6></div></article></div></div></div></div></div><div class="gridlove-sidebar-action-overlay"></div> <script type="text/javascript">var gmapstyles = 'default';</script> <div id="fb-root"></div> <script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=713095298769737";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MW6NQMQ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>  <script>jQuery(document)
	.on('ready', function(){
		if(jQuery('body').is('.home')){
			setTimeout(function(){
				window.location.reload(1);
			}, 1800000);
		}
	});</script><div class='evo_lightboxes'><div class='evo_lightbox eventcard eventon_events_list' id=''><div class="evo_content_in"><div class="evo_content_inin"><div class="evo_lightbox_content"> <a class='evolbclose '>X</a><div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'></div></div></div></div></div></div><script type='text/javascript'>var evoli_ajax_script = {"evoli_ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php","postnonce":"dc295eb92d"};</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/digbr.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};</script> <script type='text/javascript'>var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/a-food-journey-with-iverstine-family-farms\/?wc-ajax=%%endpoint%%"};</script> <script type='text/javascript'>var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/a-food-journey-with-iverstine-family-farms\/?wc-ajax=%%endpoint%%","fragment_name":"wc_fragments"};</script> <script type='text/javascript'>var gridlove_js_settings = {"rtl_mode":"","header_sticky":"1","header_sticky_offset":"100","header_sticky_up":"","logo":"https:\/\/digbr.com\/wp-content\/uploads\/2017\/09\/DIG-REG.png","logo_retina":"https:\/\/digbr.com\/wp-content\/uploads\/2017\/09\/DIG-retina.png","logo_mini":"https:\/\/digbr.com\/wp-content\/uploads\/2017\/09\/DIG-mobile.png","logo_mini_retina":"","gridlove_gallery":"1"};</script> <script type='text/javascript'>var the_ajax_script = {"ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php","postnonce":"f08eb02596"};</script> <script type='text/javascript' src='https://maps.googleapis.com/maps/api/js?ver=1.0'></script> <script type='text/javascript'>var mc4wp_vars = {"ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php","ajax_loader_url":"https:\/\/digbr.com\/wp-content\/plugins\/mailchimp-for-wp-pro\/assets\/img\/ajax-loader.gif"};</script> </style>  <script type="text/javascript" defer src="https://digbr.com/wp-content/cache/autoptimize/js/autoptimize_40fac0a015ee8dc7903d96d88f518308.js"></script></body></html>