<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#" class="no-js"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width,initial-scale=1.0"><link type="text/css" media="all" href="https://digbr.com/wp-content/cache/autoptimize/css/autoptimize_5e2aeb74f40f2b1c9c2ed6baee7d0767.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://digbr.com/wp-content/cache/autoptimize/css/autoptimize_53c4c0a131500d29ce025cdc7c57f1f1.css" rel="stylesheet" /><link type="text/css" media="only screen and (max-width: 768px)" href="https://digbr.com/wp-content/cache/autoptimize/css/autoptimize_cfc7e39d708c2a6d0ed80d0180ecdb98.css" rel="stylesheet" /><title>Margarita &#8211; Dig Baton Rouge</title><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Dig Baton Rouge &raquo; Feed" href="https://digbr.com/feed/" /><link rel="alternate" type="text/calendar" title="Dig Baton Rouge &raquo; iCal Feed" href="https://digbr.com/events/?ical=1" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/digbr.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='gridlove-fonts-css'  href='https://fonts.googleapis.com/css?family=Cabin%3A400%2C700%7CLato%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;ver=1.4.2' type='text/css' media='all' /><link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A700%2C400%2C400i%7CRoboto%3A700%2C400&#038;ver=4.9.5' type='text/css' media='screen' /><link rel='stylesheet' id='mailchimp-for-wp-css'  href='https://digbr.com/wp-content/plugins/mailchimp-for-wp-pro/assets/css/css.php?checkbox=1&#038;ver=1.98.7' type='text/css' media='all' /> <script type='text/javascript'>var tribe_events_linked_posts = {"post_types":{"tribe_venue":"venue","tribe_organizer":"organizer"}};</script> <script type='text/javascript' src='https://digbr.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript'>var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/greatest-margarita\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View Cart","cart_url":"https:\/\/digbr.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};</script> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/arrive/2.4.1/arrive.min.js?ver=2.4.1'></script> <script type='text/javascript'>var tribe_this_week = {"ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php"};</script> <link rel='https://api.w.org/' href='https://digbr.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://digbr.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://digbr.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Win dinner for two to Qdoba!' href='https://digbr.com/win-dinner-for-two-to-qdoba/' /><link rel='next' title='Place to Eat at the Bar' href='https://digbr.com/greatest-place-to-eat-at-the-bar/' /><link rel="canonical" href="https://digbr.com/greatest-margarita/" /><link rel="alternate" type="application/json+oembed" href="https://digbr.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdigbr.com%2Fgreatest-margarita%2F" /><link rel="alternate" type="text/xml+oembed" href="https://digbr.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdigbr.com%2Fgreatest-margarita%2F&#038;format=xml" /><meta property="fb:app_id" content="713095298769737" />  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MW6NQMQ');</script>  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-21029509-1', 'auto');
  ga('send', 'pageview');</script><script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":71952,"post_name":"greatest-margarita","post_title":"Margarita","post_type":"post","post_author":"10000224","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":322,"name":"Food &amp; Dining","slug":"brag-food-dining","term_group":0,"term_taxonomy_id":322,"taxonomy":"category","description":"","parent":321,"count":46,"filter":"raw","cat_ID":322,"category_count":46,"category_description":"","cat_name":"Food &amp; Dining","category_nicename":"brag-food-dining","category_parent":321}]; _mmunch['postTags'] = false; _mmunch['postAuthor'] = {"name":"","ID":""};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="86056" async></script> <script type="text/javascript">jQuery(document).ready(function() {
				// CUSTOM AJAX CONTENT LOADING FUNCTION
				var ajaxRevslider = function(obj) {
				
					// obj.type : Post Type
					// obj.id : ID of Content to Load
					// obj.aspectratio : The Aspect Ratio of the Container / Media
					// obj.selector : The Container Selector where the Content of Ajax will be injected. It is done via the Essential Grid on Return of Content
					
					var content = "";

					data = {};
					
					data.action = 'revslider_ajax_call_front';
					data.client_action = 'get_slider_html';
					data.token = '56b71cc146';
					data.type = obj.type;
					data.id = obj.id;
					data.aspectratio = obj.aspectratio;
					
					// SYNC AJAX REQUEST
					jQuery.ajax({
						type:"post",
						url:"https://digbr.com/wp-admin/admin-ajax.php",
						dataType: 'json',
						data:data,
						async:false,
						success: function(ret, textStatus, XMLHttpRequest) {
							if(ret.success == true)
								content = ret.data;								
						},
						error: function(e) {
							console.log(e);
						}
					});
					
					 // FIRST RETURN THE CONTENT WHEN IT IS LOADED !!
					 return content;						 
				};
				
				// CUSTOM AJAX FUNCTION TO REMOVE THE SLIDER
				var ajaxRemoveRevslider = function(obj) {
					return jQuery(obj.selector+" .rev_slider").revkill();
				};

				// EXTEND THE AJAX CONTENT LOADING TYPES WITH TYPE AND FUNCTION
				var extendessential = setInterval(function() {
					if (jQuery.fn.tpessential != undefined) {
						clearInterval(extendessential);
						if(typeof(jQuery.fn.tpessential.defaults) !== 'undefined') {
							jQuery.fn.tpessential.defaults.ajaxTypes.push({type:"revslider",func:ajaxRevslider,killfunc:ajaxRemoveRevslider,openAnimationSpeed:0.3});   
							// type:  Name of the Post to load via Ajax into the Essential Grid Ajax Container
							// func: the Function Name which is Called once the Item with the Post Type has been clicked
							// killfunc: function to kill in case the Ajax Window going to be removed (before Remove function !
							// openAnimationSpeed: how quick the Ajax Content window should be animated (default is 0.3)
						}
					}
				},30);
			});</script> <script type='text/javascript'>var taqyeem = {"ajaxurl":"https://digbr.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};</script> <meta name="generator" content="EventON 2.5.5" /><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/> <!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://digbr.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://digbr.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><meta name="wpsso:mark:begin" content="wpsso meta tags begin"/><meta name="generator" content="WPSSO 3.45.3/G"/><link rel="shortlink" href="https://digbr.com/?p=71952"/><meta property="og:url" content="https://digbr.com/greatest-margarita/"/><meta property="og:type" content="article"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="Dig Baton Rouge"/><meta property="og:title" content="Margarita"/><meta property="og:description" content="Superior Grill 51% Pass us a lime and some salt! We can&rsquo;t seem to get enough of Superior Grill, so much that they&rsquo;ve opened a new location. You can stop by during happy hour everyday from 4:30-6:30 pm; it&rsquo;s the greatest after all Multiple Locations | batonrouge.superiorgrill.com 2. The Velvet..."/><meta property="og:image" content="https://digbr.com/wp-content/uploads/2018/04/superiormarg-600x315.jpeg"/><meta property="og:image:width" content="600"/><meta property="og:image:height" content="315"/><meta property="article:published_time" content="2018-04-30T16:14:04+00:00"/><meta property="article:modified_time" content="2018-04-30T16:14:36+00:00"/><meta property="og:updated_time" content="2018-04-30T16:14:36+00:00"/><meta name="weibo:article:create_at" content="2018-04-30 16:14:04"/><meta name="weibo:article:update_at" content="2018-04-30 16:14:36"/><meta name="twitter:domain" content="digbr.com"/><meta name="twitter:title" content="Margarita"/><meta name="twitter:description" content="Superior Grill 51% Pass us a lime and some salt! We can&rsquo;t seem to get enough of Superior Grill, so much that they&rsquo;ve opened a new location. You can stop by during happy hour everyday from..."/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://digbr.com/wp-content/uploads/2018/04/superiormarg-800x533.jpeg"/><link itemprop="url" href="https://digbr.com/greatest-margarita/"/><meta itemprop="name" content="Margarita"/><meta itemprop="description" content="Superior Grill 51% Pass us a lime and some salt! We can&rsquo;t seem to get enough of Superior Grill, so much that they&rsquo;ve opened a new location. You can stop by during happy hour everyday from 4:30-6:30 pm; it&rsquo;s the greatest after all Multiple..."/><meta itemprop="datePublished" content="2018-04-30T16:14:04+00:00"/><meta itemprop="dateModified" content="2018-04-30T16:14:36+00:00"/><meta name="author" content="DIG Staff"/><meta name="description" content="Superior Grill 51% Pass us a lime and some salt! We can&rsquo;t seem to get enough of Superior Grill, so much that they&rsquo;ve opened a new location. You can stop..."/> <noscript itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="DIG Staff"/> </noscript> <noscript itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><link itemprop="url" href="https://digbr.com/wp-content/uploads/2018/04/superiormarg-800x533.jpeg"/><meta itemprop="width" content="800"/><meta itemprop="height" content="533"/> </noscript><meta name="wpsso:mark:end" content="wpsso meta tags end"/> <noscript><style type="text/css">.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head><body class="post-template-default single single-post postid-71952 single-format-standard unknown wpb-js-composer js-comp-ver-4.11.2.1 vc_responsive"><header id="header" class="gridlove-site-header hidden-md-down  gridlove-header-shadow"><div class="gridlove-header-wrapper"><div class="gridlove-header-1 gridlove-header-middle container"><div class="gridlove-slot-l"><div class="gridlove-site-branding  "> <span class="site-title h1"><a href="https://digbr.com/" rel="home"><img class="gridlove-logo" src="https://digbr.com/wp-content/uploads/2018/02/DIG-Logo-white-sm.png" alt="Dig Baton Rouge"></a></span></div></div><div class="gridlove-slot-r"><nav class="gridlove-main-navigation"><ul id="menu-main-menu" class="gridlove-main-nav gridlove-menu"><li id="menu-item-6977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6977"><a href="https://digbr.com/category/news/">NEWS</a><ul class="sub-menu"><li id="menu-item-66360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66360"><a href="https://digbr.com/category/news/crime/">Crime</a></li><li id="menu-item-66359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66359"><a href="https://digbr.com/category/news/biz/">Business</a></li><li id="menu-item-7141" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7141"><a href="https://digbr.com/category/news/opinion/">Opinion</a></li><li id="menu-item-6979" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6979"><a href="https://digbr.com/category/news/campus/">LSU</a></li></ul></li><li id="menu-item-7306" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7306"><a href="https://digbr.com/category/leisure/">LEISURE</a><ul class="sub-menu"><li id="menu-item-66358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66358"><a href="https://digbr.com/the-lineup/">Things to do</a></li><li id="menu-item-66393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66393"><a href="https://digbr.com/food-drink/">Food &#038; Drink</a></li><li id="menu-item-6969" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6969"><a href="https://digbr.com/category/leisure/arts-culture/">Arts &#038; Culture</a></li><li id="menu-item-7316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7316"><a href="https://digbr.com/category/sports/">Sports</a></li><li id="menu-item-6972" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6972"><a href="https://digbr.com/category/leisure/music/">Music</a></li><li id="menu-item-31878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31878"><a href="https://digbr.com/category/leisure/fitness/">Health &#038; Fitness</a></li></ul></li><li id="menu-item-47579" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47579"><a href="#">FUN STUFF!</a><ul class="sub-menu"><li id="menu-item-47583" class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-47583"><a href="https://digbr.com/product-category/ticketed-event/">DIG Events</a></li><li id="menu-item-7155" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7155"><a href="https://digbr.com/category/galleries/">Galleries</a></li></ul></li><li id="menu-item-66741" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66741"><a href="https://digbr.com/category/magazine/">MAGAZINE</a></li></ul></nav><ul class="gridlove-actions gridlove-menu"><li class="gridlove-actions-button gridlove-action-search"> <span> <i class="fa fa-search"></i> </span><ul class="sub-menu"><li><form class="gridlove-search-form" action="https://digbr.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form></li></ul></li><li class="gridlove-actions-button"> <span class="gridlove-sidebar-action"> <i class="fa fa-bars"></i> </span></li></ul></div></div></div><div id="gridlove-header-sticky" class="gridlove-header-sticky"><div class="container"><div class="gridlove-slot-l"><div class="gridlove-site-branding mini"> <span class="site-title h1"><a href="https://digbr.com/" rel="home"><img class="gridlove-logo-mini" src="https://digbr.com/wp-content/uploads/2018/02/DIG-Logo-white-mini2.png" alt="Dig Baton Rouge"></a></span></div></div><div class="gridlove-slot-r"><nav class="gridlove-main-navigation"><ul id="menu-main-menu-1" class="gridlove-main-nav gridlove-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6977"><a href="https://digbr.com/category/news/">NEWS</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66360"><a href="https://digbr.com/category/news/crime/">Crime</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66359"><a href="https://digbr.com/category/news/biz/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7141"><a href="https://digbr.com/category/news/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6979"><a href="https://digbr.com/category/news/campus/">LSU</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7306"><a href="https://digbr.com/category/leisure/">LEISURE</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66358"><a href="https://digbr.com/the-lineup/">Things to do</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66393"><a href="https://digbr.com/food-drink/">Food &#038; Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6969"><a href="https://digbr.com/category/leisure/arts-culture/">Arts &#038; Culture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7316"><a href="https://digbr.com/category/sports/">Sports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6972"><a href="https://digbr.com/category/leisure/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31878"><a href="https://digbr.com/category/leisure/fitness/">Health &#038; Fitness</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47579"><a href="#">FUN STUFF!</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-47583"><a href="https://digbr.com/product-category/ticketed-event/">DIG Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7155"><a href="https://digbr.com/category/galleries/">Galleries</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66741"><a href="https://digbr.com/category/magazine/">MAGAZINE</a></li></ul></nav><ul class="gridlove-actions gridlove-menu"><li class="gridlove-actions-button gridlove-action-search"> <span> <i class="fa fa-search"></i> </span><ul class="sub-menu"><li><form class="gridlove-search-form" action="https://digbr.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form></li></ul></li><li class="gridlove-actions-button"> <span class="gridlove-sidebar-action"> <i class="fa fa-bars"></i> </span></li></ul></div></div></div></header><div id="gridlove-header-responsive" class="gridlove-header-responsive hidden-lg-up"><div class="container"><div class="gridlove-site-branding mini"> <span class="site-title h1"><a href="https://digbr.com/" rel="home"><img class="gridlove-logo-mini" src="https://digbr.com/wp-content/uploads/2018/02/DIG-Logo-white-mini2.png" alt="Dig Baton Rouge"></a></span></div><ul class="gridlove-actions gridlove-menu"><li class="gridlove-actions-button gridlove-action-search"> <span> <i class="fa fa-search"></i> </span><ul class="sub-menu"><li><form class="gridlove-search-form" action="https://digbr.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form></li></ul></li><li class="gridlove-actions-button"> <span class="gridlove-sidebar-action"> <i class="fa fa-bars"></i> </span></li></ul></div></div><div id="content" class="gridlove-site-content container gridlove-sidebar-right"><div class="row"><div class="gridlove-share-wrapper"><div class="gridlove-share gridlove-box gridlove-sticky-share"> <a href="javascript:void(0);" class="gridlove-facebook gridlove-share-item" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fdigbr.com%2Fgreatest-margarita%2F&amp;t=Margarita"><i class="fa fa-facebook"></i></a> <a href="javascript:void(0);" class="gridlove-twitter gridlove-share-item" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fdigbr.com%2Fgreatest-margarita%2F&amp;text=Margarita"><i class="fa fa-twitter"></i></a> <a href="/cdn-cgi/l/email-protection#7f400c0a1d151a1c0b42321e0d181e0d160b1e591e120f441d101b0642170b0b0f0c5a4c3e5a4d395a4d391b16181d0d511c10125a4d39180d1a1e0b1a0c0b52121e0d181e0d160b1e5a4d39" class="gridlove-mailto"><i class="fa fa-envelope-o"></i></a></div></div><div class="gridlove-content gridlove-single-layout-1"><article id="post-71952" class="gridlove-box box-vm post-71952 post type-post status-publish format-standard has-post-thumbnail hentry category-brag-food-dining"><div class="entry-image"> <img width="740" height="493" src="https://digbr.com/wp-content/uploads/2018/04/superiormarg-740x493.jpeg" class="attachment-gridlove-single size-gridlove-single wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2018/04/superiormarg-740x493.jpeg 740w, https://digbr.com/wp-content/uploads/2018/04/superiormarg-300x200.jpeg 300w, https://digbr.com/wp-content/uploads/2018/04/superiormarg-768x512.jpeg 768w, https://digbr.com/wp-content/uploads/2018/04/superiormarg-1024x682.jpeg 1024w, https://digbr.com/wp-content/uploads/2018/04/superiormarg-150x100.jpeg 150w, https://digbr.com/wp-content/uploads/2018/04/superiormarg-600x400.jpeg 600w, https://digbr.com/wp-content/uploads/2018/04/superiormarg-1032x688.jpeg 1032w, https://digbr.com/wp-content/uploads/2018/04/superiormarg-800x533.jpeg 800w, https://digbr.com/wp-content/uploads/2018/04/superiormarg.jpeg 1280w" sizes="(max-width: 740px) 100vw, 740px" data-wp-pid="71953" nopin="nopin" /></div><div class="box-inner-p-bigger box-single"><div class="entry-header"><div class="entry-category"> <a href="https://digbr.com/category/brag/brag-food-dining/" class="gridlove-cat gridlove-cat-322">Food &amp; Dining</a></div><h1 class="entry-title">Margarita</h1><div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="https://digbr.com/author/andredigbr-com/"><img src="https://digbr.com/wp-content/uploads/2018/02/DIG-logo-blue-150x150.png" width="24" height="24" alt="DIG Staff" class="avatar avatar-24 wp-user-avatar wp-user-avatar-24 alignnone photo" /> DIG Staff</a></span></span></div><div class="meta-item meta-date"><span class="updated">17 hours ago</span></div></div></div><div class="entry-content"><div class="wpsso-schema-image-for-pinterest" style="display:none;"> <img src="https://digbr.com/wp-content/uploads/2018/04/superiormarg-800x533.jpeg" width="0" height="0" style="width:0;height:0;" data-pin-description="Superior Grill 51% Pass us a lime and some salt! We can&rsquo;t seem to get enough of Superior Grill, so much that they&rsquo;ve opened a new location. You can stop by during happy hour everyday from 4:30-6:30 pm; it&rsquo;s the greatest after all Multiple..."/></div><div class='mailmunch-forms-before-post' style='display: none !important;'></div><div class="page" title="Page 29"><div class="section"><div class="layoutArea"><div class="column"><p><strong>Superior Grill</strong><br /> <strong>51%</strong></p><p><span style="font-weight: 400;">Pass us a lime and some salt! We can’t seem to get enough of Superior Grill, so much that they’ve opened a new location. You can stop by during happy hour everyday from 4:30-6:30 pm; it’s the greatest after all</span><span style="font-weight: 400;"> </span><strong>Multiple Locations | <b>batonrouge.superiorgrill.com</b></strong></p><p><em>2. <span style="font-weight: 400;">The Velvet Cactus 20%</span></em></p><p><em>3. <span style="font-weight: 400;">Mestizo Restaurant 8%</span></em></p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div></div><p>&nbsp;</p><p>Photo: DIG File</p></div></div></div><div class='mailmunch-forms-after-post' style='display: none !important;'></div></div></div></article><div style="padding: 40px 60px 50px; background-color: #fff; box-shadow: 0 3px 5px 0 rgba(0,1,1,.1); margin-bottom: 30px;"><h3>Comments</h3><div class="fb-comments" data-href="https://digbr.com/greatest-margarita/" data-numposts="5" data-width="100%"></div></div><div class="gridlove-related"><div class="gridlove-module"><div class="module-header"><div class="module-title"><h4 class="h2">You may also like</h2></div></div><div class="row"><div class="col-lg-12 col-md-12 col-sm-12"><article class="gridlove-post gridlove-post-b gridlove-box  post-71968 post type-post status-publish format-standard has-post-thumbnail hentry category-brag-food-dining"><div class="entry-image"> <a href="https://digbr.com/greatest-overall-restaurant-2/" title="Overall Restaurant"><img width="385" height="300" src="https://digbr.com/wp-content/uploads/2018/04/chimes-seafood-385x300.jpeg" class="attachment-gridlove-b8 size-gridlove-b8 wp-post-image" alt="" data-wp-pid="71969" nopin="nopin" /></a></div><div class="box-inner-ptbr box-col-b entry-sm-overlay"><div class="box-inner-ellipsis"><div class="entry-category"> <a href="https://digbr.com/category/brag/brag-food-dining/" class="gridlove-cat gridlove-cat-322">Food &amp; Dining</a></div><h2 class="entry-title h3"><a href="https://digbr.com/greatest-overall-restaurant-2/">Overall Restaurant</a></h2><div class="entry-content"><p>The Chimes 32% Coming in as the greatest for not one, but FOUR of our categories, it is obvious that The Chimes is something special to Baton Rouge. Their food and beer selection have appeased the appetites of locals for over 25 years, and with no...</p></div></div><div class="entry-meta"><div class="meta-item meta-date"><span class="updated">16 hours ago</span></div></div></div></article></div></div></div></div></div><div class="gridlove-sidebar"><div id="shortcode-widget-2" class="widget gridlove-box shortcode_widget"><div class="textwidget"><article class="custom-614 gridlove-post gridlove-post-d gridlove-box post type-post status-publish format-standard has-post-thumbnail hentry"> <script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">ga('send', 'event', 'ads', 'impressions', 'Primeval Gear - Gear up for summer!');</script> <div class="entry-image"><a onclick="ga('send', 'event', 'ads', 'clicks', 'Primeval Gear - Gear up for summer!');" href="https://primevalgear.com" target="_blank"> <img width="770" height="575" src="https://digbr.com/wp-content/uploads/2017/12/croppedDSC_0182-BW-1.jpg" class="attachment-gridlove-d4 size-gridlove-d4 wp-post-image wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2017/12/croppedDSC_0182-BW-1.jpg 906w, https://digbr.com/wp-content/uploads/2017/12/croppedDSC_0182-BW-1-300x224.jpg 300w, https://digbr.com/wp-content/uploads/2017/12/croppedDSC_0182-BW-1-768x574.jpg 768w, https://digbr.com/wp-content/uploads/2017/12/croppedDSC_0182-BW-1-150x112.jpg 150w, https://digbr.com/wp-content/uploads/2017/12/croppedDSC_0182-BW-1-600x448.jpg 600w, https://digbr.com/wp-content/uploads/2017/12/croppedDSC_0182-BW-1-740x553.jpg 740w, https://digbr.com/wp-content/uploads/2017/12/croppedDSC_0182-BW-1-80x60.jpg 80w, https://digbr.com/wp-content/uploads/2017/12/croppedDSC_0182-BW-1-800x598.jpg 800w" sizes="(max-width: 770px) 100vw, 770px" data-wp-pid="71833" nopin="nopin" /> </a></div><div class="entry-overlay box-inner-p"><div class="box-inner-ellipsis"><h2 class="entry-title h3"> <a onclick="ga('send', 'event', 'ads', 'clicks', 'Primeval Gear - Gear up for summer!');" href="https://primevalgear.com" target="_blank">Gear up for summer!</a></h2><div class="client" style="">Primeval Gear</div></div></div></article></div></div><div id="mks_social_widget-4" class="widget gridlove-box mks_social_widget"><h4 class="widget-title">Follow Us</h4><ul class="mks_social_widget_ul"><li><a href="https://www.instagram.com/digbatonrouge/" title="Instagram" class="instagram_ico soc_circle" target="_blank" style="width: 42px; height: 42px; font-size: 16px;"><span>instagram</span></a></li><li><a href="https://twitter.com/DigBatonRouge" title="Twitter" class="twitter_ico soc_circle" target="_blank" style="width: 42px; height: 42px; font-size: 16px;"><span>twitter</span></a></li><li><a href="https://www.facebook.com/digbatonrouge/" title="Facebook" class="facebook_ico soc_circle" target="_blank" style="width: 42px; height: 42px; font-size: 16px;"><span>facebook</span></a></li></ul></div><div id="evcalwidget-2" class="widget gridlove-box EvcalWidget"><div id='evcal_widget' class='evo_widget'><div id='evcal_calendar_581' class='ajde_evcal_calendar  ul' ><div class='evo-data' data-cyear="2018" data-cmonth="5" data-runajax="1" data-evc_open="0" data-cal_ver="2.5.5" data-mapscroll="true" data-mapformat="roadmap" data-mapzoom="18" data-mapiconurl="" data-ev_cnt="5" data-show_limit="no" data-tiles="no" data-sort_by="sort_date" data-filters_on="false" data-range_start="0" data-range_end="0" data-send_unix="0" data-ux_val="0" data-accord="0" data-rtl="no"  ></div><div id='evcal_head' class='calendar_header ' ><div class='evo_cal_above'><span class='evo-gototoday-btn' style='display:none' data-mo='5' data-yr='2018' data-dy=''>Current Month</span></div><div class='evo_cal_above_content'></div><div class='cal_arguments' style='display:none' data-hide_past="yes" data-show_et_ft_img="no" data-event_order="ASC" data-ft_event_priority="no" data-lang="L1" data-month_incre="0" data-only_ft="no" data-evc_open="no" data-show_limit="no" data-etc_override="no" data-show_limit_redir="0" data-tiles="no" data-tile_height="0" data-tile_bg="0" data-tile_count="2" data-tile_style="0" data-s="" data-members_only="no" data-ux_val="0" data-show_limit_ajax="no" data-show_limit_paged="1" ></div><div class='clear'></div></div><div class='evcal_month_line'><p>may</p></div><div id='evcal_list' class='eventon_events_list '><div id="event_68729" class="eventon_list_event  event" data-event_id="68729" data-ri="21" data-time="1525204800-1525217400" data-colr="#ff057a" itemscope itemtype='http://schema.org/Event' 1><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/kings-of-karaoke-tuesdays/&quest;ri&equals;21&amp;'></a><span itemprop='name'  >Kings of Karaoke Tuesdays!</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2017/11/kings-of-karaoke-300x157.jpg' ></meta><meta itemprop='description' content='Come join us as The Station hosts Baton Rouge's BEST Karaoke Party tonite-- Kings of Karaoke! It's DJ GREEN GEAUX playing YOUR favorite songs every Tuesday night!  Bring your entire crew' ></meta><meta itemprop='startDate' content='2018-5-1' ></meta><meta itemprop='endDate' content='2018-5-1' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">The Station Sports Bar and Grill</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">4608 Bennington Ave, Baton Rouge, Louisiana 70808</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Kings of Karaoke Tuesdays!",
							  	"startDate": "2018-5-1T20-20-00-00",
							  	"endDate": "2018-5-1T23-23-30-00",
							  	"image":"https://digbr.com/wp-content/uploads/2017/11/kings-of-karaoke-300x157.jpg",
							  	"description":"Come join us as The Station hosts Baton Rouge's BEST Karaoke Party tonite-- Kings of Karaoke! It's DJ GREEN GEAUX playing YOUR favorite songs every Tuesday night!

Bring your entire crew",
							  	"location":{
										"@type":"Place",
										"name":"The Station Sports Bar and Grill",
										"address":"4608 Bennington Ave, Baton Rouge, Louisiana 70808"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #ff057a;" id="evc_152520480068729" class="event_repeat desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#ff057a' data-smon='may' data-syr='2018'><span class='evo_start '><em class='date'>01</em><em class='month'>may</em><em class='time'>8:00 pm</em></span><span class='evo_end only_time'><em class='time'>11:30 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.4200183,-91.1388287"  data-location_address="4608 Bennington Ave, Baton Rouge, Louisiana 70808" data-location_type="lonlat" data-location_name="The Station Sports Bar and Grill" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Kings of Karaoke Tuesdays!</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='502' data-imgwidth='960'  style='background-image: url("https://digbr.com/wp-content/uploads/2017/11/kings-of-karaoke.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>Come join us as The Station hosts Baton Rouge's BEST Karaoke Party tonite-- Kings of Karaoke! It's DJ GREEN GEAUX playing YOUR favorite songs every Tuesday night!  Bring your entire crew</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell shorter_desc'><div class='eventon_details_shading_bot'><p class='eventon_shad_p' content='less'><span class='ev_more_text' data-txt='less'>more</span><span class='ev_more_arrow'></span></p></div><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>Come join us as The Station hosts Baton Rouge&#8217;s BEST Karaoke Party tonite&#8211; Kings of Karaoke! It&#8217;s DJ GREEN GEAUX playing YOUR favorite songs every Tuesday night!</p><p>Bring your entire crew to jump on stage and sing along! And because it&#8217;s SERVICE INDUSTRY NITE, enjoy $6 wells all nite long along with other great food, drinks, &amp; yes, music! Check out all the new craft drafts on tap plus over 75 Imports and the best selections of spirits around! Our kitchen is always serving fantastic food until 1am!</p><p>We open at 4:30pm!</p><p>For more information including our weekly entertainment lineup , HUGE BEER MENU, and drink specials, visit <a href="https://l.facebook.com/l.php?u=http%3A%2F%2Fwww.StationSportsBar.com%2F&amp;h=ATPP30NI_L35zcZS8MyEP7RI2lsc5xCdAsdII0IHmPjhmx-5Vaek__2qrw2uc5NLVEGNpXTa3iCTsAIpWi8I1lL3pDDjuQ34uVqmdUSEHl1Fhhi7H8be6Jy7Be9oIbtvSUZQsBoWzxmqp3ihkDRRMqSD09NGqSzJGpXEdXI37nc7UnPeaST3fHM" target="_blank" rel="nofollow noopener" data-lynx-mode="origin">www.StationSportsBar.com</a>! Be sure to sign up for the mailing list to take advantage of members-only alerts and discounts!</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Tuesday) 8:00 pm - 11:30 pm</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='381'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>The Station Sports Bar and Grill</p><p>4608 Bennington Ave, Baton Rouge, Louisiana 70808</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=68729&amp;sunix=20180502T010000Z&amp;eunix=20180502T043000Z&amp;loca=4608 Bennington Ave, Baton Rouge, Louisiana 70808&amp;locn=The Station Sports Bar and Grill' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Kings+of+Karaoke+Tuesdays%21&amp;dates=20180502T010000Z/20180502T043000Z&amp;details=Come+join+us+as+The+Station+hosts+Baton+Rouge%27s+BEST+Karaoke+Party+tonite--+Kings+of+Karaoke%21+It%27s+DJ+GREEN+GEAUX+playing+YOUR+favorite+songs+every+Tuesday+night%21%0D%0A%0D%0ABring+your+entire+crew&amp;location=The+Station+Sports+Bar+and+Grill - 4608+Bennington+Ave%2C+Baton+Rouge%2C+Louisiana+70808' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_70854" class="eventon_list_event  event" data-event_id="70854" data-ri="7" data-time="1525278600-1525294800" data-colr="#5ca4b4" itemscope itemtype='http://schema.org/Event' 2><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/6-burger-nite-at-the-station-2/&quest;ri&equals;7&amp;'></a><span itemprop='name'  >$6 Burger Nite at the Station</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2018/03/28070379_10155360178243602_7054226522505134294_o-300x169.jpg' ></meta><meta itemprop='description' content='Every Wednesday is $6 Burger Nite at The Station 4:30-9pm! Come hungry, stay late! We've got a FREE Comedy Show 8-10pm and some awesome drink specials!  💥 $5 Wells
💥 $2 Bud' ></meta><meta itemprop='startDate' content='2018-5-2' ></meta><meta itemprop='endDate' content='2018-5-2' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">The Station Sports Bar and Grill</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">4608 Bennington Ave, Baton Rouge, Louisiana 70808</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "$6 Burger Nite at the Station",
							  	"startDate": "2018-5-2T16-16-30-00",
							  	"endDate": "2018-5-2T21-21-00-00",
							  	"image":"https://digbr.com/wp-content/uploads/2018/03/28070379_10155360178243602_7054226522505134294_o-300x169.jpg",
							  	"description":"Every Wednesday is $6 Burger Nite at The Station 4:30-9pm! Come hungry, stay late! We've got a FREE Comedy Show 8-10pm and some awesome drink specials!

💥 $5 Wells
💥 $2 Bud",
							  	"location":{
										"@type":"Place",
										"name":"The Station Sports Bar and Grill",
										"address":"4608 Bennington Ave, Baton Rouge, Louisiana 70808"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #5ca4b4;" id="evc_152527860070854" class="event_repeat desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#5ca4b4' data-smon='may' data-syr='2018'><span class='evo_start '><em class='date'>02</em><em class='month'>may</em><em class='time'><i>(may 2)</i>4:30 pm</em></span><span class='evo_end only_time'><em class='time'><i>(may 2)</i>4:30 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.4200183,-91.1388287"  data-location_address="4608 Bennington Ave, Baton Rouge, Louisiana 70808" data-location_type="lonlat" data-location_name="The Station Sports Bar and Grill" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>$6 Burger Nite at the Station</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='1152' data-imgwidth='2048'  style='background-image: url("https://digbr.com/wp-content/uploads/2018/03/28070379_10155360178243602_7054226522505134294_o.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>Every Wednesday is $6 Burger Nite at The Station 4:30-9pm! Come hungry, stay late! We've got a FREE Comedy Show 8-10pm and some awesome drink specials!  💥 $5 Wells
💥 $2 Bud</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell shorter_desc'><div class='eventon_details_shading_bot'><p class='eventon_shad_p' content='less'><span class='ev_more_text' data-txt='less'>more</span><span class='ev_more_arrow'></span></p></div><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>Every Wednesday is $6 Burger Nite at The Station 4:30-9pm! Come hungry, stay late! We&#8217;ve got a FREE Comedy Show 8-10pm and some awesome drink specials!</p><p>💥 $5 Wells<br /> 💥 $2 Bud Light<br /> 💥 $3 Tequila Shots</p><p>===========</p><p>Introducing our BRAND NEW MENU ft. an expanded burger lineup! Still proudly serving 100+ beers!</p><p>Daily Happy Hour Tuesday-Saturday Open-7pm + ALL NIGHT MONDAY!<br /> 💥 $3 Appetizers<span class="text_exposed_show"><br /> 💥 2-For-1 Wells<br /> 💥 $10 Domestic Buckets</p><p>Check out our menu, event calendar, and more <a href="https://l.facebook.com/l.php?u=http%3A%2F%2Fwww.StationSportsBar.com%2F&amp;h=ATMbxqUvbvJb5v4r7rdPujptSgVijfe67hgwv0UdPQ6LH79Z0jJvdOLa5_qtsAlT01_YtMidaeETADw-VrqUr3PMF89jxrgtxSfwBzIsUjdKonXN99tSEOuELIDQW-vLlRrfca39" target="_blank" rel="nofollow noopener" data-lynx-mode="async">www.StationSportsBar.com</a></span></p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Wednesday) 4:30 pm - 9:00 pm</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='381'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>The Station Sports Bar and Grill</p><p>4608 Bennington Ave, Baton Rouge, Louisiana 70808</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=70854&amp;sunix=20180502T213000Z&amp;eunix=20180503T020000Z&amp;loca=4608 Bennington Ave, Baton Rouge, Louisiana 70808&amp;locn=The Station Sports Bar and Grill' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=%246+Burger+Nite+at+the+Station&amp;dates=20180502T213000Z/20180503T020000Z&amp;details=Every+Wednesday+is+%246+Burger+Nite+at+The+Station+4%3A30-9pm%21+Come+hungry%2C+stay+late%21+We%27ve+got+a+FREE+Comedy+Show+8-10pm+and+some+awesome+drink+specials%21%0D%0A%0D%0A%F0%9F%92%A5+%245+Wells%0D%0A%F0%9F%92%A5+%242+Bud&amp;location=The+Station+Sports+Bar+and+Grill - 4608+Bennington+Ave%2C+Baton+Rouge%2C+Louisiana+70808' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_68671" class="eventon_list_event  event" data-event_id="68671" data-ri="22" data-time="1525287600-1525298400" data-colr="#ff057a" itemscope itemtype='http://schema.org/Event' 3><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/ladies-night-karaoke/&quest;ri&equals;22&amp;'></a><span itemprop='name'  >Ladies Night Karaoke</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2017/11/karaoke-300x300.jpg' ></meta><meta itemprop='description' content='Every Wednesday we've got Karaoke starting at 7pm with ½ off bottles of wine, $5 strawberry margaritas, and $3 select cocktails!' ></meta><meta itemprop='startDate' content='2018-5-2' ></meta><meta itemprop='endDate' content='2018-5-2' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Lava Cantina</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">10001 Perkins Rowe Baton Rouge, LA 70810</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Ladies Night Karaoke",
							  	"startDate": "2018-5-2T19-19-00-00",
							  	"endDate": "2018-5-2T22-22-00-00",
							  	"image":"https://digbr.com/wp-content/uploads/2017/11/karaoke-300x300.jpg",
							  	"description":"Every Wednesday we've got Karaoke starting at 7pm with ½ off bottles of wine, $5 strawberry margaritas, and $3 select cocktails!",
							  	"location":{
										"@type":"Place",
										"name":"Lava Cantina",
										"address":"10001 Perkins Rowe Baton Rouge, LA 70810"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #ff057a;" id="evc_152528760068671" class="event_repeat desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#ff057a' data-smon='may' data-syr='2018'><span class='evo_start '><em class='date'>02</em><em class='month'>may</em><em class='time'><i>(may 2)</i>7:00 pm</em></span><span class='evo_end only_time'><em class='time'><i>(may 2)</i>7:00 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.3797337,-91.0949915"  data-location_address="10001 Perkins Rowe Baton Rouge, LA 70810" data-location_type="lonlat" data-location_name="Lava Cantina" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Ladies Night Karaoke</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='960' data-imgwidth='960'  style='background-image: url("https://digbr.com/wp-content/uploads/2017/11/karaoke.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>Every Wednesday we've got Karaoke starting at 7pm with ½ off bottles of wine, $5 strawberry margaritas, and $3 select cocktails!</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>Every Wednesday we&#8217;ve got Karaoke starting at 7pm with ½ off bottles of wine, $5 strawberry margaritas, and $3 select cocktails!</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Wednesday) 7:00 pm - 10:00 pm</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='360'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Lava Cantina</p><p>10001 Perkins Rowe Baton Rouge, LA 70810</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=68671&amp;sunix=20180503T000000Z&amp;eunix=20180503T030000Z&amp;loca=10001 Perkins Rowe Baton Rouge, LA 70810&amp;locn=Lava Cantina' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Ladies+Night+Karaoke&amp;dates=20180503T000000Z/20180503T030000Z&amp;details=Every+Wednesday+we%27ve+got+Karaoke+starting+at+7pm+with+%C2%BD+off+bottles+of+wine%2C+%245+strawberry+margaritas%2C+and+%243+select+cocktails%21&amp;location=Lava+Cantina - 10001+Perkins+Rowe+Baton+Rouge%2C+LA+70810' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_69958" class="eventon_list_event  event" data-event_id="69958" data-time="1525305601-1525564799" data-colr="#ff057a" itemscope itemtype='http://schema.org/Event' 4><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/weekend-two-2018-new-orleans-jazz-fest/'></a><span itemprop='name'  >Weekend Two - 2018 New Orleans Jazz Fest</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2018/01/jazz-1-300x169.jpg' ></meta><meta itemprop='description' content='Started in 1970, "Jazz Fest" continues to showcase the most important names in music both locally and nationally. Celebrating 49 years of musical and cultural memories, Jazz Fest stands alone' ></meta><meta itemprop='startDate' content='2018-5-3' ></meta><meta itemprop='endDate' content='2018-5-5' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Fair Grounds Race Course and Slots</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">1751 Gentilly Blvd, New Orleans, Louisiana 70119</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Weekend Two - 2018 New Orleans Jazz Fest",
							  	"startDate": "2018-5-3T00-00-00-00",
							  	"endDate": "2018-5-5T23-23-59-00",
							  	"image":"https://digbr.com/wp-content/uploads/2018/01/jazz-1-300x169.jpg",
							  	"description":"Started in 1970, "Jazz Fest" continues to showcase the most important names in music both locally and nationally. Celebrating 49 years of musical and cultural memories, Jazz Fest stands alone",
							  	"location":{
										"@type":"Place",
										"name":"Fair Grounds Race Course and Slots",
										"address":"1751 Gentilly Blvd, New Orleans, Louisiana 70119"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #ff057a;" id="evc_152530560169958" class="desc_trig mul_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#ff057a' data-smon='may' data-syr='2018'><span class='evo_start '><em class='date'>03</em><em class='month'>may</em><em class='time'>allday</em></span><span class='evo_end '><em class='date'>05</em><em class='time'>allday</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata '  data-location_address="1751 Gentilly Blvd, New Orleans, Louisiana 70119" data-location_type="address" data-location_name="Fair Grounds Race Course and Slots" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Weekend Two - 2018 New Orleans Jazz Fest</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='1080' data-imgwidth='1920'  style='background-image: url("https://digbr.com/wp-content/uploads/2018/01/jazz-1.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>Started in 1970, "Jazz Fest" continues to showcase the most important names in music both locally and nationally. Celebrating 49 years of musical and cultural memories, Jazz Fest stands alone</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell shorter_desc'><div class='eventon_details_shading_bot'><p class='eventon_shad_p' content='less'><span class='ev_more_text' data-txt='less'>more</span><span class='ev_more_arrow'></span></p></div><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>Started in 1970, &#8220;Jazz Fest&#8221; continues to showcase the most important names in music both locally and nationally. Celebrating 49 years of musical and cultural memories, Jazz Fest stands alone in presenting the highest caliber artists in such varied genres as gospel, blues, traditional and contemporary jazz, rock, R&amp;B, Cajun, country, zydeco and much more.</p><p>Thursday, May 3 Lineup:<br /> <a href="http://www.nojazzfest.com/lineup/#/lineup_groupings/thursday-may-3" target="_blank" rel="nofollow noopener" data-lynx-mode="async" data-lynx-uri="https://l.facebook.com/l.php?u=http%3A%2F%2Fwww.nojazzfest.com%2Flineup%2F%23%2Flineup_groupings%2Fthursday-may-3&amp;h=ATPphx1qdP-fSQhxzlXH6ryiI527mID-Tme8jiwnu30C_1Y1GiBDs0HnRmJ9g59S9-hMBPDn19xxz2gYn8q1JUkkOEhg0yocIsbbJnvrwZJFyxFDx4YFAtxf7GxJOYZvSvkQwHcwCqre-fRe8T7Et5RWQTyCWh3LK96TnZGu3hqpnp7FFo39Oi0">http://www.nojazzfest.com/<wbr />lineup/#/lineup_groupings/<wbr />thursday-may-3</a></p><p>Friday, May 4 Lineup:<br /> <a href="http://www.nojazzfest.com/lineup/#/lineup_groupings/friday-may-4" target="_blank" rel="nofollow noopener" data-lynx-mode="async" data-lynx-uri="https://l.facebook.com/l.php?u=http%3A%2F%2Fwww.nojazzfest.com%2Flineup%2F%23%2Flineup_groupings%2Ffriday-may-4&amp;h=ATPUZhIspqtARa7TSpNxnGMJa5psyPUxVRMS8KEatVKyE4I3TDB06iYZ-_RlebgNLbpPH8O-XdlCrLND4QW0siB6SzBhsZIoXmfxhQl-9J4mSPJcOq0G0TTD-AJ-0v7UghYZnK2Bwoyu1sv22QGtlYWU-WIEC-swP5-aoDENwrvBEm0dglUQi4Q">http://www.nojazzfest.com/<wbr />lineup/#/lineup_groupings/<wbr />friday-may-4</a></p><p>Saturday, May 5 Lineup:<br /> <a href="http://www.nojazzfest.com/lineup/#/lineup_groupings/saturday-may-5" target="_blank" rel="nofollow noopener" data-lynx-mode="async" data-lynx-uri="https://l.facebook.com/l.php?u=http%3A%2F%2Fwww.nojazzfest.com%2Flineup%2F%23%2Flineup_groupings%2Fsaturday-may-5&amp;h=ATPvj0T5NxBAcf6sSNlKryoKFRgvMth50WtOteOT-1ejDVkZ1lVy2zfpiKpm-5CJ71bkGRoMBQKoe8W6tN3Kysn6rzzJH2s_oh1MpbXfTQgBoZkl2pXNni09rlrTHN620_Ktu6ioxp3Pu0SJY0bvyIJDp6vrfy9YGI8vG6bPM_22bt80Bh47Bls">http://www.nojazzfest.com/<wbr />lineup/#/lineup_groupings/<wbr />saturday-may-5</a></p><p>Sunday, May 6 Lineup:<br /> <a href="http://www.nojazzfest.com/lineup/#/lineup_groupings/sunday-may-6" target="_blank" rel="nofollow noopener" data-lynx-mode="async" data-lynx-uri="https://l.facebook.com/l.php?u=http%3A%2F%2Fwww.nojazzfest.com%2Flineup%2F%23%2Flineup_groupings%2Fsunday-may-6&amp;h=ATN48W-jBaJy0qHKQ2TpCjJNOjurRwRToNTZuEJzrpV-29EUblZ3R7UucBOA3iZtBUi0xiDYsVzCOeKu-QxBg8XMWknRt_OxPN0FtvvYK8kc4bY1iJeqPIlXdRknHNoMqEjv0-4R0kyCtvTTxHM6vqV6wcBsmRdmsNthWEKHapImaAkrq1DDkUA">http://www.nojazzfest.com/<wbr />lineup/#/lineup_groupings/<wbr />sunday-may-6</a></p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>may 3 (Thursday) - 5 (Saturday)</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='618'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Fair Grounds Race Course and Slots</p><p>1751 Gentilly Blvd, New Orleans, Louisiana 70119</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=69958&amp;sunix=20180503T050000Z&amp;eunix=20180506T045900Z&amp;loca=1751 Gentilly Blvd, New Orleans, Louisiana 70119&amp;locn=Fair Grounds Race Course and Slots' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Weekend+Two+-+2018+New+Orleans+Jazz+Fest&amp;dates=20180503T050000Z/20180506T045900Z&amp;details=Started+in+1970%2C+%22Jazz+Fest%22+continues+to+showcase+the+most+important+names+in+music+both+locally+and+nationally.+Celebrating+49+years+of+musical+and+cultural+memories%2C+Jazz+Fest+stands+alone&amp;location=Fair+Grounds+Race+Course+and+Slots - 1751+Gentilly+Blvd%2C+New+Orleans%2C+Louisiana+70119' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_71213" class="eventon_list_event  event" data-event_id="71213" data-ri="4" data-time="1525366800-1525381200" data-colr="#5ca4b4" itemscope itemtype='http://schema.org/Event' 5><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/thursdays-all-you-can-eat-crawfish/&quest;ri&equals;4&amp;'></a><span itemprop='name'  >Thursday's All You Can Eat Crawfish</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2018/04/27337362_1840528702912073_1627601172524143827_n-300x201.jpg' ></meta><meta itemprop='description' content='Stinky's Fish Camp will be having ALL YOU CAN EAT CRAWFISH from 5pm-9pm. Live Music, Great Food, Great Service, Great Time. Call now to make reservations 225-615-3870!' ></meta><meta itemprop='startDate' content='2018-5-3' ></meta><meta itemprop='endDate' content='2018-5-3' ></meta><meta itemprop='eventStatus' content='on-schedule' ></meta> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Stinky&#039;s Fish Camp</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">5500 Hilton Ave</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Thursday's All You Can Eat Crawfish",
							  	"startDate": "2018-5-3T17-17-00-00",
							  	"endDate": "2018-5-3T21-21-00-00",
							  	"image":"https://digbr.com/wp-content/uploads/2018/04/27337362_1840528702912073_1627601172524143827_n-300x201.jpg",
							  	"description":"Stinky's Fish Camp will be having ALL YOU CAN EAT CRAWFISH from 5pm-9pm. Live Music, Great Food, Great Service, Great Time. Call now to make reservations 225-615-3870!",
							  	"location":{
										"@type":"Place",
										"name":"Stinky&#039;s Fish Camp",
										"address":"5500 Hilton Ave"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #5ca4b4;" id="evc_152536680071213" class="event_repeat desc_trig sin_val evcal_list_a" data-ux_val="1" ><span class='evcal_cblock ' data-bgcolor='#5ca4b4' data-smon='may' data-syr='2018'><span class='evo_start '><em class='date'>03</em><em class='month'>may</em><em class='time'><i>(may 3)</i>5:00 pm</em></span><span class='evo_end only_time'><em class='time'><i>(may 3)</i>5:00 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.423142,-91.1343135"  data-location_address="5500 Hilton Ave" data-location_type="lonlat" data-location_name="Stinky&#039;s Fish Camp" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Thursday's All You Can Eat Crawfish</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></p></a><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='642' data-imgwidth='960'  style='background-image: url("https://digbr.com/wp-content/uploads/2018/04/27337362_1840528702912073_1627601172524143827_n.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>Stinky's Fish Camp will be having ALL YOU CAN EAT CRAWFISH from 5pm-9pm. Live Music, Great Food, Great Service, Great Time. Call now to make reservations 225-615-3870!</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>Stinky&#8217;s Fish Camp will be having ALL YOU CAN EAT CRAWFISH from 5pm-9pm. Live Music, Great Food, Great Service, Great Time. Call now to make reservations 225-615-3870!</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Thursday) 5:00 pm - 9:00 pm</p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='647'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Stinky&#039;s Fish Camp</p><p>5500 Hilton Ave</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=71213&amp;sunix=20180503T220000Z&amp;eunix=20180504T020000Z&amp;loca=5500 Hilton Ave&amp;locn=Stinky&#039;s Fish Camp' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Thursday%27s+All+You+Can+Eat+Crawfish&amp;dates=20180503T220000Z/20180504T020000Z&amp;details=Stinky%27s+Fish+Camp+will+be+having+ALL+YOU+CAN+EAT+CRAWFISH+from+5pm-9pm.+Live+Music%2C+Great+Food%2C+Great+Service%2C+Great+Time.+Call+now+to+make+reservations+225-615-3870%21&amp;location=Stinky%26%23039%3Bs+Fish+Camp - 5500+Hilton+Ave' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div></div><div class='clear'></div></div></div></div><div id="gridlove_posts_widget-1" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Recent posts<span class="gridlove-slider-controls" data-autoplay="0"></span></h4><div class="gridlove-posts-widget gridlove-widget-slider"><div class="gridlove-posts-widget-item-wrapper"><article class="post-71968 post type-post status-publish format-standard has-post-thumbnail hentry category-brag-food-dining"><div class="entry-image"> <a href="https://digbr.com/greatest-overall-restaurant-2/" title="Overall Restaurant"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/04/chimes-seafood-80x60.jpeg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="71969" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/greatest-overall-restaurant-2/">Overall Restaurant</a></h6></div></article><article class="post-71966 post type-post status-publish format-standard has-post-thumbnail hentry category-brag-food-dining"><div class="entry-image"> <a href="https://digbr.com/greatest-cajun-creole/" title="Cajun/Creole"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/04/parrains-cajun-80x60.jpeg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="71967" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/greatest-cajun-creole/">Cajun/Creole</a></h6></div></article><article class="post-71963 post type-post status-publish format-standard has-post-thumbnail hentry category-brag-food-dining"><div class="entry-image"> <a href="https://digbr.com/greatest-steak-2/" title="Steak"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/04/ruths-chris-80x60.jpeg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2018/04/ruths-chris-80x60.jpeg 80w, https://digbr.com/wp-content/uploads/2018/04/ruths-chris-300x225.jpeg 300w, https://digbr.com/wp-content/uploads/2018/04/ruths-chris-768x575.jpeg 768w, https://digbr.com/wp-content/uploads/2018/04/ruths-chris-1024x767.jpeg 1024w, https://digbr.com/wp-content/uploads/2018/04/ruths-chris-150x112.jpeg 150w, https://digbr.com/wp-content/uploads/2018/04/ruths-chris-600x450.jpeg 600w, https://digbr.com/wp-content/uploads/2018/04/ruths-chris-1032x773.jpeg 1032w, https://digbr.com/wp-content/uploads/2018/04/ruths-chris-740x554.jpeg 740w, https://digbr.com/wp-content/uploads/2018/04/ruths-chris-800x599.jpeg 800w, https://digbr.com/wp-content/uploads/2018/04/ruths-chris.jpeg 1280w" sizes="(max-width: 80px) 100vw, 80px" data-wp-pid="71964" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/greatest-steak-2/">Steak</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-71961 post type-post status-publish format-standard has-post-thumbnail hentry category-brag-food-dining"><div class="entry-image"> <a href="https://digbr.com/greatest-beer-selection-2/" title="Happy Hour"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/04/superiorhappyhour-80x60.jpeg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="71962" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/greatest-beer-selection-2/">Happy Hour</a></h6></div></article><article class="post-71959 post type-post status-publish format-standard has-post-thumbnail hentry category-brag-food-dining"><div class="entry-image"> <a href="https://digbr.com/greatest-beer-selection/" title="Beer Selection"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/04/chimes-beer-board-80x60.jpeg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="71960" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/greatest-beer-selection/">Beer Selection</a></h6></div></article><article class="post-71957 post type-post status-publish format-standard has-post-thumbnail hentry category-brag-food-dining"><div class="entry-image"> <a href="https://digbr.com/greatest-sushi-2/" title="Sushi"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/04/ichibansushi-80x60.jpeg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="71958" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/greatest-sushi-2/">Sushi</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-71954 post type-post status-publish format-standard has-post-thumbnail hentry category-brag-food-dining"><div class="entry-image"> <a href="https://digbr.com/greatest-place-to-eat-at-the-bar/" title="Place to Eat at the Bar"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/04/chimesboudinballs-80x60.jpeg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="71955" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/greatest-place-to-eat-at-the-bar/">Place to Eat at the Bar</a></h6></div></article><article class="post-71952 post type-post status-publish format-standard has-post-thumbnail hentry category-brag-food-dining"><div class="entry-image"> <a href="https://digbr.com/greatest-margarita/" title="Margarita"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/04/superiormarg-80x60.jpeg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="71953" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/greatest-margarita/">Margarita</a></h6></div></article><article class="post-71949 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-perk tag-now"><div class="entry-image"> <a href="https://digbr.com/win-dinner-for-two-to-qdoba/" title="Win dinner for two to Qdoba!"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2018/04/qdoba-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="71950" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/win-dinner-for-two-to-qdoba/">Win dinner for two to Qdoba!</a></h6></div></article></div></div></div><div id="shortcode-widget-3" class="widget gridlove-box shortcode_widget"><div class="textwidget"><article class="custom-614 gridlove-post gridlove-post-d gridlove-box post type-post status-publish format-standard has-post-thumbnail hentry"> <script type="text/javascript">ga('send', 'event', 'ads', 'impressions', 'Beausoleil Restaurant & Bar - Happy Hour Monday &#8211; Friday 3pm-6pm');</script> <div class="entry-image"><a onclick="ga('send', 'event', 'ads', 'clicks', 'Beausoleil Restaurant & Bar - Happy Hour Monday &#8211; Friday 3pm-6pm');" href="http://beausoleilrestaurant.com" target="_blank"> <img width="700" height="565" src="https://digbr.com/wp-content/uploads/2018/03/beausoleil.jpg" class="attachment-gridlove-d4 size-gridlove-d4 wp-post-image wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2018/03/beausoleil.jpg 700w, https://digbr.com/wp-content/uploads/2018/03/beausoleil-300x242.jpg 300w, https://digbr.com/wp-content/uploads/2018/03/beausoleil-150x121.jpg 150w, https://digbr.com/wp-content/uploads/2018/03/beausoleil-600x484.jpg 600w, https://digbr.com/wp-content/uploads/2018/03/beausoleil-370x300.jpg 370w" sizes="(max-width: 700px) 100vw, 700px" data-wp-pid="71012" nopin="nopin" /> </a></div><div class="entry-overlay box-inner-p"><div class="box-inner-ellipsis"><h2 class="entry-title h3"> <a onclick="ga('send', 'event', 'ads', 'clicks', 'Beausoleil Restaurant & Bar - Happy Hour Monday &#8211; Friday 3pm-6pm');" href="http://beausoleilrestaurant.com" target="_blank">Happy Hour Monday &#8211; Friday 3pm-6pm</a></h2><div class="client" style="">Beausoleil Restaurant & Bar</div></div></div></article></div></div></div></div></div><div id="footer" class="gridlove-footer"><div class="container"><div class="row"><div class="col-lg-4 col-md-6 col-sm-12"><div id="text-2" class="widget widget_text"><div class="textwidget"><p><img width="159" src="https://digbr.com/wp-content/uploads/2017/09/DIG-wht.png"/></p><p>DIGBR.com is how Baton Rouge keeps the pulse of our great city. We curate what's important and deliver it fast and throughout the day along with great content from your monthly DIG Magazine.</p></div></div><div id="mks_social_widget-3" class="widget mks_social_widget"><ul class="mks_social_widget_ul"><li><a href="https://www.facebook.com/digbatonrouge/" title="Facebook" class="facebook_ico soc_circle" target="_blank" style="width: 40px; height: 40px; font-size: 16px;"><span>facebook</span></a></li><li><a href="https://twitter.com/DigBatonRouge" title="Twitter" class="twitter_ico soc_circle" target="_blank" style="width: 40px; height: 40px; font-size: 16px;"><span>twitter</span></a></li><li><a href="https://www.instagram.com/digbatonrouge/" title="Instagram" class="instagram_ico soc_circle" target="_blank" style="width: 40px; height: 40px; font-size: 16px;"><span>instagram</span></a></li></ul></div></div><div class="col-lg-4 col-md-6 col-sm-12"><div id="mc4wp_widget-3" class="widget widget_mc4wp_widget"><h4 class="widget-title">Newsletter</h4><div id="mc4wp-form-1" class="mc4wp-form mc4wp-form-47580 mc4wp-ajax "><form method="post" action="https://digbr.com/greatest-margarita/"><p> <label for="mc4wp_email">Every day, DIG hits your inbox with the latest happening in BR - news, fun, cool events and more.</label> <input type="email" id="mc4wp_email" name="EMAIL" required placeholder="Your email address" /></p><p> <input type="submit" value="Sign up" /></p><textarea name="_mc4wp_required_but_not_really" style="display: none;"></textarea><input type="hidden" name="_mc4wp_form_ID" value="47580" /><input type="hidden" name="_mc4wp_form_instance" value="1" /><input type="hidden" name="_mc4wp_form_submit" value="1" /><input type="hidden" name="_mc4wp_form_nonce" value="b176a280cc" /></form><span class="mc4wp-ajax-loader" style="display: none;"></span><div style="display:none;" class="mc4wp-alert mc4wp-success-message mc4wp-success">Thank you, your sign-up request was successful! Please check your e-mail inbox. <span class="mc4wp-mailchimp-error"></span></div><div style="display:none;" class="mc4wp-alert mc4wp-already_subscribed-message mc4wp-notice">Given email address is already subscribed, thank you! <span class="mc4wp-mailchimp-error"></span></div><div style="display:none;" class="mc4wp-alert mc4wp-invalid_email-message mc4wp-error">Please provide a valid email address. <span class="mc4wp-mailchimp-error"></span></div><div style="display:none;" class="mc4wp-alert mc4wp-error-message mc4wp-error">Oops. Something went wrong. Please try again later. <span class="mc4wp-mailchimp-error"></span></div></div></div></div><div class="col-lg-4 col-md-6 col-sm-12"><div id="nav_menu-1" class="widget widget_nav_menu"><h4 class="widget-title">Help &#038; Support</h4><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-47573" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47573"><a href="https://digbr.com/terms-of-service/">Terms of Service</a></li><li id="menu-item-47574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47574"><a href="https://digbr.com/advertise-with-dig/">Advertise</a></li><li id="menu-item-47576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47576"><a href="https://digbr.com/join-the-team/">Join the Team!</a></li><li id="menu-item-48020" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48020"><a href="https://digbr.com/find-a-copy/">Find a copy</a></li><li id="menu-item-63187" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63187"><a href="https://digbr.com/aboutcontact/">About/Contact</a></li></ul></div></div></div></div></div><div class="gridlove-copyright"><div class="container"><p style="text-align: center">Copyright © 2017 · Primedia Holdings, LLC</p></div></div></div><div class="gridlove-sidebar-action-wrapper"> <span class="gridlove-action-close"><i class="fa fa-times" aria-hidden="true"></i></span><div class="gridlove-sidebar-action-inside"><div class="hidden-lg-up widget gridlove-box widget_nav_menu"><ul id="menu-main-menu-2" class="gridlove-mobile-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6977"><a href="https://digbr.com/category/news/">NEWS</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66360"><a href="https://digbr.com/category/news/crime/">Crime</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66359"><a href="https://digbr.com/category/news/biz/">Business</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7141"><a href="https://digbr.com/category/news/opinion/">Opinion</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6979"><a href="https://digbr.com/category/news/campus/">LSU</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7306"><a href="https://digbr.com/category/leisure/">LEISURE</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66358"><a href="https://digbr.com/the-lineup/">Things to do</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66393"><a href="https://digbr.com/food-drink/">Food &#038; Drink</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6969"><a href="https://digbr.com/category/leisure/arts-culture/">Arts &#038; Culture</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7316"><a href="https://digbr.com/category/sports/">Sports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6972"><a href="https://digbr.com/category/leisure/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31878"><a href="https://digbr.com/category/leisure/fitness/">Health &#038; Fitness</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47579"><a href="#">FUN STUFF!</a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-47583"><a href="https://digbr.com/product-category/ticketed-event/">DIG Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7155"><a href="https://digbr.com/category/galleries/">Galleries</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66741"><a href="https://digbr.com/category/magazine/">MAGAZINE</a></li></ul></div><div id="mks_social_widget-1" class="widget gridlove-box mks_social_widget"><h4 class="widget-title">Follow us</h4><p>Don't be shy, get in touch. We love meeting interesting people and making new friends.</p><ul class="mks_social_widget_ul"><li><a href="https://www.facebook.com/mekshq" title="Facebook" class="facebook_ico soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;"><span>facebook</span></a></li><li><a href="https://twitter.com/mekshq" title="Twitter" class="twitter_ico soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;"><span>twitter</span></a></li><li><a href="http://youtube.com/" title="Youtube" class="youtube_ico soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;"><span>youtube</span></a></li><li><a href="http://blogger.com" title="Blogger" class="blogger_ico soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;"><span>blogger</span></a></li></ul></div><div id="gridlove_posts_widget-2" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Most popular<span class="gridlove-slider-controls" data-autoplay="0"></span></h4></div><div id="gridlove_posts_widget-3" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Most discussed<span class="gridlove-slider-controls" data-autoplay="0"></span></h4><div class="gridlove-posts-widget gridlove-widget-slider"><div class="gridlove-posts-widget-item-wrapper"><article class="post-12295 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-sports"><div class="entry-image"> <a href="https://digbr.com/londoner-hosts-celebration-of-historic-usa-world-cup-victory/" title="Londoner Hosts Celebration of Historic USA World Cup Victory"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/ANCHOR_Outlaws-Londoner-12-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12296" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/londoner-hosts-celebration-of-historic-usa-world-cup-victory/">Londoner Hosts Celebration of Historic USA World Cup Victory</a></h6></div></article><article class="post-12485 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/business-as-usual-bobby-jindal-crony-capitalism/" title="Business As Usual"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/Fred-Dive-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12486" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/business-as-usual-bobby-jindal-crony-capitalism/">Business As Usual</a></h6></div></article><article class="post-12047 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-leisure category-sports"><div class="entry-image"> <a href="https://digbr.com/digs-baton-rouge-world-cup-watch-guide/" title="DIG&#8217;s Baton Rouge World Cup Watch Guide"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/JUMP-2014.06.07_DIG_FUTBOL-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12048" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/digs-baton-rouge-world-cup-watch-guide/">DIG&#8217;s Baton Rouge World Cup Watch Guide</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-12652 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/paul-stars-part-two/" title="All Mainieri Team: Infield"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/07/JUMP-Austin-Nola-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12653" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/paul-stars-part-two/">All Mainieri Team: Infield</a></h6></div></article><article class="post-12262 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/red-stick-roller-derby-baton-rouge-bittersweet/" title="BITTERSWEET"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/roller-derby-1-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12265" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/red-stick-roller-derby-baton-rouge-bittersweet/">BITTERSWEET</a></h6></div></article><article class="post-49342 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/fargas-finished-lsu-womens-basketball-needs-to-move-past-coaching-regime/" title="Fargas finished? LSU women&#8217;s basketball needs to move past coaching regime"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2016/03/Fargas-1-e1457541734999-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="49344" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/fargas-finished-lsu-womens-basketball-needs-to-move-past-coaching-regime/">Fargas finished? LSU women&#8217;s basketball needs to move past coaching regime</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-48120 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/diamonds-in-the-rough/" title="Diamonds in the Rough"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2016/02/Jacob-Hester-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="48123" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/diamonds-in-the-rough/">Diamonds in the Rough</a></h6></div></article><article class="post-28505 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/making-moves-taking-risks/" title="Making Moves, Taking Risks"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2015/03/Jimmy-Graham-80x60.png" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="28506" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/making-moves-taking-risks/">Making Moves, Taking Risks</a></h6></div></article><article class="post-30257 post type-post status-publish format-standard has-post-thumbnail hentry category-outdoors category-sports tag-chase-berenson"><div class="entry-image"> <a href="https://digbr.com/camping-on-the-cajun-riveriera/" title="Camping on the Cajun Riveriera"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-80x60.jpg 80w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-300x225.jpg 300w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-768x576.jpg 768w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-1024x768.jpg 1024w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-150x113.jpg 150w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-600x450.jpg 600w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-1032x774.jpg 1032w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-740x555.jpg 740w, https://digbr.com/wp-content/uploads/2015/05/Holly-Beach-800x600.jpg 800w" sizes="(max-width: 80px) 100vw, 80px" data-wp-pid="30258" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/camping-on-the-cajun-riveriera/">Camping on the Cajun Riveriera</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-16337 post type-post status-publish format-standard hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/game-day-preview-lsu-vs-nmsu/" title="Game Day Preview: LSU vs. NMSU"> <img src="https://demo.mekshq.com/gridlove/wp-content/themes/gridlove/assets/img/gridlove_default.jpg" alt="Game Day Preview: LSU vs. NMSU" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/game-day-preview-lsu-vs-nmsu/">Game Day Preview: LSU vs. NMSU</a></h6></div></article><article class="post-18423 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/game-day-preview-lsu-vs-ole-miss/" title="Game Day Preview: LSU vs. Ole Miss"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/10/LSU-vs-UM-0025-copy-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="18425" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/game-day-preview-lsu-vs-ole-miss/">Game Day Preview: LSU vs. Ole Miss</a></h6></div></article><article class="post-11599 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/lsu-wins-sec-tournament-championship/" title="LSU wins SEC Tournament Championship"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/05/LSU-SEC-Champs-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="11600" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/lsu-wins-sec-tournament-championship/">LSU wins SEC Tournament Championship</a></h6></div></article></div></div></div></div></div><div class="gridlove-sidebar-action-overlay"></div> <script type="text/javascript">var gmapstyles = 'default';</script> <div id="fb-root"></div> <script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=713095298769737";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MW6NQMQ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>  <script>jQuery(document)
	.on('ready', function(){
		if(jQuery('body').is('.home')){
			setTimeout(function(){
				window.location.reload(1);
			}, 1800000);
		}
	});</script><div class='evo_lightboxes'><div class='evo_lightbox eventcard eventon_events_list' id=''><div class="evo_content_in"><div class="evo_content_inin"><div class="evo_lightbox_content"> <a class='evolbclose '>X</a><div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'></div></div></div></div></div></div><script type='text/javascript'>var evoli_ajax_script = {"evoli_ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php","postnonce":"ff28285cdc"};</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/digbr.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};</script> <script type='text/javascript'>var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/greatest-margarita\/?wc-ajax=%%endpoint%%"};</script> <script type='text/javascript'>var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/greatest-margarita\/?wc-ajax=%%endpoint%%","fragment_name":"wc_fragments"};</script> <script type='text/javascript'>var gridlove_js_settings = {"rtl_mode":"","header_sticky":"1","header_sticky_offset":"100","header_sticky_up":"","logo":"https:\/\/digbr.com\/wp-content\/uploads\/2018\/02\/DIG-Logo-white-sm.png","logo_retina":"https:\/\/digbr.com\/wp-content\/uploads\/2018\/02\/DIG-Logo-white-ret.png","logo_mini":"https:\/\/digbr.com\/wp-content\/uploads\/2018\/02\/DIG-Logo-white-mini2.png","logo_mini_retina":"","gridlove_gallery":"1"};</script> <script type='text/javascript'>var the_ajax_script = {"ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php","postnonce":"f5d117d10f"};</script> <script type='text/javascript' src='https://maps.googleapis.com/maps/api/js?ver=1.0'></script> <script type='text/javascript'>var mc4wp_vars = {"ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php","ajax_loader_url":"https:\/\/digbr.com\/wp-content\/plugins\/mailchimp-for-wp-pro\/assets\/img\/ajax-loader.gif"};</script>  </style>  <script type="text/javascript" defer src="https://digbr.com/wp-content/cache/autoptimize/js/autoptimize_2b0972682d67c002f5613295efc27523.js"></script></body></html>