<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#" class="no-js"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width,initial-scale=1.0"><link type="text/css" media="all" href="https://digbr.com/wp-content/cache/autoptimize/css/autoptimize_0946e7e03279ff4c9da792011eec473b.css" rel="stylesheet" /><link type="text/css" media="screen" href="https://digbr.com/wp-content/cache/autoptimize/css/autoptimize_f2cb9830a034f3a14d79a37fa33a315b.css" rel="stylesheet" /><link type="text/css" media="only screen and (max-width: 768px)" href="https://digbr.com/wp-content/cache/autoptimize/css/autoptimize_dcb2de333eec7ab4ae31385ed8d6a393.css" rel="stylesheet" /><title>Looking forward: Baton Rouge openings in 2020 &#8211; Dig Baton Rouge</title><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Dig Baton Rouge &raquo; Feed" href="https://digbr.com/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/digbr.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.0.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='gridlove-fonts-css'  href='https://fonts.googleapis.com/css?family=Cabin%3A400%2C700%7CLato%3A400%2C700&#038;subset=latin%2Clatin-ext&#038;ver=1.7.2' type='text/css' media='all' /><link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A700%2C400%2C400i%7CRoboto%3A700%2C400&#038;ver=5.0.8' type='text/css' media='screen' /><link rel='stylesheet' id='mailchimp-for-wp-css'  href='https://digbr.com/wp-content/plugins/mailchimp-for-wp-pro/assets/css/css.php?checkbox=1&#038;ver=1.98.7' type='text/css' media='all' /> <script type='text/javascript' src='https://digbr.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript'>var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/digbr.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};</script> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/arrive/2.4.1/arrive.min.js?ver=2.4.1'></script> <link rel='https://api.w.org/' href='https://digbr.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://digbr.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://digbr.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Dine downtown this New Year&#8217;s Eve' href='https://digbr.com/dine-downtown-this-new-years-eve/' /><link rel='next' title='Keep up your New Years Resolutions with these healthy dishes at your favorite spots' href='https://digbr.com/keep-up-your-new-years-resolutions-with-these-healthy-dishes-at-your-favorite-spots/' /><meta name="generator" content="WordPress 5.0.8" /><meta name="generator" content="WooCommerce 3.7.1" /><link rel="canonical" href="https://digbr.com/looking-forward-baton-rouge-openings-in-2020/" /><link rel="alternate" type="application/json+oembed" href="https://digbr.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdigbr.com%2Flooking-forward-baton-rouge-openings-in-2020%2F" /><link rel="alternate" type="text/xml+oembed" href="https://digbr.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdigbr.com%2Flooking-forward-baton-rouge-openings-in-2020%2F&#038;format=xml" /><meta property="fb:app_id" content="713095298769737" />  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MW6NQMQ');</script>  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-21029509-1', 'auto');
  ga('send', 'pageview');</script><script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":85234,"post_name":"looking-forward-baton-rouge-openings-in-2020","post_title":"Looking forward: Baton Rouge openings in 2020","post_type":"post","post_author":"10000250","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":454,"name":"Business","slug":"biz","term_group":0,"term_taxonomy_id":454,"taxonomy":"category","description":"","parent":2,"count":165,"filter":"raw","cat_ID":454,"category_count":165,"category_description":"","cat_name":"Business","category_nicename":"biz","category_parent":2},{"term_id":10,"name":"Leisure","slug":"leisure","term_group":0,"term_taxonomy_id":10,"taxonomy":"category","description":"","parent":0,"count":1496,"filter":"raw","cat_ID":10,"category_count":1496,"category_description":"","cat_name":"Leisure","category_nicename":"leisure","category_parent":0}]; _mmunch['postTags'] = [{"term_id":457,"name":"NOW","slug":"now","term_group":0,"term_taxonomy_id":457,"taxonomy":"post_tag","description":"For homepage block","parent":0,"count":1258,"filter":"raw"}]; _mmunch['postAuthor'] = {"name":"","ID":""};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="mc_mm" data-mailmunch-site-id="86056" async></script><script type='text/javascript'>var taqyeem = {"ajaxurl":"https://digbr.com/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};</script> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript><meta name="generator" content="EventON 2.6.15" /><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/> <!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://digbr.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><meta name="wpsso:mark:begin" content="wpsso meta tags begin"/><meta name="generator" content="WPSSO Core 6.10.0/S"/><link rel="shortlink" href="https://digbr.com/?p=85234"/><meta property="og:type" content="article"/><meta property="og:url" content="https://digbr.com/looking-forward-baton-rouge-openings-in-2020/"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="Dig Baton Rouge"/><meta property="og:title" content="Looking forward: Baton Rouge openings in 2020"/><meta property="og:description" content="2020 is looking like the year of the taco, and we are so okay with that. Here are loads of new tacos you can feast on this year, and a few more exciting openings we can&rsquo;t wait for. ThaiHey Thaifood - ThaiHey is opening a stall in White Star in January. Thailand Native Orawin Yimchalam will... #NOW"/><meta property="og:updated_time" content="2020-01-02T17:32:14+00:00"/><meta property="og:image" content="https://digbr.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-02-at-11.30.15-AM-600x315-cropped.png"/><meta property="og:image:width" content="600"/><meta property="og:image:height" content="315"/><meta property="article:published_time" content="2020-01-02T17:31:04+00:00"/><meta property="article:modified_time" content="2020-01-02T17:32:14+00:00"/><meta property="article:tag" content="NOW"/><meta name="weibo:article:create_at" content="2020-01-02 17:31:04"/><meta name="weibo:article:update_at" content="2020-01-02 17:32:14"/><meta name="twitter:domain" content="digbr.com"/><meta name="twitter:title" content="Looking forward: Baton Rouge openings in 2020"/><meta name="twitter:description" content="2020 is looking like the year of the taco, and we are so okay with that. Here are loads of new tacos you can feast on this year, and a few more exciting openings we can&rsquo;t wait for. ThaiHey... #NOW"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://digbr.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-02-at-11.30.15-AM-800x594.png"/><link itemprop="url" href="https://digbr.com/looking-forward-baton-rouge-openings-in-2020/"/><meta itemprop="name" content="Looking forward: Baton Rouge openings in 2020"/><meta itemprop="description" content="2020 is looking like the year of the taco, and we are so okay with that. Here are loads of new tacos you can feast on this year, and a few more exciting openings we can&rsquo;t wait for. ThaiHey Thaifood - ThaiHey is opening a stall in White Star in..."/><meta itemprop="datePublished" content="2020-01-02T17:31:04+00:00"/><meta itemprop="dateModified" content="2020-01-02T17:32:14+00:00"/><link itemprop="thumbnailurl" href="https://digbr.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-02-at-11.30.15-AM.png"/><link itemprop="image" href="https://digbr.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-02-at-11.30.15-AM.png"/><meta name="author" content="Erin Bowling"/><meta name="description" content="2020 is looking like the year of the taco, and we are so okay with that. Here are loads of new tacos you can feast on this year, and a few more exciting openings we can&rsquo;t wait for. ThaiHey Thaifood - ThaiHey is..."/><meta name="thumbnail" content="https://digbr.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-02-at-11.30.15-AM.png"/><meta name="robots" content="index, follow"/><meta name="wpsso:mark:end" content="wpsso meta tags end"/><meta name="generator" content="Powered by Slider Revolution 5.4.8 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." /> <script type="text/javascript">function setREVStartSize(e){									
						try{ e.c=jQuery(e.c);var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;
							if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
						}catch(d){console.log("Failure at Presize of Slider:"+d)}						
					};</script> <noscript><style type="text/css">.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head><body class="post-template-default single single-post postid-85234 single-format-standard theme-gridlove woocommerce-no-js unknown iphone gridlove-v_1_7_2 wpb-js-composer js-comp-ver-5.5.4 vc_responsive"><header id="header" class="gridlove-site-header hidden-md-down  gridlove-header-shadow"><div class="gridlove-header-wrapper"><div class="gridlove-header-1 gridlove-header-middle container"><div class="gridlove-slot-l"><div class="gridlove-site-branding  "> <span class="site-title h1"><a href="https://digbr.com/" rel="home"><img class="gridlove-logo" src="https://digbr.com/wp-content/uploads/2018/02/DIG-Logo-white-sm.png" alt="Dig Baton Rouge"></a></span></div></div><div class="gridlove-slot-r"><nav class="gridlove-main-navigation"><ul id="menu-main-menu" class="gridlove-main-nav gridlove-menu"><li id="menu-item-66393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66393"><a href="https://digbr.com/food-drink/">Food</a></li><li id="menu-item-75953" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75953"><a href="https://digbr.com/nightlife/">Nightlife</a></li><li id="menu-item-7316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7316"><a href="https://digbr.com/category/sports/">Sports</a></li><li id="menu-item-6969" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6969"><a href="https://digbr.com/category/leisure/arts-culture/">Arts</a></li><li id="menu-item-76070" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76070"><a href="https://digbr.com/style/">Style</a></li><li id="menu-item-31878" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31878"><a href="https://digbr.com/category/leisure/fitness/">Fit</a></li><li id="menu-item-66359" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-66359"><a href="https://digbr.com/category/news/biz/">Biz</a></li><li id="menu-item-47579" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47579"><a href="#">Lagniappe</a><ul class="sub-menu"><li id="menu-item-66358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66358"><a href="https://digbr.com/the-lineup/">Things to do</a></li><li id="menu-item-72249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-72249"><a href="https://digbr.com/category/leisure/perk/">Perks</a></li><li id="menu-item-47583" class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-47583"><a href="https://digbr.com/product-category/ticketed-event/">DIG Events</a></li><li id="menu-item-7155" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7155"><a href="https://digbr.com/category/galleries/">Galleries</a></li></ul></li></ul></nav><ul class="gridlove-actions gridlove-menu"><li class="gridlove-actions-button gridlove-action-search"> <span> <i class="fa fa-search"></i> </span><ul class="sub-menu"><li><form class="gridlove-search-form" action="https://digbr.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form></li></ul></li><li class="gridlove-actions-button"> <span class="gridlove-sidebar-action"> <i class="fa fa-bars"></i> </span></li><li><ul id="menu-gridlove-social" class="gridlove-soc-menu"><li id="menu-item-66298" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66298"><a href="https://www.facebook.com/mekshq"><span class="gridlove-social-name">Facebook</span></a></li><li id="menu-item-66299" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66299"><a href="https://twitter.com/mekshq"><span class="gridlove-social-name">Twitter</span></a></li><li id="menu-item-66303" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66303"><a href="https://www.instagram.com/digbatonrouge/"><span class="gridlove-social-name">Instagram</span></a></li></ul></li></ul></div></div></div><div id="gridlove-header-sticky" class="gridlove-header-sticky"><div class="container"><div class="gridlove-slot-l"><div class="gridlove-site-branding mini"> <span class="site-title h1"><a href="https://digbr.com/" rel="home"><img class="gridlove-logo-mini" src="https://digbr.com/wp-content/uploads/2018/02/DIG-Logo-white-mini2.png" alt="Dig Baton Rouge"></a></span></div></div><div class="gridlove-slot-r"><nav class="gridlove-main-navigation"><ul id="menu-main-menu-1" class="gridlove-main-nav gridlove-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66393"><a href="https://digbr.com/food-drink/">Food</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75953"><a href="https://digbr.com/nightlife/">Nightlife</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7316"><a href="https://digbr.com/category/sports/">Sports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6969"><a href="https://digbr.com/category/leisure/arts-culture/">Arts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76070"><a href="https://digbr.com/style/">Style</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31878"><a href="https://digbr.com/category/leisure/fitness/">Fit</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-66359"><a href="https://digbr.com/category/news/biz/">Biz</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47579"><a href="#">Lagniappe</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66358"><a href="https://digbr.com/the-lineup/">Things to do</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-72249"><a href="https://digbr.com/category/leisure/perk/">Perks</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-47583"><a href="https://digbr.com/product-category/ticketed-event/">DIG Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7155"><a href="https://digbr.com/category/galleries/">Galleries</a></li></ul></li></ul></nav><ul class="gridlove-actions gridlove-menu"><li class="gridlove-actions-button gridlove-action-search"> <span> <i class="fa fa-search"></i> </span><ul class="sub-menu"><li><form class="gridlove-search-form" action="https://digbr.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form></li></ul></li><li class="gridlove-actions-button"> <span class="gridlove-sidebar-action"> <i class="fa fa-bars"></i> </span></li><li><ul id="menu-gridlove-social-1" class="gridlove-soc-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66298"><a href="https://www.facebook.com/mekshq"><span class="gridlove-social-name">Facebook</span></a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66299"><a href="https://twitter.com/mekshq"><span class="gridlove-social-name">Twitter</span></a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66303"><a href="https://www.instagram.com/digbatonrouge/"><span class="gridlove-social-name">Instagram</span></a></li></ul></li></ul></div></div></div></header><div id="gridlove-header-responsive" class="gridlove-header-responsive hidden-lg-up"><div class="container"><div class="gridlove-site-branding mini"> <span class="site-title h1"><a href="https://digbr.com/" rel="home"><img class="gridlove-logo-mini" src="https://digbr.com/wp-content/uploads/2018/02/DIG-Logo-white-mini2.png" alt="Dig Baton Rouge"></a></span></div><ul class="gridlove-actions gridlove-menu"><li class="gridlove-actions-button gridlove-action-search"> <span> <i class="fa fa-search"></i> </span><ul class="sub-menu"><li><form class="gridlove-search-form" action="https://digbr.com/" method="get"><input name="s" type="text" value="" placeholder="Type here to search..." /><button type="submit" class="gridlove-button-search">Search</button></form></li></ul></li><li class="gridlove-actions-button"> <span class="gridlove-sidebar-action"> <i class="fa fa-bars"></i> </span></li><li class="gridlove-actions-button gridlove-social-icons"> <span> <i class="fa fa-share-alt"></i> </span><ul class="sub-menu"><li><ul id="menu-gridlove-social-2" class="gridlove-soc-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66298"><a href="https://www.facebook.com/mekshq"><span class="gridlove-social-name">Facebook</span></a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66299"><a href="https://twitter.com/mekshq"><span class="gridlove-social-name">Twitter</span></a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66303"><a href="https://www.instagram.com/digbatonrouge/"><span class="gridlove-social-name">Instagram</span></a></li></ul></li></ul></li></ul></div></div><div id="content" class="gridlove-site-content container gridlove-sidebar-right"><div class="row"><div class="gridlove-share-wrapper"><div class="gridlove-share gridlove-box gridlove-sticky-share"> <a href="javascript:void(0);" class="gridlove-facebook gridlove-share-item" data-url="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fdigbr.com%2Flooking-forward-baton-rouge-openings-in-2020%2F&amp;t=Looking%20forward%3A%20Baton%20Rouge%20openings%20in%202020"><i class="fa fa-facebook"></i></a> <a href="javascript:void(0);" class="gridlove-twitter gridlove-share-item" data-url="http://twitter.com/intent/tweet?url=https%3A%2F%2Fdigbr.com%2Flooking-forward-baton-rouge-openings-in-2020%2F&amp;text=Looking%20forward%3A%20Baton%20Rouge%20openings%20in%202020"><i class="fa fa-twitter"></i></a> <a href="mailto:?subject=Looking%20forward%3A%20Baton%20Rouge%20openings%20in%202020&amp;body=https%3A%2F%2Fdigbr.com%2Flooking-forward-baton-rouge-openings-in-2020%2F" class="gridlove-mailto"><i class="fa fa-envelope-o"></i></a></div></div><div class="gridlove-content gridlove-single-layout-1"><article id="post-85234" class="gridlove-box box-vm post-85234 post type-post status-publish format-standard has-post-thumbnail hentry category-biz category-leisure tag-now"><div class="box-inner-p-bigger box-single"><div class="entry-header"><div class="entry-category"> <a href="https://digbr.com/category/news/biz/" class="gridlove-cat gridlove-cat-454">Business</a><a href="https://digbr.com/category/leisure/" class="gridlove-cat gridlove-cat-10">Leisure</a></div><h1 class="entry-title">Looking forward: Baton Rouge openings in 2020</h1><div class="entry-meta"><div class="meta-item meta-author"><span class="vcard author"><span class="fn"><a href="https://digbr.com/author/eatbatonrouge/"><img src="https://digbr.com/wp-content/uploads/2018/06/eatbatonrouge-100x100.jpg" width="24" height="24" alt="Erin Bowling" class="avatar avatar-24 wp-user-avatar wp-user-avatar-24 alignnone photo" /> Erin Bowling</a></span></span></div><div class="meta-item meta-date"><span class="updated">1 day ago</span></div></div></div><div class="entry-content"><div class="wpsso-schema-image-for-pinterest" style="display:none;"> <img src="https://digbr.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-02-at-11.30.15-AM-800x594.png" width="0" height="0" style="width:0;height:0;" data-pin-description="2020 is looking like the year of the taco, and we are so okay with that. Here are loads of new tacos you can feast on this year, and a few more exciting openings we can&rsquo;t wait for. ThaiHey Thaifood - ThaiHey is opening a stall in White Star in..." alt="" /></div><div class='mailmunch-forms-before-post' style='display: none !important;'></div><p>2020 is looking like the year of the taco, and we are <em>so</em> okay with that. Here are loads of new tacos you can feast on this year, and a few more exciting openings we can’t wait for. </p><p><strong>ThaiHey Thaifood </strong>&#8211; ThaiHey is opening a stall in White Star in January. Thailand Native Orawin Yimchalam will be cooking behind the counter and we can’t wait to try some authentic Thai goodness. </p><figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper"><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B1e_TVNlHin/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B1e_TVNlHin/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B1e_TVNlHin/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">&#34;Kanom jeen puu&#34; Crab curry with Vermicelli noodle cooking class here in Lafayette. Learn how to make authentic Thaifood with Orawin Yimchalam. Tickets are available at 👇 www.thaiheythaifood.com  10% off promo code TAKE10 for limited early bird. #cookingclass #lafayette #lafayettelouisiana #thaifoodlover #thaifood #cook #cooking #cookingclasses #cookingtime #thaicookingclass #thaicookinglesson #lovetocook #authenticthaifood #thaiauthentic</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/thaiheythaifood/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Thaihey Thaifood</a> (@thaiheythaifood) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2019-08-22T23:10:30+00:00">Aug 22, 2019 at 4:10pm PDT</time></p></div></blockquote><script async src="//www.instagram.com/embed.js"></script> </div></figure><p><strong>Cypress Coast Brewing</strong>’s open air taproom and brewhouse is shaping up nicely at 5643 Government St.</p><figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper"><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B6Rx3gsF-Vw/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B6Rx3gsF-Vw/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B6Rx3gsF-Vw/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">After some delays and some hard work, it’s time to share a teaser of our space. We are excited with how it’s coming along! In a few weeks, we should be announcing our grand opening date, so stay tuned for that announcement. Cheers! #midcitybr #cypresscoastbrewingco #craftbr #brla #louisianacraftbeer #tagallthehashtags #geauxbatonrouge #craftbrew</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/cypresscoastbrewing/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Cypress Coast Brewing Co</a> (@cypresscoastbrewing) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2019-12-20T02:39:56+00:00">Dec 19, 2019 at 6:39pm PST</time></p></div></blockquote><script async src="//www.instagram.com/embed.js"></script> </div></figure><p>Next door, <strong>Gov’t Taco</strong> will open a brick and mortar location and we are very much hoping that some of their fantastic monthly specials make the permanent menu.  </p><p><strong>Torchy’s Tacos &#8211;  </strong>We don’t often rave about a chain, but Torchy’s is delicious (so bring on that Texas taco goodness). Torchy&#8217;s will. be opening in the Nicholson Gateway at LSU. </p><p><strong>Modesto Tacos &#8211; </strong>Modesto Tacos, Tequila and Whiskey is coming from the team at Rocca, Lit and Izzo’s—joints that Baton Rouge has come to cherish—so our hopes are sky high. <a href="https://digbr.com/heres-what-you-can-expect-from-the-menu-at-modesto-tacos-tequila-whiskey-opening-early-2020/">Our tasting preview</a> showed some serious promise for this new Burbank Dr. spot.</p><figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper"><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B5n7oxWlfjG/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B5n7oxWlfjG/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B5n7oxWlfjG/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Really enjoy our @eatmodesto preview last night. Very excited to see the full experience when they’re open and to eat my weight in their insanely good chips and salsa.</a></p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/eatbatonrouge/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Eat Baton Rouge</a> (@eatbatonrouge) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2019-12-03T20:37:12+00:00">Dec 3, 2019 at 12:37pm PST</time></p></div></blockquote><script async src="//www.instagram.com/embed.js"></script> </div></figure><p><strong>Boru</strong>m- The openings at the Electric Depot development spot have been slower than we expected, but we still have our eye out on Boru Poke and Ramen.  </p><p><strong>Hot Tails&nbsp;</strong>&#8211; No two people are more qualified to serve up Cajun comfort classics than Samantha and Cody Carroll. Their second Hot Tails location will open in Prairieville this fall. Anyone who has made the pilgrimage to their New Roads spot, knows we are in for such a treat, quite a bit closer to home.&nbsp;</p><figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper"><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B2SJ9rgleeM/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B2SJ9rgleeM/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B2SJ9rgleeM/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">Some throwback photos of meals I’ve had at Hot Tails to get you pumped about them opening a location in BR! It was always worth the drive to New Roads, but now it’s closer!</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/eatbatonrouge/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Eat Baton Rouge</a> (@eatbatonrouge) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2019-09-11T20:04:55+00:00">Sep 11, 2019 at 1:04pm PDT</time></p></div></blockquote><script async src="//www.instagram.com/embed.js"></script> </div></figure><p><strong>Good Bird</strong> will open January 10 at 144 W Chimes St. We&#8217;ve been drooling over their rotisserie style chicken sandwiches for months. It looks like a great place for healthful meal.</p><figure class="wp-block-embed-instagram wp-block-embed is-type-rich is-provider-instagram"><div class="wp-block-embed__wrapper"><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B5LYsybF_ga/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B5LYsybF_ga/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B5LYsybF_ga/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">You can never go wrong with The Larry Bird! What’s your go-to sandwich? 😎</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/_goodbird/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Good Bird</a> (@_goodbird) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2019-11-22T18:33:11+00:00">Nov 22, 2019 at 10:33am PST</time></p></div></blockquote><script async src="//www.instagram.com/embed.js"></script> </div></figure><p><strong>Pelican to Mars</strong> &#8211; Pelican to Mars is a pet-friendly, space age themed, neighborhood bar opening soon on Government Street. The. bar will feature travel-oriented drinks and cocktails inspired by the flavors of the world, as well as over 63 taps and local beers and spirits. <a href="https://digbr.com/pelican-to-mars-aims-to-open-on-government-st-soon/">Owners say</a> the bar also hopes to experiment with drinks, and they plan on canning cocktails that are best made in large batches.</p><div class='mailmunch-forms-after-post' style='display: none !important;'></div></div></div></article><div style="padding: 40px 60px 50px; background-color: #fff; box-shadow: 0 3px 5px 0 rgba(0,1,1,.1); margin-bottom: 30px;"><h3>Comments</h3><div class="fb-comments" data-href="https://digbr.com/looking-forward-baton-rouge-openings-in-2020/" data-numposts="5" data-width="100%"></div></div><div class="gridlove-related"><div class="gridlove-module"><div class="module-header"><div class="module-title"><h4 class="h2">You may also like</h2></div></div><div class="row"><div class="col-lg-12 col-md-12 col-sm-12"><article class="gridlove-post gridlove-post-b gridlove-box  post-85241 post type-post status-publish format-standard has-post-thumbnail hentry category-leisure category-style tag-now"><div class="entry-image"> <a href="https://digbr.com/instagrammable-businesses/" title="Baton Rouge businesses that are both Instagrammable and delicious"><img width="385" height="300" src="https://digbr.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-02-at-12.10.25-PM-385x300.png" class="attachment-gridlove-b8 size-gridlove-b8 wp-post-image" alt="" data-wp-pid="85244" nopin="nopin" /></a></div><div class="box-inner-ptbr box-col-b entry-sm-overlay"><div class="box-inner-ellipsis"><div class="entry-category"> <a href="https://digbr.com/category/leisure/" class="gridlove-cat gridlove-cat-10">Leisure</a><a href="https://digbr.com/category/leisure/style/" class="gridlove-cat gridlove-cat-69">Style</a></div><h2 class="entry-title h3"><a href="https://digbr.com/instagrammable-businesses/">Baton Rouge businesses that are both Instagrammable and delicious</a></h2><div class="entry-content"><p>Instagram feed beginning to look a little boring after the holidays? Head to one of these locations for a meal and have a quick selfie session with their stunning decor and murals. Main Squeeze Grab a selfie with one of...</p></div></div><div class="entry-meta"><div class="meta-item meta-date"><span class="updated">1 day ago</span></div></div></div></article></div></div></div></div></div><div class="gridlove-sidebar"><div id="gridlove_posts_widget-1" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Recent posts</h4><div class="gridlove-posts-widget "><article class="post-85256 post type-post status-publish format-standard has-post-thumbnail hentry category-holidays category-lifestyle tag-now"><div class="entry-image"> <a href="https://digbr.com/four-tips-to-help-you-keep-your-new-years-resolutions/" title="Four tips to help you keep your New Year&#8217;s resolutions"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2020/01/isaac-smith-Ij7h-m4nJ18-unsplash-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="85257" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/four-tips-to-help-you-keep-your-new-years-resolutions/">Four tips to help you keep your New Year&#8217;s resolutions</a></h6></div></article><article class="post-85248 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-outdoors tag-now"><div class="entry-image"> <a href="https://digbr.com/brecs-baton-rouge-zoo-welcomes-new-baby-giraffe/" title="BREC&#8217;s Baton Rouge Zoo welcomes new baby giraffe"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-02-at-12.38.03-PM-80x60.png" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="85251" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/brecs-baton-rouge-zoo-welcomes-new-baby-giraffe/">BREC&#8217;s Baton Rouge Zoo welcomes new baby giraffe</a></h6></div></article><article class="post-85241 post type-post status-publish format-standard has-post-thumbnail hentry category-leisure category-style tag-now"><div class="entry-image"> <a href="https://digbr.com/instagrammable-businesses/" title="Baton Rouge businesses that are both Instagrammable and delicious"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-02-at-12.10.25-PM-80x60.png" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="85244" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/instagrammable-businesses/">Baton Rouge businesses that are both Instagrammable and delicious</a></h6></div></article><article class="post-85238 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-lifestyle tag-now"><div class="entry-image"> <a href="https://digbr.com/keep-up-your-new-years-resolutions-with-these-healthy-dishes-at-your-favorite-spots/" title="Keep up your New Years Resolutions with these healthy dishes at your favorite spots"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2020/01/Screen-Shot-2020-01-02-at-11.44.13-AM-80x60.png" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="85239" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/keep-up-your-new-years-resolutions-with-these-healthy-dishes-at-your-favorite-spots/">Keep up your New Years Resolutions with these healthy dishes at your favorite spots</a></h6></div></article></div></div><div id="shortcode-widget-2" class="widget gridlove-box shortcode_widget"><div class="textwidget"><article class="custom-614 gridlove-post gridlove-post-d gridlove-box post type-post status-publish format-standard has-post-thumbnail hentry"> <script type="text/javascript">ga('send', 'event', 'ads', 'impressions', 'Burgersmith - ');</script><div class="entry-image"><a onclick="ga('send', 'event', 'ads', 'clicks', 'Burgersmith - ');" href="https://www.facebook.com/EatBurgersmith/" target="_blank"> <img width="447" height="375" src="https://digbr.com/wp-content/uploads/2019/03/Burgersmith-1-e1552075690829.png" class="attachment-gridlove-d4 size-gridlove-d4 wp-post-image wp-post-image" alt="" srcset="https://digbr.com/wp-content/uploads/2019/03/Burgersmith-1-e1552075690829.png 447w, https://digbr.com/wp-content/uploads/2019/03/Burgersmith-1-e1552075690829-300x252.png 300w, https://digbr.com/wp-content/uploads/2019/03/Burgersmith-1-e1552075690829-370x310.png 370w, https://digbr.com/wp-content/uploads/2019/03/Burgersmith-1-e1552075690829-270x227.png 270w" sizes="(max-width: 447px) 100vw, 447px" data-wp-pid="78518" nopin="nopin" /> </a></div></article></div></div><div id="evcalwidget-2" class="widget gridlove-box EvcalWidget"><div id='evcal_widget' class='evo_widget'><div id='evcal_calendar_533' class='list_cal ajde_evcal_calendar  ul' ><div class='evo-data' data-cyear="2020" data-cmonth="1" data-runajax="1" data-evc_open="0" data-cal_ver="2.6.15" data-mapscroll="true" data-mapformat="roadmap" data-mapzoom="18" data-mapiconurl="" data-ev_cnt="5" data-show_limit="no" data-tiles="no" data-sort_by="sort_date" data-filters_on="false" data-range_start="0" data-range_end="0" data-send_unix="0" data-ux_val="0" data-accord="0" data-rtl="no"  ></div><div id='evcal_head' class='calendar_header ' ><div class='evo_cal_above'><span class='evo-gototoday-btn' style='display:none' data-mo='1' data-yr='2020' data-dy=''>Current Month</span></div><div class='evo_cal_above_content'></div><div class='cal_arguments' style='display:none' data-hide_past="yes" data-show_et_ft_img="no" data-event_order="ASC" data-ft_event_priority="no" data-lang="L1" data-month_incre="0" data-only_ft="no" data-hide_ft="no" data-evc_open="no" data-show_limit="no" data-etc_override="no" data-show_limit_redir="0" data-tiles="no" data-tile_height="0" data-tile_bg="0" data-tile_count="2" data-tile_style="0" data-s="" data-members_only="no" data-ux_val="0" data-show_limit_ajax="no" data-show_limit_paged="1" data-hide_mult_occur="yes" data-show_repeats="no" data-hide_end_time="no" ></div><div class='clear'></div></div><div class='evcal_month_line'><p>january</p></div><div id='evcal_list' class='eventon_events_list '><div id="event_84965" class="eventon_list_event evo_eventtop  event" data-event_id="84965" data-ri="1" data-time="1578009601-1578095999" data-colr="#5ca4b4" itemscope itemtype='http://schema.org/Event'><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/ice-skating-on-the-river-3/var/ri-1.l-L1'></a><span itemprop='name'  >Ice Skating on the River</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2019/12/74330359_3456000941107463_6519511496332935168_o.jpg' /><meta itemprop='description' content='The Raising Cane’s River Center will once again magically transform into a “Winter Wonderland” just in time for you to create your holiday memories. Ice Skating on the River is' /><meta itemprop='startDate' content='2020-1-3' /><meta itemprop='endDate' content='2020-1-3' /><meta itemprop='eventStatus' content='on-schedule' /> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Raising Cane&#039;s River Center</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">275 S River Rd</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Ice Skating on the River",
							  	"startDate": "2020-1-3T00-00-00-00",
							  	"endDate": "2020-1-3T23-23-59-00",
							  	"image":"https://digbr.com/wp-content/uploads/2019/12/74330359_3456000941107463_6519511496332935168_o.jpg",
							  	"description":"The Raising Cane’s River Center will once again magically transform into a “Winter Wonderland” just in time for you to create your holiday memories. Ice Skating on the River is",
							  	"location":{
										"@type":"Place",
										"name":"Raising Cane&#039;s River Center",
										"address":"275 S River Rd"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #5ca4b4;" id="evc_157800960184965" class="event_repeat desc_trig sin_val evcal_list_a allday" data-ux_val="1"  ><span class='evcal_cblock ' data-bgcolor='#5ca4b4' data-smon='january' data-syr='2020'><span class='evo_start '><em class='date'>03</em><em class='month'>jan</em><em class='time'>All Day</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata '  data-location_address="275 S River Rd" data-location_type="address" data-location_name="Raising Cane&#039;s River Center" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Ice Skating on the River</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></a></p><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='540' data-imgwidth='960'  style='background-image: url("https://digbr.com/wp-content/uploads/2019/12/74330359_3456000941107463_6519511496332935168_o.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>The Raising Cane’s River Center will once again magically transform into a “Winter Wonderland” just in time for you to create your holiday memories. Ice Skating on the River is</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>The Raising Cane’s River Center will once again magically transform into a “Winter Wonderland” just in time for you to create your holiday memories. Ice Skating on the River is an annual holiday tradition that will kick off on Friday, December 20, 2019. The Coca-Cola Santa Truck and ‘ole Saint Nicholas will be at the Raising Cane’s River Center spreading the joy of the season exclusively for the opening session. Check out the session times and grab your tickets <a href="http://raisingcanesrivercenter.com/events/#!/ice-skating-on-the-river/">here</a>!</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>All Day (Friday) <em class="evo_eventcard_tiemzone">CST</em></p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='703'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Raising Cane&#039;s River Center</p><p class='evo_location_address'>275 S River Rd</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=84965&amp;sunix=20200103T060000Z&amp;eunix=20200104T055900Z&amp;loca=275 S River Rd&amp;locn=Raising Cane&#039;s River Center' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Ice+Skating+on+the+River&amp;dates=20200103T060000Z/20200104T055900Z&amp;details=The+Raising+Cane%E2%80%99s+River+Center+will+once+again+magically+transform+into+a+%E2%80%9CWinter+Wonderland%E2%80%9D+just+in+time+for+you+to+create+your+holiday+memories.+Ice+Skating+on+the+River+is&amp;location=Raising+Cane%26%23039%3Bs+River+Center - 275+S+River+Rd' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_83969" class="eventon_list_event evo_eventtop  event" data-event_id="83969" data-ri="2" data-time="1578070800-1578085200" data-colr="#5ca4b4" itemscope itemtype='http://schema.org/Event'><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/family-friday-at-tin-roof-brewing-company-4/var/ri-2.l-L1'></a><span itemprop='name'  >Family Friday at Tin Roof Brewing Company</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2019/10/69568631_2476402279072799_224625943472242688_n.jpg' /><meta itemprop='description' content='Join Tin Roof Brewing Company on the FIRST Friday of each month for Family Friday! They'll have tasty brews for the adults and entertainment for the kids, including inflatable bounce' /><meta itemprop='startDate' content='2020-1-3T17:00' /><meta itemprop='endDate' content='2020-1-3T21:00' /><meta itemprop='eventStatus' content='on-schedule' /> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Tin Roof Brewery</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">1624 Wyoming St, Baton Rouge, Louisiana 70802</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Family Friday at Tin Roof Brewing Company",
							  	"startDate": "2020-1-3T17-17-00-00",
							  	"endDate": "2020-1-3T21-21-00-00",
							  	"image":"https://digbr.com/wp-content/uploads/2019/10/69568631_2476402279072799_224625943472242688_n.jpg",
							  	"description":"Join Tin Roof Brewing Company on the FIRST Friday of each month for Family Friday! They'll have tasty brews for the adults and entertainment for the kids, including inflatable bounce",
							  	"location":{
										"@type":"Place",
										"name":"Tin Roof Brewery",
										"address":"1624 Wyoming St, Baton Rouge, Louisiana 70802"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #5ca4b4;" id="evc_157807080083969" class="event_repeat desc_trig sin_val evcal_list_a" data-ux_val="1"  ><span class='evcal_cblock ' data-bgcolor='#5ca4b4' data-smon='january' data-syr='2020'><span class='evo_start '><em class='date'>03</em><em class='month'>jan</em><em class='time'>5:00 pm</em></span><span class='evo_end only_time'><em class='time'>9:00 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.4326913,-91.1891544"  data-location_address="1624 Wyoming St, Baton Rouge, Louisiana 70802" data-location_type="lonlat" data-location_name="Tin Roof Brewery" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Family Friday at Tin Roof Brewing Company</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></a></p><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='960' data-imgwidth='611'  style='background-image: url("https://digbr.com/wp-content/uploads/2019/10/69568631_2476402279072799_224625943472242688_n.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>Join Tin Roof Brewing Company on the FIRST Friday of each month for Family Friday! They'll have tasty brews for the adults and entertainment for the kids, including inflatable bounce</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>Join Tin Roof Brewing Company on the FIRST Friday of each month for Family Friday! They&#8217;ll have tasty brews for the adults and entertainment for the kids, including inflatable bounce houses, face painting, sweet treats and more. Check out the event page <a href="https://www.facebook.com/events/432053480741893/?event_time_id=432053487408559">here</a>!</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Friday) 5:00 pm - 9:00 pm <em class="evo_eventcard_tiemzone">CST</em></p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='347'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Tin Roof Brewery</p><p class='evo_location_address'>1624 Wyoming St, Baton Rouge, Louisiana 70802</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=83969&amp;sunix=20200103T230000Z&amp;eunix=20200104T030000Z&amp;loca=1624 Wyoming St, Baton Rouge, Louisiana 70802&amp;locn=Tin Roof Brewery' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Family+Friday+at+Tin+Roof+Brewing+Company&amp;dates=20200103T230000Z/20200104T030000Z&amp;details=Join+Tin+Roof+Brewing+Company+on+the+FIRST+Friday+of+each+month+for+Family+Friday%21+They%27ll+have+tasty+brews+for+the+adults+and+entertainment+for+the+kids%2C+including+inflatable+bounce&amp;location=Tin+Roof+Brewery - 1624+Wyoming+St%2C+Baton+Rouge%2C+Louisiana+70802' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_85192" class="eventon_list_event evo_eventtop  event" data-event_id="85192" data-time="1578078000-1578085200" data-colr="#5ca4b4" itemscope itemtype='http://schema.org/Event'><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/byob-painting-class-darling/'></a><span itemprop='name'  >BYOB Painting Class: Darling</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2019/12/80873917_2938811739470864_4909909804224348160_o.jpg' /><meta itemprop='description' content='Enjoy a class with Painting and Pinot fit for all skill levels! Bring your favorite adult beverage and channel your inner artist! At this class, they will be painting their "Darling"' /><meta itemprop='startDate' content='2020-1-3T19:00' /><meta itemprop='endDate' content='2020-1-3T21:00' /><meta itemprop='eventStatus' content='on-schedule' /> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Painting and Pinot</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">7248 Perkins Rd Ste F, Baton Rouge, Louisiana 70808</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "BYOB Painting Class: Darling",
							  	"startDate": "2020-1-3T19-19-00-00",
							  	"endDate": "2020-1-3T21-21-00-00",
							  	"image":"https://digbr.com/wp-content/uploads/2019/12/80873917_2938811739470864_4909909804224348160_o.jpg",
							  	"description":"Enjoy a class with Painting and Pinot fit for all skill levels! Bring your favorite adult beverage and channel your inner artist! At this class, they will be painting their Darling",
							  	"location":{
										"@type":"Place",
										"name":"Painting and Pinot",
										"address":"7248 Perkins Rd Ste F, Baton Rouge, Louisiana 70808"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #5ca4b4;" id="evc_157807800085192" class="desc_trig sin_val evcal_list_a" data-ux_val="1"  ><span class='evcal_cblock ' data-bgcolor='#5ca4b4' data-smon='january' data-syr='2020'><span class='evo_start '><em class='date'>03</em><em class='month'>jan</em><em class='time'>7:00 pm</em></span><span class='evo_end only_time'><em class='time'>9:00 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata ' data-latlng="30.3965708,-91.1141093"  data-location_address="7248 Perkins Rd Ste F, Baton Rouge, Louisiana 70808" data-location_type="lonlat" data-location_name="Painting and Pinot" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>BYOB Painting Class: Darling</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></a></p><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='480' data-imgwidth='960'  style='background-image: url("https://digbr.com/wp-content/uploads/2019/12/80873917_2938811739470864_4909909804224348160_o.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>Enjoy a class with Painting and Pinot fit for all skill levels! Bring your favorite adult beverage and channel your inner artist! At this class, they will be painting their "Darling"</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>Enjoy a class with Painting and Pinot fit for all skill levels! Bring your favorite adult beverage and channel your inner artist! At this class, they will be painting their &#8220;Darling&#8221; painting on a 16×20 canvas. All supplies are included with the $35 admission. Register for the event <a href="https://www.facebook.com/events/1491507167663741/">here</a>!</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Friday) 7:00 pm - 9:00 pm <em class="evo_eventcard_tiemzone">CST</em></p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='415'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Painting and Pinot</p><p class='evo_location_address'>7248 Perkins Rd Ste F, Baton Rouge, Louisiana 70808</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=85192&amp;sunix=20200104T010000Z&amp;eunix=20200104T030000Z&amp;loca=7248 Perkins Rd Ste F, Baton Rouge, Louisiana 70808&amp;locn=Painting and Pinot' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=BYOB+Painting+Class%3A+Darling&amp;dates=20200104T010000Z/20200104T030000Z&amp;details=Enjoy+a+class+with+Painting+and+Pinot+fit+for+all+skill+levels%21+Bring+your+favorite+adult+beverage+and+channel+your+inner+artist%21%C2%A0At+this+class%2C+they+will+be+painting+their+%22Darling%22&amp;location=Painting+and+Pinot - 7248+Perkins+Rd+Ste+F%2C+Baton+Rouge%2C+Louisiana+70808' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_85196" class="eventon_list_event evo_eventtop  event" data-event_id="85196" data-time="1578078000-1578088800" data-colr="#5ca4b4" itemscope itemtype='http://schema.org/Event'><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/congrats-lsu-tigers-with-painting-with-a-twist/'></a><span itemprop='name'  >Congrats LSU Tigers! with Painting with a Twist</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2019/12/81215635_10158322081032214_7631101207800446976_o.jpg' /><meta itemprop='description' content='
Celebrate LSU's win in the Peach Bowl Friday, January 3rd from 7 PM-10 PM with this gorgeous "Tiger Eyes" set Painting! Paint it on canvas or real' /><meta itemprop='startDate' content='2020-1-3T19:00' /><meta itemprop='endDate' content='2020-1-3T22:00' /><meta itemprop='eventStatus' content='on-schedule' /> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Painting with a Twist</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">711 Jefferson Hwy</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Congrats LSU Tigers! with Painting with a Twist",
							  	"startDate": "2020-1-3T19-19-00-00",
							  	"endDate": "2020-1-3T22-22-00-00",
							  	"image":"https://digbr.com/wp-content/uploads/2019/12/81215635_10158322081032214_7631101207800446976_o.jpg",
							  	"description":"
Celebrate LSU's win in the Peach Bowl Friday, January 3rd from 7 PM-10 PM with this gorgeous Tiger Eyes set Painting! Paint it on canvas or real",
							  	"location":{
										"@type":"Place",
										"name":"Painting with a Twist",
										"address":"711 Jefferson Hwy"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #5ca4b4;" id="evc_157807800085196" class="desc_trig sin_val evcal_list_a" data-ux_val="1"  ><span class='evcal_cblock ' data-bgcolor='#5ca4b4' data-smon='january' data-syr='2020'><span class='evo_start '><em class='date'>03</em><em class='month'>jan</em><em class='time'>7:00 pm</em></span><span class='evo_end only_time'><em class='time'>10:00 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata '  data-location_address="711 Jefferson Hwy" data-location_type="address" data-location_name="Painting with a Twist" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Congrats LSU Tigers! with Painting with a Twist</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></a></p><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='540' data-imgwidth='960'  style='background-image: url("https://digbr.com/wp-content/uploads/2019/12/81215635_10158322081032214_7631101207800446976_o.jpg")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p> Celebrate LSU's win in the Peach Bowl Friday, January 3rd from 7 PM-10 PM with this gorgeous "Tiger Eyes" set Painting! Paint it on canvas or real</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><div class="_63eu"><div class="_63ew" data-testid="event-permalink-details">Celebrate LSU&#8217;s win in the Peach Bowl Friday, January 3rd from 7 PM-10 PM with this gorgeous &#8220;Tiger Eyes&#8221; set Painting! Paint it on canvas or real wood pallets! Check out the event page <a href="https://www.facebook.com/events/521540455373511/">here</a>!</div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Friday) 7:00 pm - 10:00 pm <em class="evo_eventcard_tiemzone">CST</em></p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='685'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Painting with a Twist</p><p class='evo_location_address'>711 Jefferson Hwy</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=85196&amp;sunix=20200104T010000Z&amp;eunix=20200104T040000Z&amp;loca=711 Jefferson Hwy&amp;locn=Painting with a Twist' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Congrats+LSU+Tigers%21+with+Painting+with+a+Twist&amp;dates=20200104T010000Z/20200104T040000Z&amp;details=%0D%0ACelebrate+LSU%27s+win+in+the+Peach+Bowl+Friday%2C+January+3rd+from+7+PM-10+PM+with+this+gorgeous+%22Tiger+Eyes%22+set+Painting%21+Paint+it+on+canvas+or+real&amp;location=Painting+with+a+Twist - 711+Jefferson+Hwy' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div><div id="event_85190" class="eventon_list_event evo_eventtop  event" data-event_id="85190" data-time="1578078000-1578095400" data-colr="#5ca4b4" itemscope itemtype='http://schema.org/Event'><div class="evo_event_schema" style="display:none" ><a itemprop='url'  href='https://digbr.com/events/gumbo-jam-nite-1-year-anniversary/'></a><span itemprop='name'  >Gumbo Jam Nite: 1 Year Anniversary</span><meta itemprop='image' content='https://digbr.com/wp-content/uploads/2019/12/78595229_10159153423374447_605017319839629312_n.png' /><meta itemprop='description' content='GUMBO JAM NITE featuring live performances from Universal Language Music + Gumbo Band. Sounds by DJ Kicks. Hosted by Howard Hall. Check out the event page here!' /><meta itemprop='startDate' content='2020-1-3T19:00' /><meta itemprop='endDate' content='2020-1-3T23:50' /><meta itemprop='eventStatus' content='on-schedule' /> <item style="display:none" itemprop="location" itemscope itemtype="http://schema.org/Place"> <span itemprop="name">Varsity Theatre</span> <span itemprop="address" itemscope itemtype="http://schema.org/PostalAddress"> <item itemprop="streetAddress">3353 Highland Rd</item> </span></item><script type="application/ld+json">{	"@context": "http://schema.org",
							  	"@type": "Event",
							  	"name": "Gumbo Jam Nite: 1 Year Anniversary",
							  	"startDate": "2020-1-3T19-19-00-00",
							  	"endDate": "2020-1-3T23-23-50-00",
							  	"image":"https://digbr.com/wp-content/uploads/2019/12/78595229_10159153423374447_605017319839629312_n.png",
							  	"description":"GUMBO JAM NITE featuring live performances from Universal Language Music + Gumbo Band. Sounds by DJ Kicks. Hosted by Howard Hall. Check out the event page here!",
							  	"location":{
										"@type":"Place",
										"name":"Varsity Theatre",
										"address":"3353 Highland Rd"
							  		}
							 }</script></div><p class="desc_trig_outter"><a data-gmap_status="null" data-exlk="0" style="border-color: #5ca4b4;" id="evc_157807800085190" class="desc_trig sin_val evcal_list_a" data-ux_val="1"  ><span class='evcal_cblock ' data-bgcolor='#5ca4b4' data-smon='january' data-syr='2020'><span class='evo_start '><em class='date'>03</em><em class='month'>jan</em><em class='time'>7:00 pm</em></span><em class='clear'></em></span><span class='evcal_desc evo_info hide_eventtopdata '  data-location_address="3353 Highland Rd" data-location_type="address" data-location_name="Varsity Theatre" data-location_status="true" ><span class='evo_above_title'></span><span class='evcal_desc2 evcal_event_title' itemprop='name'>Gumbo Jam Nite: 1 Year Anniversary</span><span class='evo_below_title'></span><span class='evcal_desc_info' ></span><span class='evcal_desc3'></span></span><em class='clear'></em></a></p><div class='event_description evcal_eventcard ' style="display:none"><div class='evo_metarow_fimg evorow evcal_evdata_img  evo_imghover' data-imgheight='427' data-imgwidth='640'  style='background-image: url("https://digbr.com/wp-content/uploads/2019/12/78595229_10159153423374447_605017319839629312_n.png")' data-imgstyle='full' data-minheight='400' data-status=''></div><div class='evo_metarow_details evorow evcal_evdata_row bordb evcal_event_details'><div class="event_excerpt" style="display:none"><h3 class="padb5 evo_h3">Event Details</h3><p>GUMBO JAM NITE featuring live performances from Universal Language Music + Gumbo Band. Sounds by DJ Kicks. Hosted by Howard Hall. Check out the event page here!</p></div><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span><div class='evcal_evdata_cell '><div class='eventon_full_description'><h3 class='padb5 evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-align-justify'></i></span>Event Details</h3><div class='eventon_desc_in' itemprop='description'><p>GUMBO JAM NITE featuring live performances from Universal Language Music + Gumbo Band. Sounds by DJ Kicks. Hosted by Howard Hall. Check out the event page <a href="https://www.facebook.com/events/584170299000730/">here</a>!</p></div><div class='clear'></div></div></div></div><div class='evo_metarow_time_location evorow bordb '><div class='tb' ><div class='tbrow'><div class='evcal_col50 bordr'><div class='evcal_evdata_row evo_time'> <span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span><div class='evcal_evdata_cell'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-clock-o'></i></span>Time</h3><p>(Friday) 7:00 pm <em class="evo_eventcard_tiemzone">CST</em></p></div></div></div><div class='evcal_col50'><div class='evcal_evdata_row evo_location'> <span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span><div class='evcal_evdata_cell' data-loc_tax_id='365'><h3 class='evo_h3'><span class='evcal_evdata_icons'><i class='fa fa-map-marker'></i></span>Location</h3><p class='evo_location_name'>Varsity Theatre</p><p class='evo_location_address'>3353 Highland Rd</p></div></div></div><div class='clear'></div></div></div></div><div class='evo_metarow_ICS evorow bordb evcal_evdata_row'> <span class="evcal_evdata_icons"><i class="fa fa-calendar"></i></span><div class='evcal_evdata_cell'><p><a href='https://digbr.com/wp-admin/admin-ajax.php?action=eventon_ics_download&amp;event_id=85190&amp;sunix=20200104T010000Z&amp;eunix=20200104T055000Z&amp;loca=3353 Highland Rd&amp;locn=Varsity Theatre' class='evo_ics_nCal' title='Add to your calendar'>Calendar</a><a href='//www.google.com/calendar/event?action=TEMPLATE&amp;text=Gumbo+Jam+Nite%3A+1+Year+Anniversary&amp;dates=20200104T010000Z/20200104T055000Z&amp;details=GUMBO+JAM+NITE+featuring+live+performances+from%C2%A0Universal+Language+Music+%2B+Gumbo+Band.+Sounds+by+DJ+Kicks.+Hosted+by+Howard+Hall.+Check+out+the+event+page+here%21&amp;location=Varsity+Theatre - 3353+Highland+Rd' target='_blank' class='evo_ics_gCal' title='Add to google calendar'>GoogleCal</a></p></div></div></div><div class='clear end'></div></div></div><div class='clear'></div></div></div></div><div class="elfsight-widget-instagram-feed elfsight-widget" data-elfsight-instagram-feed-options="%7B%22source%22%3A%5B%22%40digbatonrouge%22%5D%2C%22filterOnly%22%3A%5B%5D%2C%22filterExcept%22%3A%5B%5D%2C%22limit%22%3A%22%22%2C%22layout%22%3A%22slider%22%2C%22postTemplate%22%3A%22tile%22%2C%22columns%22%3A2%2C%22rows%22%3A6%2C%22gutter%22%3A4%2C%22responsive%22%3A%5B%7B%22minWidth%22%3A375%2C%22columns%22%3A1%2C%22rows%22%3A1%2C%22gutter%22%3A%220%22%7D%2C%7B%22minWidth%22%3A768%2C%22columns%22%3A3%2C%22rows%22%3A2%2C%22gutter%22%3A%220%22%7D%5D%2C%22width%22%3A%22auto%22%2C%22callToActionButtons%22%3A%5B%7B%22postUrl%22%3A%22https%3A%5C%2F%5C%2Fwww.instagram.com%5C%2Fp%5C%2FBcknqVZHtD3%5C%2F%22%2C%22buttonLabel%22%3A%22Install%20Instagram%20Feed%20now%22%2C%22buttonLink%22%3A%22https%3A%5C%2F%5C%2Felfsight.com%5C%2Finstagram-feed-instashow%5C%2F%22%7D%2C%7B%22postUrl%22%3A%22https%3A%5C%2F%5C%2Fwww.instagram.com%5C%2Fp%5C%2FBbSBRarnOik%5C%2F%22%2C%22buttonLabel%22%3A%22Install%20Instagram%20Feed%20now%22%2C%22buttonLink%22%3A%22https%3A%5C%2F%5C%2Felfsight.com%5C%2Finstagram-feed-instashow%5C%2F%22%7D%2C%7B%22postUrl%22%3A%22https%3A%5C%2F%5C%2Fwww.instagram.com%5C%2Fp%5C%2FBa9NwWLHaEx%5C%2F%22%2C%22buttonLabel%22%3A%22Install%20Instagram%20Feed%20now%22%2C%22buttonLink%22%3A%22https%3A%5C%2F%5C%2Felfsight.com%5C%2Finstagram-feed-instashow%5C%2F%22%7D%5D%2C%22postElements%22%3A%5B%22user%22%2C%22date%22%2C%22instagramLink%22%2C%22likesCount%22%2C%22commentsCount%22%2C%22share%22%2C%22text%22%5D%2C%22popupElements%22%3A%5B%22user%22%2C%22location%22%2C%22followButton%22%2C%22instagramLink%22%2C%22likesCount%22%2C%22share%22%2C%22text%22%2C%22comments%22%2C%22date%22%5D%2C%22imageClickAction%22%3A%22popup%22%2C%22sliderArrows%22%3Atrue%2C%22sliderDrag%22%3Atrue%2C%22sliderSpeed%22%3A0.59999999999999998%2C%22sliderAutoplay%22%3A%22%22%2C%22colorScheme%22%3A%22default%22%2C%22colorPostOverlayBg%22%3A%22rgba%280%2C%200%2C%200%2C%200.8%29%22%2C%22colorPostOverlayText%22%3A%22rgb%28255%2C%20255%2C%20255%29%22%2C%22colorPostBg%22%3A%22rgb%28255%2C%20255%2C%20255%29%22%2C%22colorPostText%22%3A%22rgb%280%2C%200%2C%200%29%22%2C%22colorPostLinks%22%3A%22rgb%280%2C%2053%2C%20107%29%22%2C%22colorSliderArrows%22%3A%22rgb%28255%2C%20255%2C%20255%29%22%2C%22colorSliderArrowsBg%22%3A%22rgba%280%2C%200%2C%200%2C%200.9%29%22%2C%22colorGridLoadMoreButton%22%3A%22rgb%2856%2C%20151%2C%20240%29%22%2C%22colorPopupOverlay%22%3A%22rgba%2843%2C%2043%2C%2043%2C%200.9%29%22%2C%22colorPopupBg%22%3A%22rgb%28255%2C%20255%2C%20255%29%22%2C%22colorPopupText%22%3A%22rgb%280%2C%200%2C%200%29%22%2C%22colorPopupLinks%22%3A%22rgb%280%2C%2053%2C%20105%29%22%2C%22colorPopupFollowButton%22%3A%22rgb%2856%2C%20151%2C%20240%29%22%2C%22colorPopupCtaButton%22%3A%22rgb%2856%2C%20151%2C%20240%29%22%2C%22widgetTitle%22%3A%22Follow%20us%20on%20Instagram%22%2C%22lang%22%3A%22en%22%2C%22cacheTime%22%3A300%2C%22api%22%3A%22https%3A%5C%2F%5C%2Fdigbr.com%5C%2Fwp-content%5C%2Fplugins%5C%2Felfsight-instagram-feed-cc%5C%2Fapi%5C%2Findex.php%22%7D"></div><div id="mks_social_widget-4" class="widget gridlove-box mks_social_widget"><h4 class="widget-title">Follow Us</h4><ul class="mks_social_widget_ul"><li><a href="https://www.instagram.com/digbatonrouge/" title="Instagram" class="socicon-instagram soc_circle" target="_blank" style="width: 42px; height: 42px; font-size: 16px;line-height:47px;"><span>instagram</span></a></li><li><a href="https://twitter.com/DigBatonRouge" title="Twitter" class="socicon-twitter soc_circle" target="_blank" style="width: 42px; height: 42px; font-size: 16px;line-height:47px;"><span>twitter</span></a></li><li><a href="https://www.facebook.com/digbatonrouge/" title="Facebook" class="socicon-facebook soc_circle" target="_blank" style="width: 42px; height: 42px; font-size: 16px;line-height:47px;"><span>facebook</span></a></li></ul></div></div></div></div><div id="footer" class="gridlove-footer"><div class="container"><div class="row"><div class="col-lg-4 col-md-6 col-sm-12"><div id="text-2" class="widget widget_text"><div class="textwidget"><p><img width="70" src="https://digbr.com/wp-content/uploads/2018/02/DIG-Logo-white-mini2.png"/></p><p>DIGBR.com is how Baton Rouge keeps the pulse of our great city. We curate what's important and deliver it fast and throughout the day here and on our social channels.</p></div></div><div id="mks_social_widget-3" class="widget mks_social_widget"><ul class="mks_social_widget_ul"><li><a href="https://www.facebook.com/digbatonrouge/" title="Facebook" class="socicon-facebook soc_circle" target="_blank" style="width: 40px; height: 40px; font-size: 16px;line-height:45px;"><span>facebook</span></a></li><li><a href="https://twitter.com/DigBatonRouge" title="Twitter" class="socicon-twitter soc_circle" target="_blank" style="width: 40px; height: 40px; font-size: 16px;line-height:45px;"><span>twitter</span></a></li><li><a href="https://www.instagram.com/digbatonrouge/" title="Instagram" class="socicon-instagram soc_circle" target="_blank" style="width: 40px; height: 40px; font-size: 16px;line-height:45px;"><span>instagram</span></a></li></ul></div></div><div class="col-lg-4 col-md-6 col-sm-12"><div id="mc4wp_widget-3" class="widget widget_mc4wp_widget"><h4 class="widget-title">Newsletter</h4><div id="mc4wp-form-1" class="mc4wp-form mc4wp-form-47580 mc4wp-ajax "><form method="post" action="https://digbr.com/looking-forward-baton-rouge-openings-in-2020/"><p> <label for="mc4wp_email">Every day, DIG hits your inbox with the latest happening in BR - news, fun, cool events and more.</label> <input type="email" id="mc4wp_email" name="EMAIL" required placeholder="Your email address" /></p><p> <input type="submit" value="Sign up" /></p><textarea name="_mc4wp_required_but_not_really" style="display: none;"></textarea><input type="hidden" name="_mc4wp_form_ID" value="47580" /><input type="hidden" name="_mc4wp_form_instance" value="1" /><input type="hidden" name="_mc4wp_form_submit" value="1" /><input type="hidden" name="_mc4wp_form_nonce" value="36b87e74bc" /></form><span class="mc4wp-ajax-loader" style="display: none;"></span><div style="display:none;" class="mc4wp-alert mc4wp-success-message mc4wp-success">Thank you, your sign-up request was successful! Please check your e-mail inbox. <span class="mc4wp-mailchimp-error"></span></div><div style="display:none;" class="mc4wp-alert mc4wp-already_subscribed-message mc4wp-notice">Given email address is already subscribed, thank you! <span class="mc4wp-mailchimp-error"></span></div><div style="display:none;" class="mc4wp-alert mc4wp-invalid_email-message mc4wp-error">Please provide a valid email address. <span class="mc4wp-mailchimp-error"></span></div><div style="display:none;" class="mc4wp-alert mc4wp-error-message mc4wp-error">Oops. Something went wrong. Please try again later. <span class="mc4wp-mailchimp-error"></span></div></div></div></div><div class="col-lg-4 col-md-6 col-sm-12"><div id="nav_menu-1" class="widget widget_nav_menu"><h4 class="widget-title">Help &#038; Support</h4><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-47573" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47573"><a href="https://digbr.com/terms-of-service/">Terms of Service</a></li><li id="menu-item-47574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47574"><a href="https://digbr.com/advertise-with-dig/">Advertise</a></li><li id="menu-item-63187" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63187"><a href="https://digbr.com/aboutcontact/">About/Contact</a></li></ul></div></div></div></div></div><div class="gridlove-copyright"><div class="container"><p style="text-align: center">Copyright © 2018 · Primedia Holdings, LLC</p></div></div></div><div class="gridlove-sidebar-action-wrapper"> <span class="gridlove-action-close"><i class="fa fa-times" aria-hidden="true"></i></span><div class="gridlove-sidebar-action-inside"><div class="hidden-lg-up widget gridlove-box widget_nav_menu"><ul id="menu-main-menu-2" class="gridlove-mobile-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66393"><a href="https://digbr.com/food-drink/">Food</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-75953"><a href="https://digbr.com/nightlife/">Nightlife</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7316"><a href="https://digbr.com/category/sports/">Sports</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6969"><a href="https://digbr.com/category/leisure/arts-culture/">Arts</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76070"><a href="https://digbr.com/style/">Style</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31878"><a href="https://digbr.com/category/leisure/fitness/">Fit</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-66359"><a href="https://digbr.com/category/news/biz/">Biz</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-47579"><a href="#">Lagniappe</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66358"><a href="https://digbr.com/the-lineup/">Things to do</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-72249"><a href="https://digbr.com/category/leisure/perk/">Perks</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-product_cat menu-item-47583"><a href="https://digbr.com/product-category/ticketed-event/">DIG Events</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7155"><a href="https://digbr.com/category/galleries/">Galleries</a></li></ul></li></ul></div><div id="mks_social_widget-1" class="widget gridlove-box mks_social_widget"><h4 class="widget-title">Follow us</h4><p>Don't be shy, get in touch. We love meeting interesting people and making new friends.</p><ul class="mks_social_widget_ul"><li><a href="https://www.facebook.com/mekshq" title="Facebook" class="socicon-facebook soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;line-height:49px;"><span>facebook</span></a></li><li><a href="https://twitter.com/mekshq" title="Twitter" class="socicon-twitter soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;line-height:49px;"><span>twitter</span></a></li><li><a href="https://www.instagram.com/digbatonrouge/" title="Instagram" class="socicon-instagram soc_circle" target="_blank" style="width: 44px; height: 44px; font-size: 16px;line-height:49px;"><span>instagram</span></a></li></ul></div><div id="gridlove_posts_widget-2" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Most popular<span class="gridlove-slider-controls" data-autoplay="0"></span></h4></div><div id="gridlove_posts_widget-3" class="widget gridlove-box gridlove_posts_widget"><h4 class="widget-title">Most discussed<span class="gridlove-slider-controls" data-autoplay="0"></span></h4><div class="gridlove-posts-widget gridlove-widget-slider"><div class="gridlove-posts-widget-item-wrapper"><article class="post-12295 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-sports"><div class="entry-image"> <a href="https://digbr.com/londoner-hosts-celebration-of-historic-usa-world-cup-victory/" title="Londoner Hosts Celebration of Historic USA World Cup Victory"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/ANCHOR_Outlaws-Londoner-12-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12296" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/londoner-hosts-celebration-of-historic-usa-world-cup-victory/">Londoner Hosts Celebration of Historic USA World Cup Victory</a></h6></div></article><article class="post-12485 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/business-as-usual-bobby-jindal-crony-capitalism/" title="Business As Usual"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/Fred-Dive-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12486" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/business-as-usual-bobby-jindal-crony-capitalism/">Business As Usual</a></h6></div></article><article class="post-12652 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/paul-stars-part-two/" title="All Mainieri Team: Infield"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/07/JUMP-Austin-Nola-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12653" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/paul-stars-part-two/">All Mainieri Team: Infield</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-12047 post type-post status-publish format-standard has-post-thumbnail hentry category-food-drink category-leisure category-sports"><div class="entry-image"> <a href="https://digbr.com/digs-baton-rouge-world-cup-watch-guide/" title="DIG&#8217;s Baton Rouge World Cup Watch Guide"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/JUMP-2014.06.07_DIG_FUTBOL-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12048" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/digs-baton-rouge-world-cup-watch-guide/">DIG&#8217;s Baton Rouge World Cup Watch Guide</a></h6></div></article><article class="post-12262 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/red-stick-roller-derby-baton-rouge-bittersweet/" title="BITTERSWEET"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/06/roller-derby-1-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="12265" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/red-stick-roller-derby-baton-rouge-bittersweet/">BITTERSWEET</a></h6></div></article><article class="post-49342 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/fargas-finished-lsu-womens-basketball-needs-to-move-past-coaching-regime/" title="Fargas finished? LSU women&#8217;s basketball needs to move past coaching regime"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2016/03/Fargas-1-e1457541734999-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="49344" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/fargas-finished-lsu-womens-basketball-needs-to-move-past-coaching-regime/">Fargas finished? LSU women&#8217;s basketball needs to move past coaching regime</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-48120 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/diamonds-in-the-rough/" title="Diamonds in the Rough"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2016/02/Jacob-Hester-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="48123" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/diamonds-in-the-rough/">Diamonds in the Rough</a></h6></div></article><article class="post-28505 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/making-moves-taking-risks/" title="Making Moves, Taking Risks"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2015/03/Jimmy-Graham-80x60.png" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="28506" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/making-moves-taking-risks/">Making Moves, Taking Risks</a></h6></div></article><article class="post-48066 post type-post status-publish format-standard has-post-thumbnail hentry category-sports-lsu category-sports"><div class="entry-image"> <a href="https://digbr.com/talkin-tigers-antonio-blakeney/" title="Talkin&#8217; Tigers: Antonio Blakeney"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2016/02/Antonio-Blakeney-OU-e1454513121631-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="48067" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/talkin-tigers-antonio-blakeney/">Talkin&#8217; Tigers: Antonio Blakeney</a></h6></div></article></div><div class="gridlove-posts-widget-item-wrapper"><article class="post-16280 post type-post status-publish format-standard has-post-thumbnail hentry category-outdoors category-sports"><div class="entry-image"> <a href="https://digbr.com/shooting-time-teal-season-in-the-blind/" title="Shooting Time, Teal Season: in the Blind"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/09/Teal-Hunt-2-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="16281" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/shooting-time-teal-season-in-the-blind/">Shooting Time, Teal Season: in the Blind</a></h6></div></article><article class="post-18404 post type-post status-publish format-standard has-post-thumbnail hentry category-outdoors category-sports tag-andrew-alexander tag-angola-prison-rodeo"><div class="entry-image"> <a href="https://digbr.com/cattle-and-convicts/" title="Cattle and Convicts"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/10/Angola-copy-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="18406" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/cattle-and-convicts/">Cattle and Convicts</a></h6></div></article><article class="post-11545 post type-post status-publish format-standard has-post-thumbnail hentry category-sports"><div class="entry-image"> <a href="https://digbr.com/redstickrollerderby-tragiccity-girlsontherun/" title="JAMMING"> <img width="80" height="60" src="https://digbr.com/wp-content/uploads/2014/05/DSC_0087_online-80x60.jpg" class="attachment-gridlove-thumbnail size-gridlove-thumbnail wp-post-image" alt="" data-wp-pid="11547" nopin="nopin" /> </a></div><div class="entry-header"><h6><a href="https://digbr.com/redstickrollerderby-tragiccity-girlsontherun/">JAMMING</a></h6></div></article></div></div></div></div></div><div class="gridlove-sidebar-action-overlay"></div> <script type="text/javascript" alt='evo_map_styles'>var gmapstyles = 'default';</script> <div id="fb-root"></div> <script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=713095298769737";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MW6NQMQ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>  <script>jQuery(document)
	.on('ready', function(){
		if(jQuery('body').is('.home')){
			setTimeout(function(){
				window.location.reload(1);
			}, 1800000);
		}
	});</script> <script type="text/javascript">var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;</script> <div class='evo_lightboxes' style='display:block'><div class='evo_lightbox eventcard eventon_events_list' id='' ><div class="evo_content_in"><div class="evo_content_inin"><div class="evo_lightbox_content"> <a class='evolbclose '>X</a><div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'></div></div></div></div></div></div> <script type="text/javascript">var wc_product_block_data = JSON.parse( decodeURIComponent( '%7B%22min_columns%22%3A1%2C%22max_columns%22%3A6%2C%22default_columns%22%3A3%2C%22min_rows%22%3A1%2C%22max_rows%22%3A6%2C%22default_rows%22%3A1%2C%22thumbnail_size%22%3A300%2C%22placeholderImgSrc%22%3A%22https%3A%5C%2F%5C%2Fdigbr.com%5C%2Fwp-content%5C%2Fuploads%5C%2Fwoocommerce-placeholder-600x600.png%22%2C%22min_height%22%3A500%2C%22default_height%22%3A500%2C%22isLargeCatalog%22%3Afalse%2C%22limitTags%22%3Afalse%2C%22hasTags%22%3Atrue%2C%22productCategories%22%3A%5B%7B%22term_id%22%3A901%2C%22name%22%3A%22Uncategorized%22%2C%22slug%22%3A%22uncategorized%22%2C%22term_group%22%3A0%2C%22term_taxonomy_id%22%3A901%2C%22taxonomy%22%3A%22product_cat%22%2C%22description%22%3A%22%22%2C%22parent%22%3A0%2C%22count%22%3A0%2C%22filter%22%3A%22raw%22%2C%22link%22%3A%22https%3A%5C%2F%5C%2Fdigbr.com%5C%2Fproduct-category%5C%2Funcategorized%5C%2F%22%7D%2C%7B%22term_id%22%3A255%2C%22name%22%3A%22DIG%27s%20Painting%20%26amp%3B%20Pinot%20Party%22%2C%22slug%22%3A%22digs-painting-pinot-party%22%2C%22term_group%22%3A0%2C%22term_taxonomy_id%22%3A262%2C%22taxonomy%22%3A%22product_cat%22%2C%22description%22%3A%22%22%2C%22parent%22%3A0%2C%22count%22%3A0%2C%22filter%22%3A%22raw%22%2C%22link%22%3A%22https%3A%5C%2F%5C%2Fdigbr.com%5C%2Fproduct-category%5C%2Fdigs-painting-pinot-party%5C%2F%22%7D%2C%7B%22term_id%22%3A225%2C%22name%22%3A%22Holiday%20Cocktail%20Competition%22%2C%22slug%22%3A%22holiday-cocktail-competition%22%2C%22term_group%22%3A0%2C%22term_taxonomy_id%22%3A232%2C%22taxonomy%22%3A%22product_cat%22%2C%22description%22%3A%22%22%2C%22parent%22%3A0%2C%22count%22%3A1%2C%22filter%22%3A%22raw%22%2C%22link%22%3A%22https%3A%5C%2F%5C%2Fdigbr.com%5C%2Fproduct-category%5C%2Fholiday-cocktail-competition%5C%2F%22%7D%2C%7B%22term_id%22%3A300%2C%22name%22%3A%22Ticketed%20Event%22%2C%22slug%22%3A%22ticketed-event%22%2C%22term_group%22%3A0%2C%22term_taxonomy_id%22%3A300%2C%22taxonomy%22%3A%22product_cat%22%2C%22description%22%3A%22%22%2C%22parent%22%3A0%2C%22count%22%3A1%2C%22filter%22%3A%22raw%22%2C%22link%22%3A%22https%3A%5C%2F%5C%2Fdigbr.com%5C%2Fproduct-category%5C%2Fticketed-event%5C%2F%22%7D%2C%7B%22term_id%22%3A217%2C%22name%22%3A%22Tigerland%20Bar%20Crawl%22%2C%22slug%22%3A%22tigerland-bar-crawl%22%2C%22term_group%22%3A0%2C%22term_taxonomy_id%22%3A224%2C%22taxonomy%22%3A%22product_cat%22%2C%22description%22%3A%22%22%2C%22parent%22%3A0%2C%22count%22%3A0%2C%22filter%22%3A%22raw%22%2C%22link%22%3A%22https%3A%5C%2F%5C%2Fdigbr.com%5C%2Fproduct-category%5C%2Ftigerland-bar-crawl%5C%2F%22%7D%5D%2C%22homeUrl%22%3A%22https%3A%5C%2F%5C%2Fdigbr.com%5C%2F%22%7D' ) );</script> <script type='text/javascript'>var evoli_ajax_script = {"evoli_ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php","postnonce":"c721ce675d"};</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/digbr.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript'>var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};</script> <script type='text/javascript'>var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_9594c994d9839b12c818afc3d1a0f6be","fragment_name":"wc_fragments_9594c994d9839b12c818afc3d1a0f6be","request_timeout":"5000"};</script> <script type='text/javascript'>var gridlove_js_settings = {"rtl_mode":"","header_sticky":"1","header_sticky_offset":"10","header_sticky_up":"","logo":"https:\/\/digbr.com\/wp-content\/uploads\/2018\/02\/DIG-Logo-white-sm.png","logo_retina":"https:\/\/digbr.com\/wp-content\/uploads\/2018\/02\/DIG-Logo-white-ret.png","logo_mini":"https:\/\/digbr.com\/wp-content\/uploads\/2018\/02\/DIG-Logo-white-mini2.png","logo_mini_retina":"","gridlove_gallery":"1"};</script> <script type='text/javascript'>var the_ajax_script = {"ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php","postnonce":"289aab0395"};</script> <script type='text/javascript' src='https://maps.googleapis.com/maps/api/js?ver=1.0'></script> <script type='text/javascript'>var mc4wp_vars = {"ajaxurl":"https:\/\/digbr.com\/wp-admin\/admin-ajax.php","ajax_loader_url":"https:\/\/digbr.com\/wp-content\/plugins\/mailchimp-for-wp-pro\/assets\/img\/ajax-loader.gif"};</script>    <script type="text/javascript" defer src="https://digbr.com/wp-content/cache/autoptimize/js/autoptimize_cadf66ccb2dafe571fd3662df809dec1.js"></script></body></html>